Topic
  • 6 replies
  • Latest Post - ‏2014-07-08T08:31:05Z by fromano
adot
adot
1 Post

Pinned topic Error restoring Installation Manager state

‏2010-06-02T20:36:11Z |
I had first insalled/ un-installed RAD - 7.0. it installed/ unistalled correctly.
During my attempt at reinstalling RAD7.5.3 I am having an issue. When I click on Install IBM Rational application Developer for Websphere software, it abruptly stops giving me the

Error restoring Installation Manager state. On clicking the details, it says
Error restoring Installation Manager state
Install registry has incompatible version 0.0.4; expected http://0.0.2,0.0.3

Any clue?
Thanks,
Adot.
Updated on 2012-11-29T08:05:01Z at 2012-11-29T08:05:01Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1807 Posts

    Re: Error restoring Installation Manager state

    ‏2010-06-09T20:14:00Z  
    It looks like the Installation Manager 1.3.4.1 installation manager was started by not installed. This can happen if you downloaded a product that had a newer version of the Installation Manager but then canceled out. You can fix this by going back to the place where you started this Installation Manager and simply installing the Installation Manager (it is not required to install any products).

    Alternatively you can download the Installation Manager 1.3.4.1 as described on this page: http://www-01.ibm.com/support/docview.wss?uid=swg24026310 towards the bottom you will see a table that has the processor specific .zip files. Download the appropriate one, unzip and run install(.exe)
  • deetomar
    deetomar
    1 Post

    Re: Error restoring Installation Manager state

    ‏2012-05-25T23:01:52Z  
    There have been errors like as below.
    Error restoring Installation Manager State
    Install registry has incompatible version 1.4.4; expected http://0.0.2,0.0.3

    Steps for resolutions -
    1. Clean the IBM folders for the installation managers. (There will be a struggle in case IBM installation manager was not uninstalled properly due to some interruptions or hard delete of the file.) In cases, may need to clean for IBM products to get installation manager installed again. Check the C:\Documents and Settings\All Users\Application Data\IBM for the Installation Manager and delete it before installing again or silent install again.

    2. Download the upgraded installation manager from IBM sites, there are many references to that and run the below silent install.
    installc --launcher.ini silent-install.ini -log c:\mylogfile.xml
    or
    installc -acceptLicense -showVerboseProgress --launcher.ini silent-install.ini -log c:\mylogfile.xml

    3. Try running downloading the product like in my RAD 7.5.4 and it should help to get installation manager through.
  • SystemAdmin
    SystemAdmin
    1807 Posts

    Re: Error restoring Installation Manager state

    ‏2012-11-29T08:05:01Z  
    Error restoring Installation Manager state
    Installation data has incompatible version 1.5.2; expected http://0.0.2,0.0.3. Newer version of the Installation Manager was used on this system.

    On a windows server 2008 machine go to the location "C:\ProgramData\IBM" in windows explorer and rename the folder "Installation Manager" to something else. Now launch the launchpad in the CCRC image. Installation would be successful.
  • Naveenmaddi
    Naveenmaddi
    2 Posts

    Re: Error restoring Installation Manager state

    ‏2013-07-31T10:01:32Z  
    Error restoring Installation Manager state
    Installation data has incompatible version 1.5.2; expected http://0.0.2,0.0.3. Newer version of the Installation Manager was used on this system.

    On a windows server 2008 machine go to the location "C:\ProgramData\IBM" in windows explorer and rename the folder "Installation Manager" to something else. Now launch the launchpad in the CCRC image. Installation would be successful.

    Hii,

    i have installed RAA 6.1, for that i installed IBM installation manger 1.5.2 . every thing went well. now i want to uninstall RAA but my Installation manager showing below error :

     Installation data has incompatible version 1.6.2; expected 1.5.2. Newer version of the Installation Manager was used on this system.

    I am not able to uninstall IBM installation manager, RAA . i am attaching the pic of the error for your reference.

    Attachments

  • Naveenmaddi
    Naveenmaddi
    2 Posts

    Re: Error restoring Installation Manager state

    ‏2013-07-31T10:06:13Z  
    Error restoring Installation Manager state
    Installation data has incompatible version 1.5.2; expected http://0.0.2,0.0.3. Newer version of the Installation Manager was used on this system.

    On a windows server 2008 machine go to the location "C:\ProgramData\IBM" in windows explorer and rename the folder "Installation Manager" to something else. Now launch the launchpad in the CCRC image. Installation would be successful.

    Hii,

    i have installed RAA 6.1, for that i installed IBM installation manger 1.5.2 . every thing went well. now i want to uninstall RAA but my Installation manager showing below error :

     Installation data has incompatible version 1.6.2; expected 1.5.2. Newer version of the Installation Manager was used on this system.

    I am not able to uninstall IBM installation manager, RAA . i am attaching the pic of the error for your reference.

    Attachments

  • fromano
    fromano
    1 Post

    Re: Error restoring Installation Manager state

    ‏2014-07-08T08:31:05Z  

    Hii,

    i have installed RAA 6.1, for that i installed IBM installation manger 1.5.2 . every thing went well. now i want to uninstall RAA but my Installation manager showing below error :

     Installation data has incompatible version 1.6.2; expected 1.5.2. Newer version of the Installation Manager was used on this system.

    I am not able to uninstall IBM installation manager, RAA . i am attaching the pic of the error for your reference.

    Today I had the same error when installing Process Designer 8.0.1.2 (previous version: 8.0.1.1) on Windows 7 by running installProcessDesigner_admin.bat.
     
    Complete error was:
    "ERROR: Error restoring Installation Manager state.
     ERROR:   Installation data has incompatible version 1.6.2; expected 1.6.0. Newer version of the Installation Manager was used on this system."
     
    Installing latest version of IM did not help. The solution was to right click the installation file and 'Run as administrator'