Topic
  • 5 replies
  • Latest Post - ‏2010-08-12T11:37:37Z by JonathanPLawrence
Rajyalakshmi
Rajyalakshmi
3 Posts

Pinned topic Problem in the installation of CA1S Support Pac

‏2010-05-26T10:48:00Z |
SupportPac CA1Sv1.1:REST support in CICs using PHP installed in CICS v3.2 with z/OS v1.9 is giving error as "HTTP 500 - Internal server error" while trying to run the HelloCICS.php which is the installation verification process of this SupportPac, the error is not even reaching the CICS as it is throwing no error message in the CICS Log.

We are trying to bring it with the java v1.4.2.Is it ok to run this supportPac in JAVA v 1.4.2 or is the Java 1.5 is
mandatory and it has something to do with the "HTTP 500 - Internal
server error" error.

Also we are installing this as a replacement of the DB2 Connect to access the data base is this a right solution?

Note: All the prerequisites are satisfied.

Can someone help on this?

Thanks in advance..
Updated on 2010-08-12T11:37:37Z at 2010-08-12T11:37:37Z by JonathanPLawrence
  • SystemAdmin
    SystemAdmin
    23 Posts

    Re: Problem in the installation of CA1S Support Pac

    ‏2010-05-28T10:44:14Z  
    Hi,

    Java 5.0sr8 is the minimum level of Java required by SupportPac CA1S. For the full list of pre-reqs, please see section 2.2 of the CA1S manual here:
    ftp://ftp.software.ibm.com/software/htp/cics/support/supportpacs/individual/ca1s.pdf
    Robin Fernandes
    PHP runtime development
  • Rajyalakshmi
    Rajyalakshmi
    3 Posts

    Re: Problem in the installation of CA1S Support Pac

    ‏2010-06-02T12:49:13Z  
    Hi,

    Java 5.0sr8 is the minimum level of Java required by SupportPac CA1S. For the full list of pre-reqs, please see section 2.2 of the CA1S manual here:
    ftp://ftp.software.ibm.com/software/htp/cics/support/supportpacs/individual/ca1s.pdf
    Robin Fernandes
    PHP runtime development
    Hi Robin,

    Thanks for the information,

    Actually we have java v1.4.2 with the PTF PK59577 applid so i think this is enough for the CA1S support pac.Is it?

    We refered the pdf for the installation aslo we have satisfied all the requirement.

    Now we are getting the problem as "HTTP 500 - Internal server error" on trying to invoke the HelloCICS.php in the browser.

    According to my understanding this error will be logged in he JVM
    standard error log.But the path is empty what will be the reason for it? Are we missing here something

    Also the cics log is not getting any error message also.

    And also is the XMLtool Kit have something to do with this suppoar pac, is it a mandatory one.

    So we are stuck at this point, can you help on this..
  • JonathanPLawrence
    JonathanPLawrence
    30 Posts

    Re: Problem in the installation of CA1S Support Pac

    ‏2010-06-02T13:39:45Z  
    Hi Robin,

    Thanks for the information,

    Actually we have java v1.4.2 with the PTF PK59577 applid so i think this is enough for the CA1S support pac.Is it?

    We refered the pdf for the installation aslo we have satisfied all the requirement.

    Now we are getting the problem as "HTTP 500 - Internal server error" on trying to invoke the HelloCICS.php in the browser.

    According to my understanding this error will be logged in he JVM
    standard error log.But the path is empty what will be the reason for it? Are we missing here something

    Also the cics log is not getting any error message also.

    And also is the XMLtool Kit have something to do with this suppoar pac, is it a mandatory one.

    So we are stuck at this point, can you help on this..
    Hi Rajya,

    No, the minimum Java level is Java 5.0 SR8 (this is Java 1.5.0), so your Java 1.4.2 installation will not be adequate.

    What I would recommend for CA1S SupportPac installation, is that you first verify your Java in CICS by installing Java 5.0 SR8 and running the simple CICS Java samples (HelloCICS etc.) before attempting to install CA1S.

    The SupportPac relies on a correct Java level and configuration; if you get that right first you are in a much better position when it comes to the SupportPac.

    Jonathan Lawrence
    PHP Runtime Development
  • Rajyalakshmi
    Rajyalakshmi
    3 Posts

    Re: Problem in the installation of CA1S Support Pac

    ‏2010-06-04T16:55:35Z  
    Hi Rajya,

    No, the minimum Java level is Java 5.0 SR8 (this is Java 1.5.0), so your Java 1.4.2 installation will not be adequate.

    What I would recommend for CA1S SupportPac installation, is that you first verify your Java in CICS by installing Java 5.0 SR8 and running the simple CICS Java samples (HelloCICS etc.) before attempting to install CA1S.

    The SupportPac relies on a correct Java level and configuration; if you get that right first you are in a much better position when it comes to the SupportPac.

    Jonathan Lawrence
    PHP Runtime Development
    Hi Jonathan,

    Thanks for it, now we are getting an error like,

    DFHPI0002 C1CICST5 A severe error (code X'0508') has occurred in module DFHPITH.

    And also in the browser its giving the error as,

    XML Parsing error: no element found
    Location:
    Line Number 1 , Column 1

    Where we are going wrong, can someone help us.

    Thanks,

    Raji
  • JonathanPLawrence
    JonathanPLawrence
    30 Posts

    Re: Problem in the installation of CA1S Support Pac

    ‏2010-08-12T11:37:37Z  
    Hi Jonathan,

    Thanks for it, now we are getting an error like,

    DFHPI0002 C1CICST5 A severe error (code X'0508') has occurred in module DFHPITH.

    And also in the browser its giving the error as,

    XML Parsing error: no element found
    Location:
    Line Number 1 , Column 1

    Where we are going wrong, can someone help us.

    Thanks,

    Raji
    Hi Raji,

    Are you still experiencing problems installing the CA1S SupportPac, or have you resolved your issues now?

    Jonathan Lawrence
    CICS PHP Runtimes development