Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
6 replies Latest Post - ‏2013-03-15T11:15:04Z by SystemAdmin
KrzysztofMejka
KrzysztofMejka
5 Posts
ACCEPTED ANSWER

Pinned topic Connection error

‏2010-05-19T15:55:26Z |
Hello
I'm trying to deploy the trial version of ClearQuest on my computer (Windows XP SP3) for a student project. I've got the free version of IBM DB2 (Express-C version). So far I was able to succesfully configure a database (using the info from the IBM Information Center), create a repository in the database (using the maintenance tool), connect to the repo in the CQ Designer and add some users. However I can't seem to be able to connect to CQ using the Client or in the web application. I've checked in the database, and the users are there. But when I try to connect to CQ all I get is "ClearQuest login of user: This login is forbidden: Invalid Credentials: Either the login name or the password is incorrect." Could someone help me with that? I can log in using a certain username (not "admin") to the CQ Designer, but not to CQ Web or CQ Client.
Updated on 2013-03-15T11:15:04Z at 2013-03-15T11:15:04Z by SystemAdmin
  • KrzysztofMejka
    KrzysztofMejka
    5 Posts
    ACCEPTED ANSWER

    Re: Connection error

    ‏2010-05-19T16:01:25Z  in response to KrzysztofMejka
    Oh I forgot one thing, I have of course created a user database in the schema repository. Thanks in advance for any help!
  • SystemAdmin
    SystemAdmin
    24948 Posts
    ACCEPTED ANSWER

    Re: Connection error

    ‏2010-05-26T20:10:19Z  in response to KrzysztofMejka
    Did you import the user from another repository or restored the user datanase from another user database, or move the database from another server?

    Jay Cheng
    • KrzysztofMejka
      KrzysztofMejka
      5 Posts
      ACCEPTED ANSWER

      Re: Connection error

      ‏2010-05-26T22:16:26Z  in response to SystemAdmin
      Non of the above. I created a new database from scratch, new repository, new users.
      • SystemAdmin
        SystemAdmin
        24948 Posts
        ACCEPTED ANSWER

        Re: Connection error

        ‏2010-05-27T05:59:55Z  in response to KrzysztofMejka
        Seems you have not upgraded the database. After user creation certainly you have to upgrade the database if you don't you can able to login to schema repo not in user database.

        Login to CQ Administrator --> DB Action --> Upgrade and select the database which you want to work.

        -Anand.
        • KrzysztofMejka
          KrzysztofMejka
          5 Posts
          ACCEPTED ANSWER

          Re: Connection error

          ‏2010-05-27T11:27:43Z  in response to SystemAdmin
          Wow I didn't know that :). Thank you very much that solved the problem. And what exactly does "upgrading the database" do?
        • SystemAdmin
          SystemAdmin
          24948 Posts
          ACCEPTED ANSWER

          Re: Connection error

          ‏2013-03-15T11:15:04Z  in response to SystemAdmin
          I performed a fresh install of the version 7.1.2 and I (now) think the SAMPL database version is 7.0.0.
          So, I didn't expect to be necessary to upgrade it.
          It worked for me.

          Thank you,
          Ricardo Bernardino