• 3 replies
  • Latest Post - ‏2011-05-16T17:08:39Z by urkanstasr
147 Posts

Pinned topic Tau doesn't recognize the C header file location

‏2010-05-05T17:20:09Z |
I'm trying to build the umlcpphellowordl example in Tau 4.3 but I get the following error:

HelloWorld.ttp Information c1.cpp
HelloWorld.ttp Information c1.cpp(1) : fatal error C1083: Cannot open include file: 'iostream': No such file or directory
HelloWorld.ttp Error NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\bin\cl.EXE"' : return code '0x2'
HelloWorld.ttp Information Stop.
HelloWorld.ttp Information TAB0054: Make execution finished - 1 Error(s), 0

I'm using Visual Studio Professional edition v9.0 on windows 7,I checked the path variables to make sure it's correct , VSdir..\VC\include;VSdir..\VC\bin. Tau doesn't recognize the header file location <iostream>.

I don't know what's wrong

Can anybody help me?

Updated on 2011-05-16T17:08:39Z at 2011-05-16T17:08:39Z by urkanstasr
  • SystemAdmin
    147 Posts

    Re: Tau doesn't recognize the C header file location

    This is almost certainly a problem with the setup of the environment for the compiler - something to do with the include paths probably.

    I can build artifact1 using VS2005 without any problem. I don't have VS9 to try this with.

    I make sure the environment is setup using the method I described in this thread: where I have a desktop shortcut which first runs the microsoft batch file to configure the environment variables and then launches Tau. NOTE You will probably have to modify the path to the microsoft batch file shown in that thread because you are using a different version of VS. This method should be foolproof.

    If instead you have manually configured the environment variables, make sure you can compile and link a simple C++ hello world which includes <iostream.h> from the command line. Until you can do this there isn't any point trying to build from TAU.

  • SystemAdmin
    147 Posts

    Re: Tau doesn't recognize the C header file location


    I tried to install Visual Studio 2008 and 2005 with Tau 4.3 in different operating systems like windows xp, windows server 2003 and windows 7.I launched vsvars32.bat before execute vcs.exe or the batch file posted in the rational forum but I get the same error <iostream> no such file or directory.

    Start of Batch Script
    :: tau.bat
    @echo off
    call "C:\VisualStudio\Common7\Tools\vsvars32.bat"
    @echo off

    End of Batch Script
    Independently of tau,I can compile makefile.mak (it was generated previously) by command shell and it works (I see the hello world when I run application.exe).
    I compile the makefile using C:> nmake /F Directory\makefile.mak

    I'm very frustrated :(

    What can I do??

  • urkanstasr
    1 Post

    Re: Tau doesn't recognize the C header file location