Topic
2 replies Latest Post - ‏2010-05-10T18:59:42Z by chwilk
null
null
11 Posts
ACCEPTED ANSWER

Pinned topic PAPI for Power7 and 2.6.32 kernels?

‏2010-05-04T18:41:59Z |
How do I setup PAPI on a 2.6.32 kernel running on a P7 system?
Updated on 2010-05-10T18:59:42Z at 2010-05-10T18:59:42Z by chwilk
  • SystemAdmin
    SystemAdmin
    706 Posts
    ACCEPTED ANSWER

    Re: PAPI for Power7 and 2.6.32 kernels?

    ‏2010-05-06T18:20:14Z  in response to null
    Various versions of PAPI are available for download here:

    http://icl.cs.utk.edu/papi/software/index.html

    Both PAPI classic, version 3.7.2 and Component PAPI, version 4.0.x should work fine with 2.6.32 on Power7. There are installation instructions on the web page shown above.
  • chwilk
    chwilk
    5 Posts
    ACCEPTED ANSWER

    Re: PAPI for Power7 and 2.6.32 kernels?

    ‏2010-05-10T18:59:42Z  in response to null
    One gotcha I ran into with my PAPI setup was with a deprecated kernel config option.

    The kernel's pseries_defconfig setup does not set the PERF_COUNTERS, instead using the new terminology, and defining PERF_EVENTS and HAVE_PERF_EVENTS. Papi checks for the older config option, and blocks a compile at that point (at least as of the 3.7.2 release)

    --
    Chandler Wilkerson
    Rice University