Topic
1 reply Latest Post - ‏2010-10-26T15:23:52Z by JFerrer
mgammie
mgammie
7 Posts
ACCEPTED ANSWER

Pinned topic Migration :: Known limitation

‏2010-04-20T13:29:20Z |
UML migration

Rational Software Architect v8.0 beta models are not supported in earlier product versions, for example, version 7.5.5.

Workaround: Make sure that you back up all the models that you plan to migrate to the Rational Software Architect v8.0 Beta 1 format.

Migrating diagram fragments

When using the beta version, you must manually migrate diagram fragments. If fragmented diagrams are migrated automatically, an empty diagram label/icon is displayed in the Project Explorer view and the diagram fragment will be deleted when its parent resource (the model itself or the parent fragment) is updated and saved. (Diagrams that you fragment in the 8.0 beta itself are fine. Also, all other kinds of fragments from a previous version are fine - this issue only affects diagram fragments.)

Workaround: Prior to migration, absorb diagram fragments in 7.5.x. The easiest way to do so is to check the Diagrams virtual folder in Project Explorer view. This view shows the flat list of diagrams and fragmented diagrams clearly marked. Once the model is migrated to 8.0 beta, it is safe to re-fragment the desired diagrams.

You can also use two pluglet projects to automate this workaround. You can download both compressed files and follow the instructions in the readme file to migrate your v7.5.x models to the v8.0 beta format. For detailed information, visit the Rational Software Architect product Wiki page at https://www.ibm.com/developerworks/wikis/display/RSA/RSA+v8+Beta.


Edited by: mgammie_admin on Apr 22, 2010 6:35 PM
Updated on 2010-10-26T15:23:52Z at 2010-10-26T15:23:52Z by JFerrer
  • JFerrer
    JFerrer
    1 Post
    ACCEPTED ANSWER

    Re: Migration :: Known limitation

    ‏2010-10-26T15:23:52Z  in response to mgammie
    Rational Software Architect v8.0 beta models are not supported in earlier product versions, for example, version 7.5.5.

    Still limited? i need to recover with v7 an .emx file made with v8