Topic
4 replies Latest Post - ‏2012-04-24T18:06:36Z by Rav81
vmatcha
vmatcha
1 Post
ACCEPTED ANSWER

Pinned topic org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid

‏2010-04-15T20:41:22Z |
Hey All,

i need some help, here is the problem.
I am trying to connect PE through java console applicatin but i am getting following eoor message.
Please help me:
org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid: 0x49421000 minor code: 42

My System.
FileNet P8 4.5, WebSphere 6.1 and Unix.

My Java Code;
Code:

String userName = "XXXX";
String password = "XXXX";
String connectionPoint = "PEConnectionPoint";

System.setProperty("java.naming.factory.initial", "com.ibm.websphere.naming.WsnInitialContextFactory");
System.setProperty( "java.naming.provider.url","iiop://server:port/FileNet/Engine" );
System.setProperty("java.security.auth.login.config", "C:/Data/Login Config/jaas.conf.WebSphere" );

filenet.vw.api.VWSession myPESession = new filenet.vw.api.VWSession();
myPESession.setBootstrapCEURI("iiop://server:port/FileNet/Engine");
try {

myPESession.logon(userName, password, connectionPoint);
}
catch (VWException vwe) {
vwe.printStackTrace();
}

Exception Message
Code:
log4j:WARN The log4j system is not properly configured!
log4j:WARN All ERROR messages will be sent to the system console until proper configuration has been detected.
com.filenet.api.exception.EngineRuntimeException: E_UNEXPECTED: An unexpected error occurred.
at filenet.pe.ceutils.ConnectionPoints.run(ConnectionPoints.java:505)
at filenet.pe.ceutils.ConnectionPoints.runEx(ConnectionPoints.java:442)
at filenet.pe.ceutils.ConnectionPoints.GetAConnectionPointFromACPName(ConnectionPoints.java:790)
at filenet.pe.ceutils.ConnectionPoints.GetConnectionPointFromCPURI(ConnectionPoints.java:376)
at filenet.pe.ceutils.ConnectionPoints.GetConnectionPointFromBootstrapURI(ConnectionPoints.java:424)
at filenet.pe.peorb.client.ORBSession.getConnectionPoint(ORBSession.java:793)
at filenet.pe.peorb.client.ORBSession.getJAASContext(ORBSession.java:733)
at filenet.pe.peorb.client.ORBSession.establishORBSession(ORBSession.java:642)
at filenet.pe.peorb.client.ORBSession.<init>(ORBSession.java:985)
at filenet.vw.server.PECommandsFactory.getPECommands(PECommandsFactory.java:119)
at filenet.vw.api.VWSession.logonByDomain(VWSession.java:811)
at filenet.vw.api.VWSession.logon(VWSession.java:670)
at VWsession1.main(VWsession1.java:28)
Caused by: com.filenet.api.exception.EngineRuntimeException: E_UNEXPECTED: An unexpected error occurred.
at com.filenet.apiimpl.transport.ejb.EJBSession.throwException(EJBSession.java:706)
at com.filenet.apiimpl.transport.ejb.EJBSession$EJBImpl._getObjects(EJBSession.java:492)
at com.filenet.apiimpl.transport.ejb.EJBSession$EJBImpl.run(EJBSession.java:333)
at java.security.AccessController.doPrivileged(AccessController.java:279)
at javax.security.auth.Subject.doAs(Subject.java:573)
at com.ibm.websphere.security.auth.WSSubject.doAs(WSSubject.java:168)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:618)
at com.filenet.apiimpl.util.J2EEUtilWS.doAs(J2EEUtilWS.java:215)
at com.filenet.apiimpl.transport.ejb.EJBSession$EJBImpl.getObjects(EJBSession.java:375)
at com.filenet.apiimpl.transport.ejb.EJBSession.getObjects(EJBSession.java:299)
at com.filenet.apiimpl.util.SessionHandle.getObjects(SessionHandle.java:334)
at com.filenet.apiimpl.core.Session.callGetObjects(Session.java:121)
at com.filenet.apiimpl.core.Session.executeGetObject(Session.java:325)
at com.filenet.apiimpl.core.Session.getObject(Session.java:339)
at com.filenet.apiimpl.core.IndependentObjectImpl.getObject(IndependentObjectImpl.java:154)
at com.filenet.apiimpl.core.IndependentObjectImpl.refresh(IndependentObjectImpl.java:161)
at com.filenet.api.core.Factory$Domain.fetchInstance(Factory.java:1543)
at filenet.pe.ceutils.ConnectionPoints.run(ConnectionPoints.java:467)
... 12 more
Caused by: java.rmi.RemoteException: CORBA NO_IMPLEMENT 0x49421042 No; nested exception is:
org.omg.CORBA.NO_IMPLEMENT:
>> SERVER (id=11c328fe, host=xxxxxx) TRACE START:
>> org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid: 0x49421000 minor code: 42 completed: No
>> at com.ibm.ws.cluster.router.selection.WLMLSDRouter.select(WLMLSDRouter.java:314)
>> at com.ibm.ws.cluster.router.selection.WLMLSDRouter.getNextTarget(WLMLSDRouter.java:216)
>> at com.ibm.ws.cluster.router.selection.WLMClientForCommonRouterImpl.getNextTarget(WLMClientForCommonRouterImpl.java:306)
>> at com.ibm.ws.wlm.client.WLMClient.getNextTarget(WLMClient.java:202)
>> at com.ibm.ws.orbimpl.services.lsd.LocationServiceDaemon.getDirectIOR(LocationServiceDaemon.java:197)
>> at com.ibm.rmi.iiop.Connection.respondTo(Connection.java:2689)
>> at com.ibm.rmi.iiop.Connection.doWork(Connection.java:2582)
>> at com.ibm.rmi.iiop.WorkUnitImpl.doWork(WorkUnitImpl.java:62)
>> at com.ibm.ejs.oa.pool.PooledThread.run(ThreadPool.java:118)
>> at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1473)
>> SERVER (id=11c328fe, host=XXXXX) TRACE END.
vmcid: 0x49421000 minor code: 42 completed: No
at com.ibm.CORBA.iiop.UtilDelegateImpl.mapSystemException(UtilDelegateImpl.java:318)
at javax.rmi.CORBA.Util.mapSystemException(Util.java:84)
at com.filenet.apiimpl.transport.ejbstubs._EngineHome_Stub.create(Unknown Source)
at com.filenet.apiimpl.transport.ejb.EJBSession$EJBImpl.createEngineBean(EJBSession.java:514)
at com.filenet.apiimpl.transport.ejb.EJBSession$EJBImpl._getObjects(EJBSession.java:477)
... 31 more
Caused by: org.omg.CORBA.NO_IMPLEMENT:
>> SERVER (id=11c328fe, host=XXXXXX) TRACE START:
>> org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid: 0x49421000 minor code: 42 completed: No
>> at com.ibm.ws.cluster.router.selection.WLMLSDRouter.select(WLMLSDRouter.java:314)
>> at com.ibm.ws.cluster.router.selection.WLMLSDRouter.getNextTarget(WLMLSDRouter.java:216)
>> at com.ibm.ws.cluster.router.selection.WLMClientForCommonRouterImpl.getNextTarget(WLMClientForCommonRouterImpl.java:306)
>> at com.ibm.ws.wlm.client.WLMClient.getNextTarget(WLMClient.java:202)
>> at com.ibm.ws.orbimpl.services.lsd.LocationServiceDaemon.getDirectIOR(LocationServiceDaemon.java:197)
>> at com.ibm.rmi.iiop.Connection.respondTo(Connection.java:2689)
>> at com.ibm.rmi.iiop.Connection.doWork(Connection.java:2582)
>> at com.ibm.rmi.iiop.WorkUnitImpl.doWork(WorkUnitImpl.java:62)
>> at com.ibm.ejs.oa.pool.PooledThread.run(ThreadPool.java:118)
>> at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1473)
>> SERVER (id=11c328fe, host=XXXXXX) TRACE END.
vmcid: 0x49421000 minor code: 42 completed: No
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:67)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:522)
at com.ibm.rmi.iiop.ReplyMessage._getSystemException(ReplyMessage.java:242)
at com.ibm.rmi.iiop.ReplyMessage.getSystemException(ReplyMessage.java:190)
at com.ibm.rmi.iiop.ClientResponseImpl.getSystemException(ClientResponseImpl.java:232)
at com.ibm.rmi.corba.ClientDelegate.invoke(ClientDelegate.java:484)
at com.ibm.CORBA.iiop.ClientDelegate.invoke(ClientDelegate.java:1188)
at com.ibm.rmi.corba.ClientDelegate.invoke(ClientDelegate.java:768)
at com.ibm.CORBA.iiop.ClientDelegate.invoke(ClientDelegate.java:1218)
at org.omg.CORBA.portable.ObjectImpl._invoke(ObjectImpl.java:484)
... 34 more
if any one have any idea, please let me know.

Thank You.
Updated on 2012-04-24T18:06:36Z at 2012-04-24T18:06:36Z by Rav81
  • KVW
    KVW
    1 Post
    ACCEPTED ANSWER

    Re: org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid

    ‏2010-09-19T00:34:21Z  in response to vmatcha
    I'm having a very similar problem. Did you find anything?

    This happens while creating an initial context that points to another server:

    SERVER (id=11c328fe, host=HOB-W-DEV-APP4B) TRACE START:
    >> org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid: 0x49421000 minor code: 42 completed: No
    >> at com.ibm.ws.cluster.router.selection.WLMLSDRouter.select(WLMLSDRouter.java:314)
    >> at com.ibm.ws.cluster.propagation.ServerClusterContextListenerImpl.forwardRequest(ServerClusterContextListenerImpl.java:625)
    • Rav81
      Rav81
      2 Posts
      ACCEPTED ANSWER

      Re: org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid

      ‏2012-03-07T00:26:52Z  in response to KVW
      I'm having a similar issue while accessing a remote P8 Server. But, it works from one windows (2000) machine and not from another (Vista).

      I set: System.setProperty(Context.INITIAL_CONTEXT_FACTORY,"org.jnp.interfaces.NamingContextFactory");

      this.vwSession = new VWSession();
      this.vwSession.setBootstrapCEURI(this.p8ServerName);
      this.vwSession.logon(userId, userPwd, region);
      I get the following error:
      com.filenet.api.exception.EngineRuntimeException: API_UNEXPECTED_JNDI_ERROR: An unexpected error occured accessing JNDI. - com.filenet.api.exceptio
      n.EngineRuntimeException: API_UNEXPECTED_JNDI_ERROR: An unexpected error occured accessing JNDI.
      I can reproduce the same error by not setting the initial context in the other machine.

      Can anyone please tell me what is going on?

      Thanks.
      • WS3T_PowerOf_Hattusas
        1 Post
        ACCEPTED ANSWER

        Re: org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid

        ‏2012-03-27T18:16:12Z  in response to Rav81
        In your cell custom settings try the

        IBM_CLUSTER_CALLBACK_TIMEOUT to 5000 or similar value and IBM_CLUSTER_ENABLE_PRELOAD to false

        http://publib.boulder.ibm.com/infocenter/wasinfo/fep/topic/com.ibm.websphere.soafep.multiplatform.doc/info/ae/ae/ragt_cell_customprops.html

        HTH
        • Rav81
          Rav81
          2 Posts
          ACCEPTED ANSWER

          Re: org.omg.CORBA.NO_IMPLEMENT: No Cluster Data Available vmcid

          ‏2012-04-24T18:06:36Z  in response to WS3T_PowerOf_Hattusas
          I forgot to mention it in my issue that I am running it as a client in Vista.

          I installed Wire Shark and try to filter and see what request going to port 1199 in the remote machine.

          It seems like this issue happens even before that.

          I really appreciate any suggestions.

          Thanks
          RS