Topic
  • 1 reply
  • Latest Post - ‏2010-03-08T16:56:51Z by ishields
premlink
premlink
8 Posts

Pinned topic Disable process killed messages on serial console

‏2010-03-08T05:24:34Z |
Iam geting the process killed messages on my serial console.I dont want this to happen on running script stopcasc.

$ stopcasc
/usr/bin/casc: line 43: 2301 Killed ./casc

Sometimes even the command execution line comes on the serial console like

$set hour 12
./set_hour -t 12
Sat Mar 6 22:11:42 2010

In the syslog.conf file, I have redirected all the messages to a file.I still dont know why iam getting these message.I have searched and found that this may be because of the parent shell sending a message about its child script getting killed.Is there a way to disable this.

Also,is it possible to disable the kernel log messages like.There are lot of them coming on the screen.I have already commented KLOGD_OPTIONS="-x" in /etc/sysconfigs/syslog

Mar 6 22:05:45 localhost kernel: parport: PnPBIOS parport detected.

Prem,
Updated on 2010-03-08T16:56:51Z at 2010-03-08T16:56:51Z by ishields
  • ishields
    ishields
    988 Posts

    Re: Disable process killed messages on serial console

    ‏2010-03-08T16:56:51Z  
    Sounds like your serial console is the controlling terminal for whatever is emitting the messages. You probably need to determine where the output and error streams are directed and redirect them according to your needs. You may also find the nohup command useful. See our LPI exam prep articles
    "Create monitor and kill processes" (http://www.ibm.com/developerworks/linux/library/l-lpic1-v3-103-5/index.html) and
    "Streams pipes and redirects" (http://www.ibm.com/developerworks/linux/library/l-lpic1-v3-103-4/index.html)
    for help.

    Ian Shields