Topic
  • 8 replies
  • Latest Post - ‏2010-03-23T13:16:09Z by higby
pkpabr
pkpabr
4 Posts

Pinned topic Adobe Reader Installation on IBM AIX 5.3

‏2010-03-05T09:44:51Z |
Hi,

I was trying to install Adobe Reader 7 on IBM AIX 5.3. Installation went successfully. But when I am starting the reader as below I am getting the below errors. Could anyone let me know the correct version of dependant package?
Is there any licensed Adobe Reader software available for IBM AIX

  1. /usr/bin/acroread
exec(): 0509-036 Cannot load program /usr/lpp/Adobe/Acrobat7.0/Reader/rs6000aix/bin/acroread because of the following errors:
0509-150 Dependent module libgdk_pixbuf_xlib-2.0.a(libgdk_pixbuf_xlib-2.0.so.0) could not be loaded.
0509-022 Cannot load module libgdk_pixbuf_xlib-2.0.a(libgdk_pixbuf_xlib-2.0.so.0).
0509-026 System error: A file or directory in the path name does not exist.
Updated on 2010-03-23T13:16:09Z at 2010-03-23T13:16:09Z by higby
  • flodstrom
    flodstrom
    115 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-05T14:47:34Z  
    If my memory serves me correct you have to install the GTK libraries from the "AIX Toolbox for Linux Applications". As you might see from the errors it seem like GTK was used to build the Acroreader for AIX (...for whatever reason?).
  • MarkTaylor
    MarkTaylor
    230 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-05T14:49:06Z  
    http://forums.adobe.com/thread/395547

    HTH
    Mark Taylor
  • pkpabr
    pkpabr
    4 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-08T16:16:50Z  
    • flodstrom
    • ‏2010-03-05T14:47:34Z
    If my memory serves me correct you have to install the GTK libraries from the "AIX Toolbox for Linux Applications". As you might see from the errors it seem like GTK was used to build the Acroreader for AIX (...for whatever reason?).
    Hi,

    I have downloaded the gtk2 rpm form IBM Toolbox site. But when I am trying to install it, many dpenedent package error is being thrown.
    1. rpm -ivh gtk2-2.10.6-2.aix5.2.ppc.rpm
    error: failed dependencies:
    libpng is needed by gtk2-2.10.6-2
    libjpeg is needed by gtk2-2.10.6-2
    glib2 >= 2.12.4 is needed by gtk2-2.10.6-2
    atk >= 1.12.3 is needed by gtk2-2.10.6-2
    pango >= 1.14.5 is needed by gtk2-2.10.6-2
    xcursor >= 1.0.2 is needed by gtk2-2.10.6-2
    cairo >= 1.8.6 is needed by gtk2-2.10.6-2
    pixman >= 0.12.0 is needed by gtk2-2.10.6-2
    libXrender.a(libXrender.so.1) is needed by gtk2-2.10.6-2
    libatk-1.0.a(libatk-1.0.so.0) is needed by gtk2-2.10.6-2
    libcairo.a(libcairo.so.2) is needed by gtk2-2.10.6-2
    libfontconfig.a(libfontconfig.so.1) is needed by gtk2-2.10.6-2
    libglib-2.0.a(libglib-2.0.so.0) is needed by gtk2-2.10.6-2
    libgmodule-2.0.a(libgmodule-2.0.so.0) is needed by gtk2-2.10.6-2
    libgobject-2.0.a(libgobject-2.0.so.0) is needed by gtk2-2.10.6-2
    libjpeg.a(libjpeg.so.62) is needed by gtk2-2.10.6-2
    libpango-1.0.a(libpango-1.0.so.0) is needed by gtk2-2.10.6-2
    libpangocairo-1.0.a(libpangocairo-1.0.so.0) is needed by gtk2-2.10.6-2
    libpng12.a(libpng12.so.0) is needed by gtk2-2.10.6-2
    How to get this installed now?
  • pkpabr
    pkpabr
    4 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-08T16:19:11Z  
    Hi,

    I tried to download gtk2-2.8.3-9 as mentioned in the link, but I could find only gtk2-2.10.6-2.aix5.2.ppc.rpm in the IBM Tool box.

    Could you please let me know from where I can download the above package?
  • flodstrom
    flodstrom
    115 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-08T16:52:20Z  
    • pkpabr
    • ‏2010-03-08T16:19:11Z
    Hi,

    I tried to download gtk2-2.8.3-9 as mentioned in the link, but I could find only gtk2-2.10.6-2.aix5.2.ppc.rpm in the IBM Tool box.

    Could you please let me know from where I can download the above package?
    The thread you viewed is rather old so most if not all packages has been updated since. Use the higher version!

    GTK has a maze of dependencies so I would advice you to download the whole toolbox image rather than dowloading selected packages. It's somewhat easier when you have all on the same level instead of bits and pieces that may have other unexpected dependencies.
  • pkpabr
    pkpabr
    4 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-10T07:40:26Z  
    • flodstrom
    • ‏2010-03-08T16:52:20Z
    The thread you viewed is rather old so most if not all packages has been updated since. Use the higher version!

    GTK has a maze of dependencies so I would advice you to download the whole toolbox image rather than dowloading selected packages. It's somewhat easier when you have all on the same level instead of bits and pieces that may have other unexpected dependencies.
    Could you please let me know the gtk bundle which I need to install and also from where I can get theses.

    Is it available on IBM AIX cd's?
  • dkcc
    dkcc
    45 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-21T01:49:34Z  
    Hi,
    Have you gotten Acorbat7 installed and running?

    If not let me know and I will try and get a list of the
    current Linux toolkit modules that I am using to get it to
    work.

    Bye,
    Dwight

    P.S.
    I just completed a complete reinstall of AIX 5.3 on
    a 9114-275 and Acorbat7 and Acrobat5 seem to be working
    OK!
  • higby
    higby
    13 Posts

    Re: Adobe Reader Installation on IBM AIX 5.3

    ‏2010-03-23T13:16:09Z  
    I have found this website to very helpful. It seems to contain many packages and I've never had a problem with anything in it.

    Just select 'gtk2' on that site, and then select any of the versions that are available. I generally select the latest one. It will be a mess to try to download all of the dependencies one-by-one as they come up, primarily because you won't know the order, but if you're persistent, it can be done.

    http://www.oss4aix.org/download/RPMS/