Topic
  • 1 reply
  • Latest Post - ‏2013-03-13T17:46:22Z by SystemAdmin
rafajna
rafajna
1 Post

Pinned topic Informix IDS - ol_svr_custom - failed to start on windows

‏2010-02-11T01:28:28Z |
I installed iif.11.50.TC6DE on my computer for the first time. Went through all the installation steps. Everything looked fine until i tried to start the "Informix IDS - ol_svr_custom" service. Windows always fails to start it with an error message: "Windows could not start the Informix IDS - ol_svr_custom service on Local Computer. Error 193:0xc1"
Could somebody please help me with the installation?
Thank you.
Updated on 2013-03-13T17:46:22Z at 2013-03-13T17:46:22Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    161 Posts

    Re: Informix IDS - ol_svr_custom - failed to start on windows

    ‏2013-03-13T17:46:22Z  
    I also bumped into this error "Error 193: 0xc1" when attempting to start the Informix 11 service on Windows 8 (64-bit). I installed it from a package I downloaded similar to yours (named "iif.11.50.TC6DE.win2003.zip").
    The underlying issue seems to be as described in a Windows support article[1] (see the "Cause" section) as illustrated by (1) and (2)

    (1) D:\Data\IBM\IBM Informix Dynamic Server
    (2) D:\Data\IBM\IBM

    In my case I didn't properly check to ensure that there are no files or folders with a name similar to the install path of the server. Eventually, I noticed the file in (2) which I had to delete.
    Here's a summary of what I did in the hope that it may help others.
    1. Re-run the setup.exe from the extracted folder (in my case this was "iif.11.50.TC6DE.win2003").
    2. Choose the "Remove" option when asked by the installer. When the wizard completes, start the installation afresh.
    3. Customize your installation and select an installation path that DOESN'T contain spaces like "Program Files".
    4. After wizard completes, add a new Windows user account using the same credentials chosen during installation. You can do this using "lusrmgr.msc" on Windows 2003 or the instructions here for Windows 8[2].
    5. Open the services console via WINKEY + R, then type "services.msc".
    6. Right click on the Informix service then select "Properties".
    7. Switch to the "Log On" tab then check the "This account" radio button.
    8. Specify the username and password of the user created in step 4 then apply your changes.

    The service should start successfully after these changes.

    [1] http://support.microsoft.com/default.aspx?scid=kb;en-us;Q325680
    [2] http://windows.microsoft.com/en-us/windows-8/create-user-account