Topic
9 replies Latest Post - ‏2010-01-29T17:17:56Z by llandale
llandale
llandale
2809 Posts
ACCEPTED ANSWER

Pinned topic Code Formatting in Posts

‏2010-01-22T19:43:18Z |

When Posting, will folks please display DXL code inside a format box. Do that by surrounding your code with the word 'code' which is itself surrounded by open and closing braces {}. Looks like {co de} without the space.
 

for lnk in o->"*" do
{  oTarget = target(lnk)
   if (null oTarget) read(fullName(target i), false, true)
   bla bla bla
}


looks a lot better than this:
for lnk in o->"*" do
{ oTarget = target(lnk)
if (null oTarget) read(fullName(target i), false, true)
bla bla bla
}

 

  • Louie

 

Updated on 2013-12-19T15:42:31Z at 2013-12-19T15:42:31Z by JAntley
  • kbmurphy
    kbmurphy
    160 Posts
    ACCEPTED ANSWER

    Re: Code Formatting in Posts

    ‏2010-01-22T23:41:42Z  in response to llandale

    I am going to try to do as Louie suggests using Safari on Windows.
     

    //here is my code
    ack "This worked."
    

     


    I believe I've tried this before and had problems...but if it works I'll be more diligent about it in the future.

    In Safari, I can't preview. I can only post. Here goes....

     

    Updated on 2013-12-19T15:43:01Z at 2013-12-19T15:43:01Z by JAntley
    • llandale
      llandale
      2809 Posts
      ACCEPTED ANSWER

      Re: Code Formatting in Posts

      ‏2010-01-24T21:35:29Z  in response to kbmurphy
      Safari?

      Lately, the preview button has been gone for me also.

      • Louie
      • kbmurphy
        kbmurphy
        160 Posts
        ACCEPTED ANSWER

        Re: Code Formatting in Posts

        ‏2010-01-26T00:34:33Z  in response to llandale
        Safari, from Apple. All the cool kids are using it. ;)
      • llandale
        llandale
        2809 Posts
        ACCEPTED ANSWER

        Re: Code Formatting in Posts

        ‏2010-01-26T17:50:27Z  in response to llandale
        I figured out the lost 'preview' button. When I use 'http://www.bla.bla.bla' I don't get the option, but when I use 'secured' httpS: 'https:/www.bla.bla.bla' it works. Changed the properties in my Favorites, life is good.

        Sometimes I have to show blocked content; very annoying.

        • Louie
        • SystemAdmin
          SystemAdmin
          3180 Posts
          ACCEPTED ANSWER

          Re: Code Formatting in Posts

          ‏2010-01-27T06:33:29Z  in response to llandale
          Having to manually add the "s" to http just see the preview tab is completely weird. This is a bug - IBM needs to fix it - are there any budding IBM people out there that can confirm that this is being looked at?


          Paul Miller
          • llandale
            llandale
            2809 Posts
            ACCEPTED ANSWER

            Re: Code Formatting in Posts

            ‏2010-01-27T18:02:01Z  in response to SystemAdmin

            You only need to add 's' to the initial favorite. The clicked links conform to that.

            For the DXL forum, change:
                http://www.ibm.com/developerworks/forums/forum.jspa?forumID=1527&start=0
            to:
                https://www.ibm.com/developerworks/forums/forum.jspa?forumID=1527&start=0
            

             


            I'm getting security certificate errors now, not sure what to think about that. I notice today I no longer see the 'rich text' tab.

             

             

             

            • Louie

             

             

            Updated on 2013-12-19T15:43:39Z at 2013-12-19T15:43:39Z by JAntley
            • Peter.Dawson
              Peter.Dawson
              22 Posts
              ACCEPTED ANSWER

              Re: Code Formatting in Posts

              ‏2010-01-29T03:26:10Z  in response to llandale
              {rant} I can't say that I am the biggest fan of developerWorks. The site is slow for me and feels old and clunky. Thought at least its not as bad as the shamefully atrocious HP forums and website.

              The frustrating thing with devWorks is that sometimes I see a legend key on the right hand side with all the useful tags explained. But I don't know where the legend is now. It certainly isn't here while I type this.
              {rant}
              • Peter.Dawson
                Peter.Dawson
                22 Posts
                ACCEPTED ANSWER

                Re: Code Formatting in Posts

                ‏2010-01-29T03:28:01Z  in response to Peter.Dawson
                Oh.... and why can't I edit my own posts!!!

                Hey what do you know... the "Plain Text Help" legend just decided to appear on the right hand side of the screen this time!
                • llandale
                  llandale
                  2809 Posts
                  ACCEPTED ANSWER

                  Re: Code Formatting in Posts

                  ‏2010-01-29T17:17:56Z  in response to Peter.Dawson
                  Try surrounding your Rants with {rant}, then other folks can delete it.

                  • lol