Topic
  • 2 replies
  • Latest Post - ‏2010-01-19T17:28:08Z by land-land
land-land
land-land
12 Posts

Pinned topic RAM configuration for SSL

‏2010-01-11T17:04:03Z |
If I initiate RAM API activity e.g. RAMSession.put(..) over http (e.g. with a ram-url = http://localhost:9080/com.ibm.ram.repository.web.ws.was/) I get the following in the logs.

RAMClientUtilities.java:101) - Unable to instantiate fake SSL context for SSLv2 protocol java.security.NoSuchAlgorithmException: SSLv2 SSLContext not available

If I open a debug session, I note the RAMSession.put attempts to establish an https session, which generates the log errors cos its not set up, but then continues to work over http.

How do I go about configuring WAS 6.1 for https to support the requirements of RAM - I've looked at the WAS configuration options but its a bit daunting.
Alternatively how do I switch off this 'reported error'.

Any help would be much appreciated.

Thanks land.
Updated on 2010-01-19T17:28:08Z at 2010-01-19T17:28:08Z by land-land
  • SystemAdmin
    SystemAdmin
    217 Posts

    Re: RAM configuration for SSL

    ‏2010-01-11T20:27:16Z  
    Hello,
    That message is a DEBUG level log which does not indicate a problem - just a trace message.

    That being said, WAS should come enabled with HTTPS port - just check under Admin Console>Servers>Application Servers>server 1>Communications>Ports>WC_defaulthost_secure.
    By default it should be 9443. Just point your client to https://localhost:9443/com.ibm.ram.repository.web.ws.was/ to talk secure.

    To disable logging of the message we need to set the Log4J's logging level to something below debug. Which client are you running this from - an Eclipse client, a simple Java process?
    Regards,
    Srimanth.
  • land-land
    land-land
    12 Posts

    Re: RAM configuration for SSL

    ‏2010-01-19T17:28:08Z  
    Hello,
    That message is a DEBUG level log which does not indicate a problem - just a trace message.

    That being said, WAS should come enabled with HTTPS port - just check under Admin Console>Servers>Application Servers>server 1>Communications>Ports>WC_defaulthost_secure.
    By default it should be 9443. Just point your client to https://localhost:9443/com.ibm.ram.repository.web.ws.was/ to talk secure.

    To disable logging of the message we need to set the Log4J's logging level to something below debug. Which client are you running this from - an Eclipse client, a simple Java process?
    Regards,
    Srimanth.
    Thanks Srimanth.