Topic
  • 5 replies
  • Latest Post - ‏2013-02-07T11:24:20Z by SystemAdmin
sachin@accenture
sachin@accenture
2 Posts

Pinned topic WTX Maps in WID7

‏2009-12-30T04:09:38Z |
I am trying to open the mediation flows containing WTX maps in WID7 and I am getting the below error. I had instructions which told me to drop WTX tooling Jar (com.ibm.websphere.services.util.wtx.primitive_1.2.0.jar) in <WIDInstallDir>/plugins. I did that.

I also added WTXPrimitive_1_2.jar in <InstallDir>\WID7_WTE\runtimes\bi_v7\lib\ext. But this error is not going away. I did the same in WID6.2 and i had no problems opening the same mediation flows.
Any help will be appreciated.

Following is the stack trace of build error i am getting:

java.util.MissingResourceException: mednode://mednodes/WTXPrimitive.mednode/WTX
at com.ibm.wbit.sib.mediation.model.manager.eflow.EFlowMediationEditModel.doLoadMessageFlowModel(EFlowMediationEditModel.java:157)
at com.ibm.wbit.sib.mediation.model.manager.MediationEditModel.load(MediationEditModel.java:818)
at com.ibm.wbit.sib.mediation.ui.editor.MediationFlowEditor.init(MediationFlowEditor.java:959)
at org.eclipse.ui.internal.EditorManager.createSite(EditorManager.java:799)
at org.eclipse.ui.internal.EditorReference.createPartHelper(EditorReference.java:643)
at org.eclipse.ui.internal.EditorReference.createPart(EditorReference.java:428)
at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:594)
at org.eclipse.ui.internal.EditorReference.getEditor(EditorReference.java:266)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditorBatched(WorkbenchPage.java:2820)
at org.eclipse.ui.internal.WorkbenchPage.busyOpenEditor(WorkbenchPage.java:2729)
at org.eclipse.ui.internal.WorkbenchPage.access$11(WorkbenchPage.java:2721)
at org.eclipse.ui.internal.WorkbenchPage$10.run(WorkbenchPage.java:2673)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:70)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2668)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2652)
at org.eclipse.ui.internal.WorkbenchPage.openEditor(WorkbenchPage.java:2643)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:646)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:605)
at org.eclipse.ui.ide.IDE.openEditor(IDE.java:1100)
at org.eclipse.ui.internal.views.markers.ExtendedMarkersView.openMarkerInEditor(ExtendedMarkersView.java:253)
at org.eclipse.ui.internal.views.markers.ExtendedMarkersView.openSelectedMarkers(ExtendedMarkersView.java:1494)
at org.eclipse.ui.internal.views.markers.ExtendedMarkersView$3.open(ExtendedMarkersView.java:517)
at org.eclipse.jface.viewers.StructuredViewer$2.run(StructuredViewer.java:820)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:37)
at org.eclipse.core.runtime.Platform.run(Platform.java:880)
at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:48)
at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:175)
at org.eclipse.jface.viewers.StructuredViewer.fireOpen(StructuredViewer.java:818)
at org.eclipse.jface.viewers.StructuredViewer.handleOpen(StructuredViewer.java:1079)
at org.eclipse.jface.viewers.StructuredViewer$6.handleOpen(StructuredViewer.java:1183)
at org.eclipse.jface.util.OpenStrategy.fireOpenEvent(OpenStrategy.java:263)
at org.eclipse.jface.util.OpenStrategy.access$2(OpenStrategy.java:257)
at org.eclipse.jface.util.OpenStrategy$1.handleEvent(OpenStrategy.java:297)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1003)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3823)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3422)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:2384)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:2348)
at org.eclipse.ui.internal.Workbench.access$4(Workbench.java:2200)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:495)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:288)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:490)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:113)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:193)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:386)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
at java.lang.reflect.Method.invoke(Method.java:599)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:549)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:504)
at org.eclipse.equinox.launcher.Main.run(Main.java:1236)
at org.eclipse.equinox.launcher.Main.main(Main.java:1212)


Thanks
Sachin
Updated on 2013-02-07T11:24:20Z at 2013-02-07T11:24:20Z by SystemAdmin
  • LewS
    LewS
    1 Post

    Re: WTX Maps in WID7

    ‏2010-01-04T20:44:53Z  
    Hi,

    It does not sound like you are using WTX 8.3 for IS (Integration Servers). You have the non-official WTX version of the primitive not done by WTX development -- (It was done by the IBM Software Services for WebSphere -- ISSW -- group).

    I suggest you upgrade to WTX 8.3, where everything should be installed automatically via our setup utility, or you will need to contact the IBM Software Services for WebSphere group.

    Note that WTX 8.3 for IS requires WTX 8.3 Design Studio as a prerequisite. They need to be installed after WID and the runtime is installed.

    Lastly, I'm not sure the ISSW offering is supported with WID / WESB 7 -- that alone may be the problem.

    -thanks
    -lew
  • sachin@accenture
    sachin@accenture
    2 Posts

    Re: WTX Maps in WID7

    ‏2010-01-04T21:04:52Z  
    • LewS
    • ‏2010-01-04T20:44:53Z
    Hi,

    It does not sound like you are using WTX 8.3 for IS (Integration Servers). You have the non-official WTX version of the primitive not done by WTX development -- (It was done by the IBM Software Services for WebSphere -- ISSW -- group).

    I suggest you upgrade to WTX 8.3, where everything should be installed automatically via our setup utility, or you will need to contact the IBM Software Services for WebSphere group.

    Note that WTX 8.3 for IS requires WTX 8.3 Design Studio as a prerequisite. They need to be installed after WID and the runtime is installed.

    Lastly, I'm not sure the ISSW offering is supported with WID / WESB 7 -- that alone may be the problem.

    -thanks
    -lew
    Hi Lew,
    Thank you very much for such a precise reply. Yes, I upgraded to WTX 8.3 Design Studion and WTX for IS and my problem was solved. I was not aware that the version we were using with WID6.2 was non official but this was a good information.

    Thanks again
    Sachin
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WTX Maps in WID7

    ‏2011-05-25T17:56:27Z  
    Hi Lew,
    Thank you very much for such a precise reply. Yes, I upgraded to WTX 8.3 Design Studion and WTX for IS and my problem was solved. I was not aware that the version we were using with WID6.2 was non official but this was a good information.

    Thanks again
    Sachin
    I am getting this same error, after having installed TX for IS 8.3.0.4 and uninstalling/reinstalling WID, WTX83, TX4IS83. I can see the jar files the TX4IS install created in the WID7_WTE directory and found the WTXPrimitive.mednode file. This has been a bugger to fix. Any assistance would be appreciated.
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WTX Maps in WID7

    ‏2013-01-18T13:36:47Z  
    I am getting this same error, after having installed TX for IS 8.3.0.4 and uninstalling/reinstalling WID, WTX83, TX4IS83. I can see the jar files the TX4IS install created in the WID7_WTE directory and found the WTXPrimitive.mednode file. This has been a bugger to fix. Any assistance would be appreciated.
    could you provide me as below mentioned jar files

    1. com.ibm.websphereservice.util.wtx.primitive_1.0.0.jar

    2. com.ibm.wtx.runtime_8.2.0.jar

    3.wtx_primitive_1_0.jar
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WTX Maps in WID7

    ‏2013-02-07T11:24:20Z  
    could you provide me as below mentioned jar files

    1. com.ibm.websphereservice.util.wtx.primitive_1.0.0.jar

    2. com.ibm.wtx.runtime_8.2.0.jar

    3.wtx_primitive_1_0.jar
    Please could anyone provide com.ibm.wtx.runtime_8.2.0.jar