Topic
  • 5 replies
  • Latest Post - ‏2009-12-14T20:08:28Z by nitsvault
Health
Health
3 Posts

Pinned topic Adding Meta data to WCM content

‏2009-12-03T15:27:29Z |
We are using Portal 6.0 and Web Trends 8.0 and are trying to capture the titles of the WCM content. I have added an HTML element to the AT's and within the element I was trying to dynamically grab the title of the content with the following code.
instead of implementing this on every page
<meta name="WT.ti" content="Title of content">

trying to do this
<meta name="WT.ti" content="<Element context="current" type="content" key="Title"/>">

and when I view the page, I see the meta tag but content="" is what displays. Does anyone have any suggestions?

Also, I am setting up groups and sub-groups. I added an HTML element to the SA and added the group/su-group data and was trying to pull that info dynamically so I didn't have to add :
<meta name="WT.cg_n" content="MainGroup">
<meta name="WT.cg_s" content="SubGroup">

to every content page. Any suggestions on this one too?
Updated on 2009-12-14T20:08:28Z at 2009-12-14T20:08:28Z by nitsvault
  • SystemAdmin
    SystemAdmin
    3918 Posts

    Re: Adding Meta data to WCM content

    ‏2009-12-04T02:02:08Z  
    It title really an Element (added through the Manage Elements process) or is the Title part of the AT. If it is part of the AT itself, try using

    <idcmpnt type='content' context='current' field='title' />

    Also, why did you choose not to put the meta tags in a PT associated with the AT? That is how it is being done at the company I am working at.
  • Health
    Health
    3 Posts

    Re: Adding Meta data to WCM content

    ‏2009-12-09T15:24:13Z  
    It title really an Element (added through the Manage Elements process) or is the Title part of the AT. If it is part of the AT itself, try using

    <idcmpnt type='content' context='current' field='title' />

    Also, why did you choose not to put the meta tags in a PT associated with the AT? That is how it is being done at the company I am working at.
    Thank You for the response...I did end up putting the meta data in the PT's and I am referencing the SA's title for displaying the group/sub group and used an element tag to pull in the title of the content....working great.

    Here is my problem now...I need to track multiple SAs ... for for ex.

    Site
    SA1
    SA1a
    Content

    Below I am tracking the Site, SA1a and the content but not SA1. Within the SA1 I have a text element called "Web Trends Sub Group" and the content within that text element is not pulling in. I would rather figure out a way to use the IDCmpt to somehow say, pull in SA1 and SA1a, SA1b, etc. if it exists as sub groups to SA1. I am trying not to use the text element within the SA but if that is what I have to do....cool.

    I am using WT 8.0 with WCM 6.0.1. Any suggestions?

    <meta name="WT.cg_n" content="<IDCmpnt context="current" type="site" field="title"/>;<IDCmpnt context="current" type="sitearea" field="title"/>">
    <meta name="WT.cg_s" content="<Element context="current" type="content" key="Web Trends Sub Group"/>">

    <meta name="WT.ti" content="<IDCmpnt context="current" type="content" field="title"/>">
  • SystemAdmin
    SystemAdmin
    3918 Posts

    Re: Adding Meta data to WCM content

    ‏2009-12-10T01:01:03Z  
    I am not sure how you will be able to get the information SA1. The reason is that with a context of current you will only get the site are information related to the content. We are not going to that level here. Maybe someone else has done this.
  • mhampton
    mhampton
    10 Posts

    Re: Adding Meta data to WCM content

    ‏2009-12-10T01:29:21Z  
    • Health
    • ‏2009-12-09T15:24:13Z
    Thank You for the response...I did end up putting the meta data in the PT's and I am referencing the SA's title for displaying the group/sub group and used an element tag to pull in the title of the content....working great.

    Here is my problem now...I need to track multiple SAs ... for for ex.

    Site
    SA1
    SA1a
    Content

    Below I am tracking the Site, SA1a and the content but not SA1. Within the SA1 I have a text element called "Web Trends Sub Group" and the content within that text element is not pulling in. I would rather figure out a way to use the IDCmpt to somehow say, pull in SA1 and SA1a, SA1b, etc. if it exists as sub groups to SA1. I am trying not to use the text element within the SA but if that is what I have to do....cool.

    I am using WT 8.0 with WCM 6.0.1. Any suggestions?

    <meta name="WT.cg_n" content="<IDCmpnt context="current" type="site" field="title"/>;<IDCmpnt context="current" type="sitearea" field="title"/>">
    <meta name="WT.cg_s" content="<Element context="current" type="content" key="Web Trends Sub Group"/>">

    <meta name="WT.ti" content="<IDCmpnt context="current" type="content" field="title"/>">
    Can you use a navigator component to build the web trends data?

    i.e. a navigator that gets all the items up the path and renders out the web trends tags as it goes
  • nitsvault
    nitsvault
    14 Posts

    Re: Adding Meta data to WCM content

    ‏2009-12-14T20:08:28Z  
    Is anyone can help me with this?

    Since i am putting meta tags inside the PT it will be always outside of the <head> tags.
    so is there anyway i can put those tags inside of the head tags?