Topic
  • 20 replies
  • Latest Post - ‏2009-12-13T21:49:18Z by SystemAdmin
SystemAdmin
SystemAdmin
801 Posts

Pinned topic using Status page builder

‏2009-11-24T12:19:35Z |
Hi,

Can some one help me in how to use the Status page builder to indicate the current no. of products for the current month as in my SQL.
I am not sure what inputs ahould be given for the Status Options* and Curent Value* inputs in the Status page builder.
Updated on 2009-12-13T21:49:18Z at 2009-12-13T21:49:18Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-26T07:38:27Z  
    In the "Status Options", you could set a couple of status and corresponding thresholds. The "current value" is a number that could be taken as one of those status.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-26T09:04:22Z  
    In the "Status Options", you could set a couple of status and corresponding thresholds. The "current value" is a number that could be taken as one of those status.
    Thanks for the reply.
    PFA model where in I have the no of products ranging from 0 to 1000 for each month coming form the SQL.
    I need to point the indicator to show the no of products in the current month. So I have had harcoded the values to check but may be I didnt give the inputs properly because of which the indicator is not poiniting against 100 which I gave for the "current value" input. Can you pls check the Status page buikder inputs and correct if any.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-26T11:01:16Z  
    Thanks for the reply.
    PFA model where in I have the no of products ranging from 0 to 1000 for each month coming form the SQL.
    I need to point the indicator to show the no of products in the current month. So I have had harcoded the values to check but may be I didnt give the inputs properly because of which the indicator is not poiniting against 100 which I gave for the "current value" input. Can you pls check the Status page buikder inputs and correct if any.
    Hi, I tried with your model by using default chart style, it seems work.
    btw. pls set Status Option with increasing thresholds.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-26T22:28:41Z  
    Hi, I tried with your model by using default chart style, it seems work.
    btw. pls set Status Option with increasing thresholds.
    Thanks for the reply!
    Any ideas why am getting 2 needles for the Custom chart style one pointing the current value and one pointing to the highest value in the Status options input of Status Page?
    PFA custom chart style.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-27T09:02:47Z  
    Thanks for the reply!
    Any ideas why am getting 2 needles for the Custom chart style one pointing the current value and one pointing to the highest value in the Status options input of Status Page?
    PFA custom chart style.
    Hi, I didn't see any possibility using two needles in Status Page builder, but it can be achieved with Web Charts - Enhanced builder.

    I attached a model with Web Charts builder for it.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-11-27T11:57:52Z  
    Hi, I didn't see any possibility using two needles in Status Page builder, but it can be achieved with Web Charts - Enhanced builder.

    I attached a model with Web Charts builder for it.
    Hi,
    Sorry for not making it clear. I dont want 2 needles but am getting 2 needles as in the figure. The one pointing against 18 is the correct value (which is what i require) but am not sure why another needle is coming up and pointing against 60. I have tried with other webcharts as well and one points to the correct value and other to the highest value. Not sure why am getting 2 needles when am using a custom chart style.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-01T14:25:36Z  
    Hi,
    Sorry for not making it clear. I dont want 2 needles but am getting 2 needles as in the figure. The one pointing against 18 is the correct value (which is what i require) but am not sure why another needle is coming up and pointing against 60. I have tried with other webcharts as well and one points to the correct value and other to the highest value. Not sure why am getting 2 needles when am using a custom chart style.
    Sorry for the late response.
    I saw from your model that you SystemOut the vairable ${Variables/varRBAllBrnIndicator} in your main action, could you tell me what was printed out?
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-01T14:27:52Z  
    Sorry for the late response.
    I saw from your model that you SystemOut the vairable ${Variables/varRBAllBrnIndicator} in your main action, could you tell me what was printed out?
    Thanks for the reply!
    It prints out 18
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-02T03:02:25Z  
    Thanks for the reply!
    It prints out 18
    I guess the two needles are somehow caused by your special chart style. I've found a workaround for it - In "Status Options" input, only specify one stauts, and make its threshold value as 0.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-02T11:24:04Z  
    I guess the two needles are somehow caused by your special chart style. I've found a workaround for it - In "Status Options" input, only specify one stauts, and make its threshold value as 0.
    I have tried earlier the same but tried again after you said but its still the same getting 2 needles.PFA. In "Status Options" input, specified just the "Low" status, and with its threshold value as 0.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-07T10:46:48Z  
    I have tried earlier the same but tried again after you said but its still the same getting 2 needles.PFA. In "Status Options" input, specified just the "Low" status, and with its threshold value as 0.
    Is there any way to get rid of the 2 needles whilst using a custom chart?
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-08T02:50:26Z  
    I have tried earlier the same but tried again after you said but its still the same getting 2 needles.PFA. In "Status Options" input, specified just the "Low" status, and with its threshold value as 0.
    Pls find the attachment for my changes to your model. The result looks good.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-09T00:36:29Z  
    Pls find the attachment for my changes to your model. The result looks good.
    Thank you very much for the reply!
    There is a glitch here, if we are getting a value of in between the ten's(for ex: 36) then we are getting 2 needles and if the number is exactly in tens (for ex: 30) then we are getting 1 needle only as u sent me.

    So I am not sure if this glitch is with the Status page builder or with the custom chart style.
  • pnpradeep
    pnpradeep
    2 Posts

    Re: using Status page builder

    ‏2009-12-09T06:55:27Z  
    Thank you very much for the reply!
    There is a glitch here, if we are getting a value of in between the ten's(for ex: 36) then we are getting 2 needles and if the number is exactly in tens (for ex: 30) then we are getting 1 needle only as u sent me.

    So I am not sure if this glitch is with the Status page builder or with the custom chart style.
    Hi,

    I also have the same issue, getting two needles when I use coustm stlye with the status page builder.
    I understand that if the value is multiples of 10 its giving one needle else its giving two needles.
    Can you please help me out how get one needle?
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-09T07:29:56Z  
    Thank you very much for the reply!
    There is a glitch here, if we are getting a value of in between the ten's(for ex: 36) then we are getting 2 needles and if the number is exactly in tens (for ex: 30) then we are getting 1 needle only as u sent me.

    So I am not sure if this glitch is with the Status page builder or with the custom chart style.
    Hi,
    I found that the root cause is the difference between Gauge chart and Dial chart. The Gauge chart allow multiple needles while Dial chart only display one. The Status page would generate a web chart data like following:

    <XML type="default"><ROW col0="42" col1="50.0">Value</ROW></XML>

    The col1 value is calculated by the max threshold specified in the Status options.
    So the workaround could be
    1. using a dial style rather than a Gauge style in Status Page builder
    2. In status page builder, select the option "Provide Custom Chart" in "Chart style Selection" input, and create a dial or gauge chart and specify the chart data like following format:

    <XML type="default"><ROW col0="42">Value</ROW></XML>

    Hope this help.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-09T22:06:34Z  
    Hi,
    I found that the root cause is the difference between Gauge chart and Dial chart. The Gauge chart allow multiple needles while Dial chart only display one. The Status page would generate a web chart data like following:

    <XML type="default"><ROW col0="42" col1="50.0">Value</ROW></XML>

    The col1 value is calculated by the max threshold specified in the Status options.
    So the workaround could be
    1. using a dial style rather than a Gauge style in Status Page builder
    2. In status page builder, select the option "Provide Custom Chart" in "Chart style Selection" input, and create a dial or gauge chart and specify the chart data like following format:

    <XML type="default"><ROW col0="42">Value</ROW></XML>

    Hope this help.
    Sorry I didnt get exactly what you suggested.

    Am not getting any option to select/specify a chart style when I select "Provide Custom Chart". So unable to know where should I specify this (<XML type="default"><ROW col0="42">Value</ROW></XML>). But this seems something like a hard coded value in XML.

    Also could you pls provide any sample dial chart.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-10T10:25:22Z  
    Sorry I didnt get exactly what you suggested.

    Am not getting any option to select/specify a chart style when I select "Provide Custom Chart". So unable to know where should I specify this (<XML type="default"><ROW col0="42">Value</ROW></XML>). But this seems something like a hard coded value in XML.

    Also could you pls provide any sample dial chart.
    Hi GuoQing,

    I have issues as in the screenshot with the Default style chart. it would be great if you can suggest a work around for the issues.

    Also it would be great if you can provide a sample when "Provide Custom Chart" is selected.

    Thanks in advance!
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-10T12:09:35Z  
    Sorry I didnt get exactly what you suggested.

    Am not getting any option to select/specify a chart style when I select "Provide Custom Chart". So unable to know where should I specify this (<XML type="default"><ROW col0="42">Value</ROW></XML>). But this seems something like a hard coded value in XML.

    Also could you pls provide any sample dial chart.
    Please see the attached model.

    You can press "Ctrl+Shift+R" and type in "dial.xml", that could help you quickly find the style file. The file you found is the default dial chart style.
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-11T01:52:22Z  
    Hi GuoQing,

    I have issues as in the screenshot with the Default style chart. it would be great if you can suggest a work around for the issues.

    Also it would be great if you can provide a sample when "Provide Custom Chart" is selected.

    Thanks in advance!
    Please open the Dial.xml at solutions\dashboard\chartstyles, and try to find xml snippet like following

    <elements drawOutline="false" drawShadow="true">
    <series index="0">
    <paint color="#00FF00"/>
    </series>
    <series index="1">
    <paint color="#FF0000"/>
    </series>
    <series index="2">
    <paint color="#FFFF00"/>
    </series>

    You could set your preferred color in sequence, e.g. green at series 0, red at series 1, and yellow at series 2.

    As the title placement, pls find xml snippet like following:
    <title placement="Left" font="Arial Unicode MS-12-bold">
    <decoration style="None"/>
    </title>

    Just set placement attribute to be "top".
  • SystemAdmin
    SystemAdmin
    801 Posts

    Re: using Status page builder

    ‏2009-12-13T21:49:18Z  
    Please open the Dial.xml at solutions\dashboard\chartstyles, and try to find xml snippet like following

    <elements drawOutline="false" drawShadow="true">
    <series index="0">
    <paint color="#00FF00"/>
    </series>
    <series index="1">
    <paint color="#FF0000"/>
    </series>
    <series index="2">
    <paint color="#FFFF00"/>
    </series>

    You could set your preferred color in sequence, e.g. green at series 0, red at series 1, and yellow at series 2.

    As the title placement, pls find xml snippet like following:
    <title placement="Left" font="Arial Unicode MS-12-bold">
    <decoration style="None"/>
    </title>

    Just set placement attribute to be "top".
    Thankyou very much for the reply!!

    I have selected "Provide Custom Style" and selected the Dial.xml for "Chart Style". Am just getting the only 2 colors with index 1 and 2 colors, not able to get the 3 colors.
    It would be great if you suggest how do I get 3 colors.