Topic
  • 1 reply
  • Latest Post - ‏2009-07-13T21:16:24Z by SystemAdmin
SystemAdmin
SystemAdmin
151 Posts

Pinned topic ODM 3.1.2 and ODM 3.3

‏2009-07-09T02:58:36Z |

[Boon said:]

Hello,

I have just installed new release of ODM - ODM 3.3

I have several ODM models, and here are my questions.

1. Can a model created by ILOG OPL6.3 (come with ODM3.3) run on ODM 3.1.2?
2. Can a model created by ILOG OPL6.1.2 (come with ODM3.1.2) run on ODM3.3?

I have tried the second case and the answer seems to be No. Is there a way to solve this issue without re-deploying?  I remembered when I made a switch to ODM 3.1.2, it asked me I needed to convert the model into new version. But it didn't ask the same thing for ODM3.3.


Thank you,
B
Updated on 2009-07-13T21:16:24Z at 2009-07-13T21:16:24Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    151 Posts

    Re: ODM 3.1.2 and ODM 3.3

    ‏2009-07-13T21:16:24Z  

    [alain.chabrier said:]

    Hi

    it really depends on what you refer to exactly with  "model" in your question.
    (OPL) Models  have not had significant syntax changes since OPL4.x, so they can be used for any application with any ODM version.

    Now if you refer to project and eventual need to redeploy the application, then indeed in ODM, you need to redeploy the application when using a new version.
    Note that this makes perfect sense in real life where an IT person will deply the new version for the business user. This is unfrequent, and this must be done in a controlled manner with mirgation plans including testing and validation.

    Alain