Topic
No replies
michael-t
michael-t
28 Posts
ACCEPTED ANSWER

Pinned topic LoadLeveler V3.4.3 cannot enable dynamically SMT for jobs on P5+ cluster

‏2009-11-18T16:52:29Z |
We are using LoadLeveler V3.4.3 on our 1600 cluster (with POE 4.3.2 and AIX 5.3 TL09-SP1) and according to documentation the
"#@ SMT=yes"
clause in a LL job script should enable SMT mode on the computation nodes dynamically before the LL job starts running on the nodes. However even though we used the above clause, when the job executes CANNOT see an SMT environment enabled.

I have verified this by the output of the "bindprocessor -q" command which never shows more processors ("CPUs") available than the physical cores (which are 16 cores per 575 node). The "bindprocessor -q" would report 2Xcores when SMT is enabled on a node. On our cluster by default the SMT is OFF. Is there anything else we should be doing so that LL can enable or disable SMT at a job's discretion ?

Info on our Cluster:
The cluster nodes are p5-575 with 16 Power5+ cores at 1.9GHz and have SMT mode disabled at boot time. See belllow:

hydra2pts/5#:perf% smtctl
This system is SMT capable.
SMT is currently disabled.
SMT boot mode is set to disabled.
SMT threads are bound to the same physical processor.
proc0 has 1 SMT threads.
Bind processor 0 is bound with proc0
proc2 has 1 SMT threads.
Bind processor 1 is bound with proc2
.....
thanks
Michael Thomadakis
SC/TAMU