Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
1 reply Latest Post - ‏2009-10-21T17:46:15Z by Philippe G
Philippe G
Philippe G
3 Posts
ACCEPTED ANSWER

Pinned topic Empty fields in Properties view

‏2009-10-09T16:20:29Z |
Hello,
I install Log and Trace Analyzer for Autonomic Computing on an ubuntu by sudoing. I also tested under windows XP.
I launch LTA by sudoing.

When I import some CBE log (it is said valid with XSD by firefox) and I try to modify printed fields, I don't see the ExtendedDataElement field. This bug occures as well under linux as under windows.

Moreover, on linux, when I go to the Properties view, the fields "Extended Data Elements", "Context Data Elements", "Situation" appear but I can't view their values. The situation values make appear a bug window saying to look at the log view, but nothing appear in this view.
Under windows XP, it does not seem to be any problem.
Log and Trace Analyzer for Autonomic Computing 4.2.0.v200609291052-IrDWgXIapGE_oId
generation ID: AC-4.2.1-200610031807
for linux and windows
Updated on 2009-10-21T17:46:15Z at 2009-10-21T17:46:15Z by Philippe G
  • Philippe G
    Philippe G
    3 Posts
    ACCEPTED ANSWER

    Re: Empty fields in Properties view

    ‏2009-10-21T17:46:15Z  in response to Philippe G
    I will precise a bit all these problems...

    My log files are said valid by firefox (but it seems to just validate
    the xml syntax and not the xsd). When I tried the java desktop tool on
    win XP with the same file, it says that the file is not of the CBE format.
    When I tried to validate it by xml parser (http://validator.w3.org/), it
    said I don't have DOCTYPE declaration. I wonder if CBE XSD is always
    available actually on the IBM website... (I use 1.0.1 format and XSD)
    I think this problem can cause all the following problems...

    For example, there is the first lines of my .xml:

    <?xml version='1.0' encoding='UTF-8'?>
    <CommonBaseEvents xmlns="http://www.ibm.com/AC/commonbaseevent1_0_1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.ibm.com/AC/commonbaseevent1_0_1 commonbaseevent1_0_1.xsd">

    When I import some CBE log (it is said valid with XSD by firefox) and I try to modify printed fields, I don't see the
    ExtendedDataElement field. This bug occures as well under linux as under windows.

    I spoke there of the main window.

    Moreover, on linux, when I go to the Properties view, the fields "Extended Data Elements", "Context Data Elements", "Situation"
    appear but I can't view their values. The situation values make appear a bug window saying to look at the log view, but nothing
    appear in this view.
    Under windows XP, it does not seem to be any problem.

    In win XP, I can see the name/values without any problem but...

    On Linux and Windows XP, clicking on the "Situation" or "Extended Data
    Elements" properties (in the properties view) make appear a bug window
    saying to look at the log view but nothing appear in this view.
    On Windows XP, this bug window occurs when importing the files and at each click, but on linux it occurs just the first time.

    On Win XP, in the situation property view
    (after closing the bug window), it is printed:
    • OtherSituation (correct);
    • reasoningScope: EXTERNAL (correct value: INTERNAL)
    • a third line appear with no name and a value "null and an empty
    subvalue.

    Does anyone has any idea of the problem ?
    Thanks.