Topic
  • 1 reply
  • Latest Post - ‏2010-02-05T05:09:14Z by yangling
SystemAdmin
SystemAdmin
280 Posts

Pinned topic Scheduled macro in Powerplay not working

‏2009-09-29T07:42:17Z |
Hi!

I have created a macro that opens a report in Cognos Powerplay 7.4 MR3, changes the dimesnion line and saves it as PDF. The macro works if I run it directly from the script editor or if I run the macro with runmac32.exe using a batch file.

When I schedule it in Windows Task scheduler, however, it doesn't finish. I can see in Task manager that it starts pwrplay.exe and runmac32.exe, but the task hangs with status "running". I'm using Windows Server 2008 64-bit. The user account has sufficient rights and I've checked "run with highest privileges" and "start whether user is logged in or not". I also tried with a simple macro that just opens and closes Powerplay, but with same results.

What could be the problem? Has anyone succesfully scheduled a PP macro? I'm already updating the cubes in Transformer every night which works great, but getting automatic reports would be even nicer.
Updated on 2010-02-05T05:09:14Z at 2010-02-05T05:09:14Z by yangling
  • yangling
    yangling
    38 Posts

    Re: Scheduled macro in Powerplay not working

    ‏2010-02-05T05:09:14Z  
    PowerPlay 7.4 MR3 was never tested on Win 2008.