Topic
1 reply Latest Post - ‏2009-09-27T10:53:12Z by Sawan
umakathir
umakathir
1 Post
ACCEPTED ANSWER

Pinned topic How to eliminitate the call goes to IBM stored procedure DSNAPCOL?

‏2009-09-24T16:18:37Z |
I have my application written in Visual basic and calling DB2 stored procedures through ODBC connection. We came to know through our DBA that Metadata IBM stored procedure DSNAPCOL (returns stored procedure parameters to program) is now being invoked and consumes more CPU.

We made the changes in ini file to set DESCRIBEPARAM=0. But that does not help us to eliminate the call goes to DSNAPCOL.

Can anyone help me?

-Uma Kathir
Updated on 2009-09-27T10:53:12Z at 2009-09-27T10:53:12Z by Sawan
  • Sawan
    Sawan
    56 Posts
    ACCEPTED ANSWER

    Re: How to eliminitate the call goes to IBM stored procedure DSNAPCOL?

    ‏2009-09-27T10:53:12Z  in response to umakathir
    Hi Uma

    Could you please try setting the parameter in the connection string or set DB2CLINIPATH environment variable to the correct db2cli.ini location.

    http://publib.boulder.ibm.com/infocenter/db2luw/v9r7/index.jsp?topic=/com.ibm.db2.luw.apdv.cli.doc/doc/r0010865.html
    http://publib.boulder.ibm.com/infocenter/db2luw/v9r7/index.jsp?topic=/com.ibm.db2.luw.qb.server.doc/doc/t0007289.html

    I suspect if the ini is being read or not. Otherwise you would have received CLI0150E when SQLDescribeParam was called.

    Regards,
    Sawan Gupta