Topic
  • 8 replies
  • Latest Post - ‏2015-11-27T08:31:05Z by BillTidy
DanMott
DanMott
54 Posts

Pinned topic Preventing tables from having only the column header at bottom of page

‏2009-08-19T22:44:11Z |
Hello all,

I am looking for a way to prevent tables from leaving only the column headers at the bottom of a page with no real table data on that page.

Regards,
Daniel Mott
Updated on 2013-02-04T17:16:34Z at 2013-02-04T17:16:34Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1299 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2009-08-21T07:49:08Z  
    Hi Daniel,

    You can put a page break element before your table, to make sure you don't have the header row at the end of a page; but this will have an effect over all tables, if your RPE table is within some iteration. Else, you can write a macro to solve the problem on the Word side.

    Milan
  • SystemAdmin
    SystemAdmin
    1299 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2009-08-21T14:07:11Z  
    One way that I have used is to create a style that you use on the first row.
    For the style include "paragraph->pagination->keep with next" and set this to "true".
    That will make sure that the first row always has at least one line below it!

    /Kristian
  • SystemAdmin
    SystemAdmin
    1299 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2013-02-04T17:16:34Z  
    One way that I have used is to create a style that you use on the first row.
    For the style include "paragraph->pagination->keep with next" and set this to "true".
    That will make sure that the first row always has at least one line below it!

    /Kristian
    Hello,

    Does anyone have a style sheet and a template that with prevent just the header row from being printed. Currently I have a Module when printed, it prints the header row then continues to the next page I would like to only print the header row with at least one row under the header otherwise start on next page.

    -Jim
  • DiegoItera
    DiegoItera
    4 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2015-11-18T10:00:00Z  
    One way that I have used is to create a style that you use on the first row.
    For the style include "paragraph->pagination->keep with next" and set this to "true".
    That will make sure that the first row always has at least one line below it!

    /Kristian

    Hello,

    I have the same problem (see image). I've tried creating a style with the "paragraph->pagination->keep with next" set to true and applied it to the first row, but it didn't work for me.

    Any other solution?

    Thanks.

    Attachments

  • Kumaraswamy M
    Kumaraswamy M
    350 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2015-11-19T04:28:41Z  

    Hello,

    I have the same problem (see image). I've tried creating a style with the "paragraph->pagination->keep with next" set to true and applied it to the first row, but it didn't work for me.

    Any other solution?

    Thanks.

    Hi Diego,

    Which version of RPE are you using? We're reported the same issue couple of weeks back and we're planning to fix this for our upcoming release.

    To confirm, you are seeing the same issue as in the attached template, correct?

     

    Thanks,

    Kumar

    Attachments

  • DiegoItera
    DiegoItera
    4 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2015-11-19T10:54:08Z  

    Hi Diego,

    Which version of RPE are you using? We're reported the same issue couple of weeks back and we're planning to fix this for our upcoming release.

    To confirm, you are seeing the same issue as in the attached template, correct?

     

    Thanks,

    Kumar

    Hi Kumar,

     

    Thanks for your reply.

    Exactly, the issue is just having the header row at the bottom of the page without any other row bellow it.

    I'm currently using RPE v1.3.

     

    Thanks.

  • Kumaraswamy M
    Kumaraswamy M
    350 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2015-11-20T05:18:07Z  

    Hi Kumar,

     

    Thanks for your reply.

    Exactly, the issue is just having the header row at the bottom of the page without any other row bellow it.

    I'm currently using RPE v1.3.

     

    Thanks.

    Hi Diego,

    We've fixing this for our upcoming release. If you need a hotfix on top of RPE 1.3, please contact IBM support.

     

    Thanks,

    Kumar

  • BillTidy
    BillTidy
    72 Posts

    Re: Preventing tables from having only the column header at bottom of page

    ‏2015-11-27T08:31:05Z  

    Doesn't need a bug fix - you can do it by using styles.

    Create a style 'Table' in RPE template and assign this style to your table in the dta

    Create a style with the same name in your Word stylesheet and set the Word stylesheet options for style Table in tab  "Line and Page breaks":

    • "Widow/Orphan control" --> on
    • "Keep with next"--> on
    Updated on 2015-11-27T08:31:58Z at 2015-11-27T08:31:58Z by BillTidy