Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
6 replies Latest Post - ‏2010-09-22T05:10:15Z by RMooreJr
SystemAdmin
SystemAdmin
13339 Posts
ACCEPTED ANSWER

Pinned topic 412153

‏2009-07-26T05:41:26Z |
412153
Updated on 2010-09-22T05:10:15Z at 2010-09-22T05:10:15Z by RMooreJr
  • SystemAdmin
    SystemAdmin
    13339 Posts
    ACCEPTED ANSWER

    test

    ‏2009-09-23T07:52:49Z  in response to SystemAdmin
    A very good tutorial. When I try to move into Eclipse3.5, and run in tomcat6.0.18. I hit the following error. Could you please give some advice.
    SEVERE: Exception sending context initialized event to listener instance of class com.sun.faces.config.ConfigureListener
    java.lang.NoClassDefFoundError: Lorg/codehaus/groovy/reflection/ClassInfo;
    at java.lang.Class.getDeclaredFields0(Native Method)
    at java.lang.Class.privateGetDeclaredFields(Class.java:2291)
    at java.lang.Class.getDeclaredFields(Class.java:1743)
    at com.sun.faces.application.annotation.ManagedBeanConfigHandler.getBeanInfo(ManagedBeanConfigHandler.java:146)
    at com.sun.faces.application.annotation.ManagedBeanConfigHandler.process(ManagedBeanConfigHandler.java:134)
    at com.sun.faces.application.annotation.ManagedBeanConfigHandler.push(ManagedBeanConfigHandler.java:120)
    at com.sun.faces.application.annotation.AnnotationManager.applyConfigAnntations(AnnotationManager.java:160)
    at com.sun.faces.config.processor.AbstractConfigProcessor.processAnnotations(AbstractConfigProcessor.java:323)
    at com.sun.faces.config.processor.ManagedBeanConfigProcessor.process(ManagedBeanConfigProcessor.java:242)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.ValidatorConfigProcessor.process(ValidatorConfigProcessor.java:119)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.ConverterConfigProcessor.process(ConverterConfigProcessor.java:123)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.ComponentConfigProcessor.process(ComponentConfigProcessor.java:117)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.ApplicationConfigProcessor.process(ApplicationConfigProcessor.java:333)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.LifecycleConfigProcessor.process(LifecycleConfigProcessor.java:114)
    at com.sun.faces.config.processor.AbstractConfigProcessor.invokeNext(AbstractConfigProcessor.java:113)
    at com.sun.faces.config.processor.FactoryConfigProcessor.process(FactoryConfigProcessor.java:220)
    at com.sun.faces.config.ConfigManager.initialize(ConfigManager.java:310)
    at com.sun.faces.config.ConfigureListener.contextInitialized(ConfigureListener.java:210)
    at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3843)
    at org.apache.catalina.core.StandardContext.start(StandardContext.java:4342)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:791)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:771)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:525)
    at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:830)
    at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:719)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:490)
    at org.apache.catalina.startup.HostConfig.start(HostConfig.java:1149)
    at org.apache.catalina.startup.HostConfig.lifecycleEvent(HostConfig.java:311)
    at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:117)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1053)
    at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
    at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
    at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
    at org.apache.catalina.core.StandardService.start(StandardService.java:516)
    at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
    at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:597)
    at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
    at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
    Caused by: java.lang.ClassNotFoundException: org.codehaus.groovy.reflection.ClassInfo
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1387)
    at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1233)
    at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
  • svcurcio
    svcurcio
    1 Post
    ACCEPTED ANSWER

    test

    ‏2009-10-07T21:24:24Z  in response to SystemAdmin
    Just replace the groovy jar in WEB-INF/lib with the one used by Eclipse (see 'Groovy Libraries' in the Eclipse project folder)
  • PJT
    PJT
    1 Post
    ACCEPTED ANSWER

    test

    ‏2009-12-10T09:26:41Z  in response to SystemAdmin
    Very useful & helpful, thank you. One problem I've come across is with the prependId="false" flag. I wanted to use the login component with spring-security but even though I used prependId="false" in the component's form the form's id was prepended. This meant that spring-security, which relies on specific j_username & j_password url parameters woudn't work. I tested without a component and prependId="false" worked fine as did spring-security. Is there somehting I'm missing about the prependId flag? Is there a particular reason it doesn't work inside a composite component? (JSF v2.0.1).
    Regards,
    PJT
  • andersaa
    andersaa
    1 Post
    ACCEPTED ANSWER

    test

    ‏2009-12-21T12:52:27Z  in response to SystemAdmin
    Hi
    I tried to run this on Glassfish V3. At first I got a ViewExpiredException on every page, but eventually fixed this by reducing session-timeout to 10 in web.xml.

    Now the example deploys and I am able to log in, but when viewing a map, every field in the map component is blank. It seems like there is a problem accessing cc.parent in the map component. If I output cc, i get:

    javax.faces.component.UINamingContainer@b9ec2b

    But if I output cc.parent I get an empty string. If I output places.pageRedraws I get the expected result, so the problem seems only to occur with cc.parent.

    Any suggestions to what this could be?
  • rmorriso
    rmorriso
    1 Post
    ACCEPTED ANSWER

    test

    ‏2010-06-19T01:27:37Z  in response to SystemAdmin
    I had the same issue with null cc.parent.attr that andersaa reports. Work around is to pass the object as an attribute to the child and reference through the child cc.attr.
  • RMooreJr
    RMooreJr
    3 Posts
    ACCEPTED ANSWER

    test

    ‏2010-09-22T05:10:15Z  in response to SystemAdmin
    I now have the FU Part 3 code up on GlassFish 3.0.1 via Netbeans 6.9.1. I also had the component nesting problem and worked around that by using UI:include for the sub-components as snippets. I still have a bothersome problem: the map pages render fine on page load but do not re-render when f:ajax submits the request. I just get a blank display even though the m:map code is still in the browser. To simplify the investigation, I made a test case of one backing bean and one xhtml page with the map component , zoom index up and down buttons, and a zoom index display.
    I encountered the identical ajax rendering problem: the buttons update the zoom index and display the new value but the map display portion is blank. Refreshing the page manually does correctly render the map with the new zoom value.

    Is this yet another Glassfish/Mojarra issue? Has anyone else seen/fixed this behavior?

    By the way, my testing determined the following specs for the gmaps4jsf tag's zoom parameter:

    1: Increasing the zoom value zooms IN not OUT.
    2: The acceptable range of zoom value is 0 to 22 corresponding to the map's zoom control that seems to have 22 "notchs". Value 22 puts you in your backyard; value 0 produces a map of the entire world.
    3. Any value higher than 22 will create an error message wallpapered on your map. A negative value is ok and is treated like 0.