Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
3 replies Latest Post - ‏2009-08-03T21:08:37Z by Brian_King
ffros
ffros
1 Post
ACCEPTED ANSWER

Pinned topic SLES 10 Sp2 could not find find disk for installation

‏2009-07-22T15:31:23Z |
Hello, Im installing Linux in a Power 6 520 server Lpar with FC card
8 Gigabit PCI Express Dual Port Fibre Channel Adapter (FC 5735) NPIV But the installation program could not find any hard disk for the installation.

I try to install AIX 6.1 on the same Lpar and I see the 30 Gb disk from the SAN.

The storage is a IBM DS 3400.

Any help would be apreciated.
Updated on 2009-08-03T21:08:37Z at 2009-08-03T21:08:37Z by Brian_King
  • SystemAdmin
    SystemAdmin
    706 Posts
    ACCEPTED ANSWER

    Re: SLES 10 Sp2 could not find find disk for installation

    ‏2009-07-29T21:40:14Z  in response to ffros
    You should see the disk during install as both SLES 10 SP2 and the FC 5735 adapter should support this configuration for install:
    http://publib.boulder.ibm.com/infocenter/systems/scope/hw/index.jsp?topic=/iphcd/fc5735.htm
    https://www-912.ibm.com/e_dir/eServerPrereq.nsf/HW2/Hardware~eServer~5735?OpenDocument

    Some troubleshooting is needed. Boot to SLES10SP2 installer adding startshell=1 as one of the options and it should provide you a shell. See if you can gather the following information:
    1. Does the adapter driver load?
    2. Does the link come up?
    3. Does the adapter see the storage, but no luns?
    • SystemAdmin
      SystemAdmin
      706 Posts
      ACCEPTED ANSWER

      Re: SLES 10 Sp2 could not find find disk for installation

      ‏2009-07-29T21:43:25Z  in response to SystemAdmin
      For question 1), do a "dmesg |grep lpfc" to see if it is loaded.
  • Brian_King
    Brian_King
    20 Posts
    ACCEPTED ANSWER

    Re: SLES 10 Sp2 could not find find disk for installation

    ‏2009-08-03T21:08:37Z  in response to ffros
    I notice NPIV is mentioned in the initial post. The 5735 is supported in SLES 10 SP2 in dedicated mode only. If the FC adapter is assigned to the VIOS and you are using NPIV, that configuration is not supported in SLES 10 SP2, since the required driver, ibmvfc, is not included in SP2. SLES 11 is the only Linux release that currently has this support.