IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 14 replies
  • Latest Post - ‏2012-11-03T07:00:06Z by MPSERVICES
nithisha
nithisha
52 Posts

Pinned topic Unable to logon to Workplace XT

‏2009-07-20T09:57:26Z |
Hi all,

I have installed Content Engine 4.5 and Workplace XT 1.1.3, but when I open Workplace XT, it shows up like the screen shot I have attached, and when I try to login, nothing happens. Can someone please tell me what could be the problem.
Updated on 2012-11-03T07:00:06Z at 2012-11-03T07:00:06Z by MPSERVICES
  • SystemAdmin
    SystemAdmin
    199 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-20T10:25:41Z  
    Hi,

    Follow carefully chapter: Task 8a: Deploy IBM FileNet Workplace XT (WebSphere) from WPXT install guide!

    Is a problem related with application roles!
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-20T13:24:53Z  
    Hi,

    Follow carefully chapter: Task 8a: Deploy IBM FileNet Workplace XT (WebSphere) from WPXT install guide!

    Is a problem related with application roles!
    Hi,
    thanks for the advice,also let me know if I can deploy workplace and workplace xt on a single websphere profile.
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-20T13:32:27Z  
    • nithisha
    • ‏2009-07-20T13:24:53Z
    Hi,
    thanks for the advice,also let me know if I can deploy workplace and workplace xt on a single websphere profile.
    I actually tried to install workplace on a different websphere profile from that of workplace xt. But then it turns out that I cannot login to either the workplace or workplace xt now. I get the following error when i Login to workplace xt now.

    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.

    Filter AE SecurityCheckFilter: filter is unavailable.

    IBM WebSphere Application Server
  • SystemAdmin
    SystemAdmin
    199 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-20T20:07:46Z  
    • nithisha
    • ‏2009-07-20T13:32:27Z
    I actually tried to install workplace on a different websphere profile from that of workplace xt. But then it turns out that I cannot login to either the workplace or workplace xt now. I get the following error when i Login to workplace xt now.

    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.

    Filter AE SecurityCheckFilter: filter is unavailable.

    IBM WebSphere Application Server
    Hi,

    I had installed a demo box with Workplace and Workplace XT installed on the same profile. When you want to use another profile, you need to configure that profile. Basically you need to copy almost all settings from the first profile to second one.

    Don't do the same mistake like me! Follow the documentation carefully!

    P.S. If you want to setup Workplace to use container authentication: follow the documentation extremely carefully!
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-21T05:30:15Z  
    Hi,

    I had installed a demo box with Workplace and Workplace XT installed on the same profile. When you want to use another profile, you need to configure that profile. Basically you need to copy almost all settings from the first profile to second one.

    Don't do the same mistake like me! Follow the documentation carefully!

    P.S. If you want to setup Workplace to use container authentication: follow the documentation extremely carefully!
    Hi,

    Ok fine, and do you mean it is also possible to deploy both of them on the same websphere profile?
  • SystemAdmin
    SystemAdmin
    199 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-21T06:25:05Z  
    • nithisha
    • ‏2009-07-21T05:30:15Z
    Hi,

    Ok fine, and do you mean it is also possible to deploy both of them on the same websphere profile?
    Hi,

    I have a one box machine on AIX 5.3, WAS 6.1, TDS 6.3, DB2 9.5, CE 4.5, CSE 4.5, PE 4.5, AE 4.5, WPXT 1.1.3.5 and eForm.

    On WAS I have only one profile on which I had deployed CE, Workplace and Workplace XT.

    P.S. This type of installation is recommended only for demo purpose!
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-21T06:50:06Z  
    Hi,

    I have a one box machine on AIX 5.3, WAS 6.1, TDS 6.3, DB2 9.5, CE 4.5, CSE 4.5, PE 4.5, AE 4.5, WPXT 1.1.3.5 and eForm.

    On WAS I have only one profile on which I had deployed CE, Workplace and Workplace XT.

    P.S. This type of installation is recommended only for demo purpose!
    Ok, I get it. Now I have uninstalled the workplace, so only workplace xt resides on my websphere profile. But I am still unable to login to workplace xt. I have cross checked all the security configuration. I continue to get the error as below.So please let me know what could be the problem.

    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.

    Filter AE SecurityCheckFilter: filter is unavailable.

    IBM WebSphere Application Server
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-25T14:14:44Z  
    • nithisha
    • ‏2009-07-21T06:50:06Z
    Ok, I get it. Now I have uninstalled the workplace, so only workplace xt resides on my websphere profile. But I am still unable to login to workplace xt. I have cross checked all the security configuration. I continue to get the error as below.So please let me know what could be the problem.

    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.

    Filter AE SecurityCheckFilter: filter is unavailable.

    IBM WebSphere Application Server
    When I try to deploy both workplace and workplact xt on the same websphere profile, I get an error while signing into workplace xt. I have attached that screen shot. Please help me out.
  • nithisha
    nithisha
    52 Posts

    Re: Unable to logon to Workplace XT

    ‏2009-07-27T09:27:51Z  
    • nithisha
    • ‏2009-07-25T14:14:44Z
    When I try to deploy both workplace and workplact xt on the same websphere profile, I get an error while signing into workplace xt. I have attached that screen shot. Please help me out.
    Hi,

    Since we are working real time now, I would like to know more about deploying both of them on separate profiles.
    Since you asked me to configure another Websphere profile similar to the profile where I have deployed the workplace. Does this mean I need to create even the datasources all over again. Can you please throw more light on this.
  • ihsblog
    ihsblog
    1 Post

    Re: Unable to logon to Workplace XT

    ‏2010-03-26T00:47:01Z  
    • nithisha
    • ‏2009-07-21T05:30:15Z
    Hi,

    Ok fine, and do you mean it is also possible to deploy both of them on the same websphere profile?
    hi it is possible only cluster deployment only.
  • googlian
    googlian
    3 Posts

    Re: Unable to logon to Workplace XT

    ‏2010-06-22T14:26:25Z  
    • ihsblog
    • ‏2010-03-26T00:47:01Z
    hi it is possible only cluster deployment only.
    I am also facing this issue.
    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.
    Filter AE SecurityCheckFilter: filter is unavailable.

    Env:
    WAS 6.1.0.17
    P8 4.5.1
    XT 1.1.4 FP 3
    on same WS profile - AE and XT using same CPs, OS

    XT Logs:
    2010-06-22 13:58:31,614 ERROR ebContainer : 3 CryptoHelper.java:93 EncryptionException:getCipher() - throw Problem initializing encryption/decryption with keyId 1b1c1081, size 256 bits. java.home=D:\Programs\IBM\WebSphere\AppServer\java\jre. Cause: java.security.InvalidKeyException: Illegal key size or default parameters
    com.filenet.wcm.api.EncryptionException: Problem initializing encryption/decryption with keyId 1b1c1081, size 256 bits. java.home=D:\Programs\IBM\WebSphere\AppServer\java\jre. Cause: java.security.InvalidKeyException: Illegal key size or default parameters
    at com.filenet.wcm.api.impl.CryptoHelper.getCipher(CryptoHelper.java:93)
    at com.filenet.wcm.api.impl.CryptoHelper.doEncryptOrDecrypt(CryptoHelper.java:104)
    at com.filenet.wcm.api.impl.SessionImpl.getTokenSymmetric(SessionImpl.java:771)
    at com.filenet.wcm.api.impl.SessionImpl.getToken(SessionImpl.java:741)
    at com.filenet.ae.toolkit.server.util.credentials.UserTokenUtil.getUserToken(UserTokenUtil.java:131)
    at com.filenet.ae.toolkit.server.servlet.filter.SecurityCheckFilter.doFilter(SecurityCheckFilter.java:50)
    at com.ibm.ws.webcontainer.filter.FilterInstanceWrapper.doFilter(FilterInstanceWrapper.java:190)

    Please let me know how I could resolve this issue.
  • SystemAdmin
    SystemAdmin
    199 Posts

    Re: Unable to logon to Workplace XT

    ‏2010-06-30T01:08:16Z  
    • googlian
    • ‏2010-06-22T14:26:25Z
    I am also facing this issue.
    SRVE0232E: Internal Server Error.
    Exception Message: [Filter AE SecurityCheckFilter]: filter is unavailable.
    Filter AE SecurityCheckFilter: filter is unavailable.

    Env:
    WAS 6.1.0.17
    P8 4.5.1
    XT 1.1.4 FP 3
    on same WS profile - AE and XT using same CPs, OS

    XT Logs:
    2010-06-22 13:58:31,614 ERROR ebContainer : 3 CryptoHelper.java:93 EncryptionException:getCipher() - throw Problem initializing encryption/decryption with keyId 1b1c1081, size 256 bits. java.home=D:\Programs\IBM\WebSphere\AppServer\java\jre. Cause: java.security.InvalidKeyException: Illegal key size or default parameters
    com.filenet.wcm.api.EncryptionException: Problem initializing encryption/decryption with keyId 1b1c1081, size 256 bits. java.home=D:\Programs\IBM\WebSphere\AppServer\java\jre. Cause: java.security.InvalidKeyException: Illegal key size or default parameters
    at com.filenet.wcm.api.impl.CryptoHelper.getCipher(CryptoHelper.java:93)
    at com.filenet.wcm.api.impl.CryptoHelper.doEncryptOrDecrypt(CryptoHelper.java:104)
    at com.filenet.wcm.api.impl.SessionImpl.getTokenSymmetric(SessionImpl.java:771)
    at com.filenet.wcm.api.impl.SessionImpl.getToken(SessionImpl.java:741)
    at com.filenet.ae.toolkit.server.util.credentials.UserTokenUtil.getUserToken(UserTokenUtil.java:131)
    at com.filenet.ae.toolkit.server.servlet.filter.SecurityCheckFilter.doFilter(SecurityCheckFilter.java:50)
    at com.ibm.ws.webcontainer.filter.FilterInstanceWrapper.doFilter(FilterInstanceWrapper.java:190)

    Please let me know how I could resolve this issue.
    This crypto-related exception is probably not related to the other stuff in this thread. It looks like you have specified maximum strength crypto keys (I think that's one of the questions during install) but you might not have the unlimited strength crypto policy files in your JRE.

    This link should help you get started on resolving that: https://www.ibm.com/developerworks/java/jdk/security/
  • googlian
    googlian
    3 Posts

    Re: Unable to logon to Workplace XT

    ‏2010-07-07T18:48:51Z  
    This crypto-related exception is probably not related to the other stuff in this thread. It looks like you have specified maximum strength crypto keys (I think that's one of the questions during install) but you might not have the unlimited strength crypto policy files in your JRE.

    This link should help you get started on resolving that: https://www.ibm.com/developerworks/java/jdk/security/
    This issue has been resolved.
    Reinstall of JCE for Java 1.4+ (in Appserver JRE) works like a charm.

    Thanks WJ.
  • MPSERVICES
    MPSERVICES
    1 Post

    Re: Unable to logon to Workplace XT

    ‏2012-11-03T07:00:06Z  
    This crypto-related exception is probably not related to the other stuff in this thread. It looks like you have specified maximum strength crypto keys (I think that's one of the questions during install) but you might not have the unlimited strength crypto policy files in your JRE.

    This link should help you get started on resolving that: https://www.ibm.com/developerworks/java/jdk/security/
    Hi.. Thank You very much..issue solved.. after replacing the two jars (local_policyand US_export_policy) in C:\Program Files\IBM\WebSphere\AppServer\java\jre\lib\security path.