Topic
  • 5 replies
  • Latest Post - ‏2013-12-13T13:23:00Z by 5P5H_剑_凌
igorM
igorM
302 Posts

Pinned topic How to disable buffer or force Cognos to use refreshed data from data sourc

‏2009-07-17T10:25:11Z |
Hi,
I have created report in Cognos v8.4 Report Studio to access relational data from data source. I get correct values from database. Then I have inserted new data in relational table and re-run report and got the same values as the first time. It looks like Cognos is using some kind of buffer to more quickly return data. How to disable buffer or how to force Cognos to execute SQL every time it is executed?

Is there any buffer size or refresh time to set?
Regards,
igorM
Updated on 2009-07-20T08:40:57Z at 2009-07-20T08:40:57Z by igorM
  • SystemAdmin
    SystemAdmin
    15496 Posts

    Re: How to disable buffer or force Cognos to use refreshed data from data sourc

    ‏2009-07-17T12:43:50Z  
    Hi IgorM,

    you can disable the local cache for every Query in you Report. Just change to the properties of the query and set the value of the entry Use Local Cache to no (see attached image).

    Regards
    jbohn
  • igorM
    igorM
    302 Posts

    Re: How to disable buffer or force Cognos to use refreshed data from data sourc

    ‏2009-07-20T06:30:17Z  
    Hi IgorM,

    you can disable the local cache for every Query in you Report. Just change to the properties of the query and set the value of the entry Use Local Cache to no (see attached image).

    Regards
    jbohn
    Hi,
    I have looked into this settings and can't find "Properties - Query" settings. Please see attached picture. What should I do to get "Properties - Query" window settings displayed?
    Regards
  • igorM
    igorM
    302 Posts

    Re: How to disable buffer or force Cognos to use refreshed data from data sourc

    ‏2009-07-20T08:06:46Z  
    • igorM
    • ‏2009-07-20T06:30:17Z
    Hi,
    I have looked into this settings and can't find "Properties - Query" settings. Please see attached picture. What should I do to get "Properties - Query" window settings displayed?
    Regards
    Hi,
    I found out: right click on crosstab and select "Go to Query" and "Properties - Query" window is displayed. The second options is to go to "Query Explorer" window and select "Query 1" (my query) and the same window is displayed.

    I have set "Use Local Cache" to No but as I see data are not getting updated in report when report is rerun. I have also try to reboot Cognos server computer and cache is still not flashed. But I see data get updated if I save report with different name and run report. So report is working fine, just refreshing (caching) data is not working.

    Any idea what could be wrong? Is there any other settings I need to set?
    Thanks for help,
    igorM
  • igorM
    igorM
    302 Posts

    Re: How to disable buffer or force Cognos to use refreshed data from data sourc

    ‏2009-07-20T08:40:57Z  
    • igorM
    • ‏2009-07-20T08:06:46Z
    Hi,
    I found out: right click on crosstab and select "Go to Query" and "Properties - Query" window is displayed. The second options is to go to "Query Explorer" window and select "Query 1" (my query) and the same window is displayed.

    I have set "Use Local Cache" to No but as I see data are not getting updated in report when report is rerun. I have also try to reboot Cognos server computer and cache is still not flashed. But I see data get updated if I save report with different name and run report. So report is working fine, just refreshing (caching) data is not working.

    Any idea what could be wrong? Is there any other settings I need to set?
    Thanks for help,
    igorM
    Hi,
    PROBLEM SOLVED!

    If in Cognow Viewer is selected "Keep this version" and "Save Report" then in Cognos Connection new button is displayed. If on Cognos Connection I click on report name (in my case "podpora") then saved state of report is displayed - the same behaviour if "view the output version for this report" is clicked (icon market by arrow). But if "run with options" button is clicked then the newest report is displayed.

    I have deleted this version by clicking on "view the output version for this report" button and then "manage versions" and deleted saved version. Now report is running OK.

    See attached picture.
    igorM
  • 5P5H_剑_凌
    5P5H_剑_凌
    1 Post

    Re: How to disable buffer or force Cognos to use refreshed data from data sourc

    ‏2013-12-13T13:23:00Z  
    Hi IgorM,

    you can disable the local cache for every Query in you Report. Just change to the properties of the query and set the value of the entry Use Local Cache to no (see attached image).

    Regards
    jbohn

    It's useful for me.