Topic
7 replies Latest Post - ‏2009-07-31T12:57:48Z by SystemAdmin
SystemAdmin
SystemAdmin
90 Posts
ACCEPTED ANSWER

Pinned topic PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Center

‏2009-07-16T07:50:53Z |
Hi all.

We make a try to install PowerVM Lx86 on our SLES10 SP2 PPC system what is runing insight of LPAR in IBM POWER 550 server. We met a problem with x86 world activation through yast - activation wizard are unable to bind this x86 jail to Novell Customer Center (assign an license to it and bring access to software repos for rug) - yast shows error message like "None of the installed products can be registered at the Novell registration server."

I read through RedBooks for PowerVM lx86 and do not found any extra steps to perform in case of LSES10 (for RHEL there is extra sections thas explains details about x86 world activation).

I want to please for support/clue/hint :) What should we do in this case? Is there any changes in SLES x86 world activation algorithm?

Thanks in advance!
Updated on 2009-07-31T12:57:48Z at 2009-07-31T12:57:48Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    90 Posts
    ACCEPTED ANSWER

    Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Center

    ‏2009-07-17T16:47:10Z  in response to SystemAdmin
    Hi,

    From your description this seems like a SLES configuration issue. Have
    you tried registering manually?

    $ runx86
    $ su -
    $ suse_register -a regcode-sles=YourRegistrationCode -a email=YourEmailAddress

    You may also find some assistance on the Linux Tech Support Forum
    http://www.ibm.com/developerworks/forums/forum.jspa?forumID=160

    After trying the suggestions above, If you are still have difficulties
    please let us know.
  • SystemAdmin
    SystemAdmin
    90 Posts
    ACCEPTED ANSWER

    Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Center

    ‏2009-07-20T10:59:38Z  in response to SystemAdmin
    Hi.

    Unfortunately manual registration do not helped - it ends with similar error message.

    SUSE-Test:~ # suse_register -a regcode-sles=XXXXXXXXXXXXX -a email=our.ncc.profile@email.com
    None of the installed products can be registered at the Novell registration server.
    SUSE-Test:~ # uname -a
    Linux SUSE-Test-AP 2.6.16.60-0.39.3 #1 SMP Mon May 11 11:46:34 UTC 2009 i686 i686 i386 GNU/Linux

    As far as I know recently Nowell changed it's licensing policy for SLES x86 and SLES ppc (now this products can not share same licensing key).
    Can it be the source of this issue?

    Thank you for answer.
    • SystemAdmin
      SystemAdmin
      90 Posts
      ACCEPTED ANSWER

      Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Cente

      ‏2009-07-21T14:49:34Z  in response to SystemAdmin
      Hello

      If you have SLES on Power entitlement then to the best of my current knowledge you should be allowed x86 entitlement for Lx86 usage. I am currently seeking further clarification on this and the process of how it happens.

      May I ask two questions:
      1) Do you have SLES on Power entitlement already setup and working?
      2) What makes you think Novell has changed it's licensing policy? I couldn't find any detailed information on this. Do you have a link?

      I will update you further when I have more information.
      • SystemAdmin
        SystemAdmin
        90 Posts
        ACCEPTED ANSWER

        Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Cente

        ‏2009-07-22T06:59:18Z  in response to SystemAdmin
        >1) Do you have SLES on Power entitlement already setup and working?

        Yes. We done SLES 10 SP2 PPC installation and activation in LPAR - it works fine. This is a "host" system where we would like to setup PowerVM Lx86 and run one of our x86 aplications what do not have an version for POWER platform. We hope it will works fine in PowerVM Lx86.

        >2) What makes you think Novell has changed it's licensing policy? I couldn't find any detailed information on >this. Do you have a link?

        This is long-long story...
        We have POWER 550 server, it have been bought in the beginning of 2009 (in January AFAIR). We bought also SLES 10 SP2 as OEM with this server in the same time. Server have been installed, splited into two LPARs, and in the each of LPARs SLES 10 have been installed and activated without any problem.

        Recently we decide to reinstall Linux in one of the LPARs (we used same activation code and same DVD installation media as before) and met a problem with SLES activation - it do not accepted the old activation code that we used before for it's activation in time of first installation. We start a support case for this issue with Novell Customer Center support guys. They investigated issue and provided us with new activation codes what we used for reinstallation. Now SLES in that LPAR is running with new activation code. Here is detailed information from Novell KB that describe our problem:
        http://www.novell.com/support/viewContent.do?externalId=7003495

        I been trying to activate Lx86 world with both activation codes - with old (what now is suspended for ppc) and with new one (what we got as a replacement). Unfortunately both without success.
        • SystemAdmin
          SystemAdmin
          90 Posts
          ACCEPTED ANSWER

          Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Cente

          ‏2009-07-29T08:51:28Z  in response to SystemAdmin
          Thank you for your reply and information. It is our current understanding that Novell's licensing policy may change but only for version 11 onwards. It is possible that this change has effected earlier versions. We are currently working at clarifying this with Novell.

          Whilst we clarify the situation have you had the opportunity to contact Novell and ask them whether you need an additional activation for the x86 world?
          • SystemAdmin
            SystemAdmin
            90 Posts
            ACCEPTED ANSWER

            Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Cente

            ‏2009-07-30T09:38:14Z  in response to SystemAdmin
            I have sent a question to Novell Customer Response Center with detailed description of activation issue that we met with Lx86 world, but do not get an answer from them jet...

            Recently we make a test try to run our x86 aplication insight of unactivated, just installed Lx86 world, and we found that this solution will not be good enought for us in terms of speed (application we need to run is heavy and is java-oriented).

            So right now this test project is stoped and we thinking about using of AIX 6.1 in that LPAR instead of SLES Linux PPC (because there is an native version for AIX of this java application).

            Thank for you support.
            • SystemAdmin
              SystemAdmin
              90 Posts
              ACCEPTED ANSWER

              Re: PowerVM lx86 and SLES10 - x86 world activation in Novell Customer Cente

              ‏2009-07-31T12:57:48Z  in response to SystemAdmin
              Thank you for letting us know your situation and apologies we do not have a response on the activation question yet either.

              With regards to the performance, if you could elaborate on what kind of performance you experienced and what speed would be fast enough to use the solution it would be helpful for us to aid in planning for future changes.

              If we can be of any further assistance please let us know.