Topic
  • 1 reply
  • Latest Post - ‏2009-06-11T12:02:44Z by lenin2k
SystemAdmin
SystemAdmin
6968 Posts

Pinned topic DSYC0698E

‏2009-06-11T04:00:41Z |
Eviroment:
Server DataBase:DB2_8.2
Mirro DataBase:DB2_9.1
DB2 Everyplace version : 9.1

Example:
There is a field in table called 'VALUE', varchar(20).
When insert 10 chinese characters(double-byte character) in this field. The Sync process will occured DSYC0698E error which means internal error on PDA screen.
Then I found insert more than 5 chinese characters could make the situation.
But 10 or 20 Englsh characters was OK.

Is there some limitation for chinese characters?
Updated on 2009-06-11T12:02:44Z at 2009-06-11T12:02:44Z by lenin2k
  • lenin2k
    lenin2k
    17 Posts

    Re: DSYC0698E

    ‏2009-06-11T12:02:44Z  
    Hi Wongd,

    I had the same error inserting special characters, I fixed it increasing the field's length in the source table.

    For example from VALUE VARCHAR(20) I modified to VALUE VARCHAR(40) and sync again.

    I think that in PDAs special characters covers more than 1 position in varchar fields.