Topic
  • 7 replies
  • Latest Post - ‏2011-12-27T21:01:20Z by prashanta.nc
prashanta.nc
prashanta.nc
99 Posts

Pinned topic Error while running transaction in workbench

‏2009-02-19T09:06:09Z |
Hi,

I just setup a new workspace using MDM toolkit for MDM 8.5... All steps went fine and I could see the data sources, the database and the configuration getting created correctly. However when I run a sample transaction its giving me following error. Please let me know if you have faced this issue and the fix for this. Looks like something to do with the caching...!

Regards
PC

Exception :

2009-02-19 14:11:18,796 ORB.thread.pool : 1 INFO com.dwl.management.config.cache.CacheFactory - Couldn't get the cache from CacheManager :ConfigSessionCacheLoader
com.ibm.mdm.cache.common.CacheException: java.lang.NoSuchMethodError: com/sun/xml/xsom/XSFacet.getValue()Ljava/lang/String;
2009-02-19 14:11:18,843 ORB.thread.pool : 1 ERROR com.dwl.base.requestHandler.beans.DWLServiceController - java.lang.NoSuchMethodError: com/sun/xml/xsom/XSFacet.getValue()Ljava/lang/String;
2009-02-19 14:11:20,359 ORB.thread.pool : 0 WARN com.dwl.base.util.DWLIDFactory - Exception in getting the instance PK identifier.
2009-02-19 14:11:20,421 ORB.thread.pool : 0 ERROR com.dwl.base.requestHandler.beans.DWLServiceController - java.lang.IllegalArgumentException: Exception_Configuration_NullConfigItem
Updated on 2011-12-27T21:01:20Z at 2011-12-27T21:01:20Z by prashanta.nc
  • SystemAdmin
    SystemAdmin
    938 Posts

    Re: Error while running transaction in workbench

    ‏2009-02-19T09:33:07Z  
    Hi,

    You have installed the WebSphere web services feature pack. This includes a new version of a jar which is incompatible with MDM Server.

    You need to uninstall the WebSphere test server (from Installation Manager) and then install it again, but this time do not select the optional web services feature pack.

    Hope that helps, Catherine.
  • prashanta.nc
    prashanta.nc
    99 Posts

    Re: Error while running transaction in workbench

    ‏2009-02-21T09:28:32Z  
    Hi,

    You have installed the WebSphere web services feature pack. This includes a new version of a jar which is incompatible with MDM Server.

    You need to uninstall the WebSphere test server (from Installation Manager) and then install it again, but this time do not select the optional web services feature pack.

    Hope that helps, Catherine.
    Thank you.... it works now after removing the fix.

    Regards
    PC
  • rcher
    rcher
    49 Posts

    Re: Error while running transaction in workbench

    ‏2010-08-12T11:32:24Z  
    Thank you.... it works now after removing the fix.

    Regards
    PC
    Hi Catherine/Prashanta ,

    From the post, I could understand that MDM does not work with the inatalled WSFP :(

    However my requirement is to build Web Services in JAX-WS. Hence I have installed the Web Services Feature Pack.
    I did :
    1) Upgraded the WAS to 6.1.0.17
    2) WAS JDK Uplift
    3) Upgraded Installation Manager to 1.3.0
    4) Updated RSA to 7.0.0.6
    5) Updated WAS with WSFP
    6) Installed WS Interim Fix Pack 53084
    7) Installed WASv6.1 Fix Pack 17 for Windows

    Is any way to make MDM work in this environment.

    Awaiting for the replies :)

    Regards,
    Elizabeth
  • prashanta.nc
    prashanta.nc
    99 Posts

    Re: Error while running transaction in workbench

    ‏2010-08-13T02:25:44Z  
    • rcher
    • ‏2010-08-12T11:32:24Z
    Hi Catherine/Prashanta ,

    From the post, I could understand that MDM does not work with the inatalled WSFP :(

    However my requirement is to build Web Services in JAX-WS. Hence I have installed the Web Services Feature Pack.
    I did :
    1) Upgraded the WAS to 6.1.0.17
    2) WAS JDK Uplift
    3) Upgraded Installation Manager to 1.3.0
    4) Updated RSA to 7.0.0.6
    5) Updated WAS with WSFP
    6) Installed WS Interim Fix Pack 53084
    7) Installed WASv6.1 Fix Pack 17 for Windows

    Is any way to make MDM work in this environment.

    Awaiting for the replies :)

    Regards,
    Elizabeth
    I am not sure if I was able to run workbench ever with WAS Fix Pack applied to development environment.

    This is history (Issue posted in early last year). Things might have changed with fix packs and higher versions. Me in your place would give a try.. (Provided I have sufficient time off course)

    Thanks
    PC
  • rcher
    rcher
    49 Posts

    Re: Error while running transaction in workbench

    ‏2010-08-13T04:25:38Z  
    I am not sure if I was able to run workbench ever with WAS Fix Pack applied to development environment.

    This is history (Issue posted in early last year). Things might have changed with fix packs and higher versions. Me in your place would give a try.. (Provided I have sufficient time off course)

    Thanks
    PC
    Hi Prashanta,

    Thanks a lot..

    As per my business requirement, I am using MDM 8.0.0
    Do u have any idea about any fix packs tht solves the issue ? Becoz this issues is a big concern for us :(

    Regards,
    Elizabeth
  • Jim.Krieger
    Jim.Krieger
    1 Post

    Re: Error while running transaction in workbench

    ‏2011-02-28T21:28:51Z  
    cgriffin wrote:
    Hi,

    You have installed the WebSphere web services feature pack. This includes a new version of a jar which is incompatible with MDM Server.

    You need to uninstall the WebSphere test server (from Installation Manager) and then install it again, but this time do not select the optional web services feature pack.

    Hope that helps, Catherine.

    It's comprehensive, Thanks for your sharing!
  • prashanta.nc
    prashanta.nc
    99 Posts

    Re: Error while running transaction in workbench

    ‏2011-12-27T21:01:20Z  
    • rcher
    • ‏2010-08-13T04:25:38Z
    Hi Prashanta,

    Thanks a lot..

    As per my business requirement, I am using MDM 8.0.0
    Do u have any idea about any fix packs tht solves the issue ? Becoz this issues is a big concern for us :(

    Regards,
    Elizabeth
    Not sure if this is required or not now.

    While doing a fix pack download for 8.5, I figured out 8.5.0.21 resolves this issue.

    ~PC