Topic
  • 13 replies
  • Latest Post - ‏2010-07-05T11:38:06Z by SystemAdmin
SystemAdmin
SystemAdmin
6089 Posts

Pinned topic WID 6.2 Issues = Could not create Java Virtual Machine

‏2009-01-28T21:24:12Z |
I've had WID 6.2 installed on windows xp sp2 for a while now and suddenly when I try to start it I get the error "Could not create Java Virtual Machine". After a few attempts I decided to uninstall it and try to reinstall. The install runs up until it's done installing eclipse and then suddently presents the exact same message. If I press ok the install continues and seems to progress to the WPS/WESB installation steps. Once reinstalled, I get the same error when trying to start.
Anyone else seen this?
Updated on 2010-07-05T11:38:06Z at 2010-07-05T11:38:06Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    6089 Posts

    WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-05-06T06:49:35Z  
    Hi

    am also facing the same issue... Can you please tel me the steps.. for resolving the problem.
    When am starting the WID6.2 am gettig the error "Could not create Java Virtual Machine"
  • VijayaR
    VijayaR
    81 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-05-06T18:42:31Z  
    Hi

    am also facing the same issue... Can you please tel me the steps.. for resolving the problem.
    When am starting the WID6.2 am gettig the error "Could not create Java Virtual Machine"
    Most likely JVM is unable to instantiate the heap requested on your machine.

    Try these steps.

    1. Open %WID_INSTALL_PATH%\eclipse.ini in notepad, make sure that you see the correct JRE following "-vm" tag like below


    -vm
    C:\IBM\WID62\jdk\jre\bin\javaw.exe
    -vmargs
    -Xquickstart
    -Xms512m
    -Xss2048k
    -Xmaxf0.1
    -Xminf0.05
    -Xmx1024m
    -Xgcpolicy:gencon
    -Xscmx96m
    -Xshareclasses:singleJVM,keep,nonfatal
    -Xnolinenumbers
    -XX:MaxPermSize=512M
    -Dsun.java2d.noddraw=true


    2. Make a backup of eclipse.ini and edit the file to comment/remove the below lines from the eclipse.ini file:

    -XmsXXm
    -XmxXXm

    3. Start eclipse from the command prompt by running eclipse.exe
    If the above works, you can test this theory by running the standalone JVM as follows:

    Run the below command from the path %WID_INSTALL_PATH%\jdk\jre\bin

    java -Xmx1024m -version

    It should error with something like "JVMJ9VM015W Initialization error for library j9gc24(2): Failed to instantiate heap; 1G requested
    Could not create the Java virtual machine."
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-07-28T20:12:00Z  
    Hi

    seen your posting and wondered if you managed to resolve the JVM problem in WID

    Getting the same issue

    Thanks

    Martyn Hewitt
  • dhmlau
    dhmlau
    43 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-07-28T20:23:32Z  
    • MG_Daven
    • ‏2009-07-28T20:12:00Z
    Hi

    seen your posting and wondered if you managed to resolve the JVM problem in WID

    Getting the same issue

    Thanks

    Martyn Hewitt
    Hi,
    Can you try to delete the java shared resources? For Windows, it's under c:\Document and Settings\<user id>\Local Settings\Aplication Data\javasharedresources
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-07-28T20:35:29Z  
    • dhmlau
    • ‏2009-07-28T20:23:32Z
    Hi,
    Can you try to delete the java shared resources? For Windows, it's under c:\Document and Settings\<user id>\Local Settings\Aplication Data\javasharedresources
    Nothing exists in this directory i'm afraid

    Should I perform a full uninstall but it takes neary 30 mins

    Thanks

    Martyn
  • dhmlau
    dhmlau
    43 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-07-28T20:38:17Z  
    • MG_Daven
    • ‏2009-07-28T20:35:29Z
    Nothing exists in this directory i'm afraid

    Should I perform a full uninstall but it takes neary 30 mins

    Thanks

    Martyn
    You mean that directory does not exist?
    Actually for me, it's under
    C:\Documents and Settings\Administrator\Local Settings\Application Data\javasharedresources
    even I'm not using the Administrator id. Try if it's there.
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-07-28T20:48:46Z  
    • dhmlau
    • ‏2009-07-28T20:38:17Z
    You mean that directory does not exist?
    Actually for me, it's under
    C:\Documents and Settings\Administrator\Local Settings\Application Data\javasharedresources
    even I'm not using the Administrator id. Try if it's there.
    working now...yes you were right under the admin user

    The eclipse.ini also needed changing as per previous post

    Thanks for your help

    Martyn
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2009-08-18T15:19:34Z  
    • MG_Daven
    • ‏2009-07-28T20:48:46Z
    working now...yes you were right under the admin user

    The eclipse.ini also needed changing as per previous post

    Thanks for your help

    Martyn
    I have had to re-install WID 6.2 on D:\ibm\WID62 on a new machine....the install gets to the "Installing : complete for eclipse" and then errors with "Could not create Java Virtual Machine".

    The install then fails and the log states Error during "complete" phase:

    I've removed contents of C:\Documents and Settings\Administrator_profile\Local Settings\Application Data\javasharedresources and there isn't an eclipse.ini to remove the -XmsXXm / -XmxXXm parameters

    Any advice would be appreciated

    Thanks

    Martyn
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2010-06-30T16:02:45Z  
    • MG_Daven
    • ‏2009-08-18T15:19:34Z
    I have had to re-install WID 6.2 on D:\ibm\WID62 on a new machine....the install gets to the "Installing : complete for eclipse" and then errors with "Could not create Java Virtual Machine".

    The install then fails and the log states Error during "complete" phase:

    I've removed contents of C:\Documents and Settings\Administrator_profile\Local Settings\Application Data\javasharedresources and there isn't an eclipse.ini to remove the -XmsXXm / -XmxXXm parameters

    Any advice would be appreciated

    Thanks

    Martyn
    hello there,

    I know it's been a bit less than one year but i just ran into the exact some problem (hangs at the same point, removed everything form javasharedresources and no eclipse.ini to edit) and spent the whole day trying to find how to go about it. Did you manage to solve yours and if yes could you please share your wisdom with me.
    Thanks a lot in advance
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2010-07-01T08:00:08Z  
    hello there,

    I know it's been a bit less than one year but i just ran into the exact some problem (hangs at the same point, removed everything form javasharedresources and no eclipse.ini to edit) and spent the whole day trying to find how to go about it. Did you manage to solve yours and if yes could you please share your wisdom with me.
    Thanks a lot in advance
    I seem to remember I performed the tests in this thread

    Run the below command from the path %WID_INSTALL_PATH%\jdk\jre\bin

    java -Xmx1024m -version

    and ended up creating a batch file whilst I installed the code which just copied in the eclipse.ini with the lower vm Xmx setting, eg 512. I was finding this was being over written during installation time.

    During installation the eclipse.ini is created with the incorrect jvm setting and then the bath file copied over the correct setting and the install completed ok

    Seems an odd workaround but worked for me during install.

    Hope this helps
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2010-07-01T15:01:17Z  
    • MG_Daven
    • ‏2010-07-01T08:00:08Z
    I seem to remember I performed the tests in this thread

    Run the below command from the path %WID_INSTALL_PATH%\jdk\jre\bin

    java -Xmx1024m -version

    and ended up creating a batch file whilst I installed the code which just copied in the eclipse.ini with the lower vm Xmx setting, eg 512. I was finding this was being over written during installation time.

    During installation the eclipse.ini is created with the incorrect jvm setting and then the bath file copied over the correct setting and the install completed ok

    Seems an odd workaround but worked for me during install.

    Hope this helps
    Hello there,
    I'm really glad you answered so promptly. I'm afraid I dont have that path (WID does not get installed so when it fails it kind of 'rollbacks' and the folder WID62 gets deleted. Nonetheless, I've tried (what so many people suggest) creating a sample (hello world.java) program and run it with -Xmx1024m option and indeed I get an error message. But if I got it right the solution was for you to create that batch file that overwrites the eclipse.ini. Could you please share with me that file or at least -should that not be possible- give me some hints of how to create such a file and mainly how to invoke it (in the right timing) to overwrite eclipse.ini, before the installation fails.
    Thanks again for your support but I'm sure you understand what i'm going through
    Looking forward to your answer.
  • MG_Daven
    MG_Daven
    6 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2010-07-02T15:05:25Z  
    Hello there,
    I'm really glad you answered so promptly. I'm afraid I dont have that path (WID does not get installed so when it fails it kind of 'rollbacks' and the folder WID62 gets deleted. Nonetheless, I've tried (what so many people suggest) creating a sample (hello world.java) program and run it with -Xmx1024m option and indeed I get an error message. But if I got it right the solution was for you to create that batch file that overwrites the eclipse.ini. Could you please share with me that file or at least -should that not be possible- give me some hints of how to create such a file and mainly how to invoke it (in the right timing) to overwrite eclipse.ini, before the installation fails.
    Thanks again for your support but I'm sure you understand what i'm going through
    Looking forward to your answer.
    I simply created a dos batch file which copied the correct eclipse.ini into the correct path

    as soon as the folder was created I started the batch file and when eclipse.ini was created it was over written immediatley and the install completed
    eg,
    @ECHO OFF
    :top
    COPY C:\ECLIPSE.INI C:\TEMP\
    GOTO TOP

    Regards

    Martyn
  • SystemAdmin
    SystemAdmin
    6089 Posts

    Re: WID 6.2 Issues = Could not create Java Virtual Machine

    ‏2010-07-05T11:38:06Z  
    • MG_Daven
    • ‏2010-07-02T15:05:25Z
    I simply created a dos batch file which copied the correct eclipse.ini into the correct path

    as soon as the folder was created I started the batch file and when eclipse.ini was created it was over written immediatley and the install completed
    eg,
    @ECHO OFF
    :top
    COPY C:\ECLIPSE.INI C:\TEMP\
    GOTO TOP

    Regards

    Martyn
    Hello,

    Martyn, thanks a lot for your support.
    I finally made it working. To be honest, i was about to try your suggestion when i got a reply from IBM, pointing to the following link
    http://www-01.ibm.com/support/docview.wss?uid=swg21410196&myns=swgrat&mynp=OCSSDV2W&mync=R which helped as well!
    Thanks again. I really appreciate it