Topic
  • 4 replies
  • Latest Post - ‏2008-12-19T14:48:25Z by dkremen
SystemAdmin
SystemAdmin
228 Posts

Pinned topic OAT 2.23 Server Administration/Configuration error

‏2008-12-12T07:09:27Z |
Hello,
I tried to upgrade from AOT 2.22 to 2.23 and when using the link menu "Server Administration/Configuration error", i got a blank page with an "internal server error" (HTTP 500) in the apache log.
When searching in the source code i changed the line 162 in the function get_dynamic_onconfig_params($idsadmin) ( file modules/onconfig.php ):
from
return $this->$dynamic_onconfig_params;
to
return $dynamic_onconfig_params;

and was able to get it working.
Regards, Jeremy
Updated on 2008-12-19T14:48:25Z at 2008-12-19T14:48:25Z by dkremen
  • SystemAdmin
    SystemAdmin
    228 Posts

    Re: OAT 2.23 Server Administration/Configuration error

    ‏2008-12-12T07:12:08Z  
    I made a little error in the previous message, the file is :lib/onconfig.php .
  • dkremen
    dkremen
    7 Posts

    Re: OAT 2.23 Server Administration/Configuration error

    ‏2008-12-16T09:44:41Z  
    Hi,

    I also get blank screens for half of the options in OAT. V2.22 worked fine, though. I'm connecting to IDS 11.50.FC2 on AIX 5.3.
    Your workaround didn't work for me.
    However, I believe the best forum to report a problem with OAT is:

    http://www.iiug.org/forums/oat
  • SystemAdmin
    SystemAdmin
    228 Posts

    Re: OAT 2.23 Server Administration/Configuration error

    ‏2008-12-18T10:13:06Z  
    • dkremen
    • ‏2008-12-16T09:44:41Z
    Hi,

    I also get blank screens for half of the options in OAT. V2.22 worked fine, though. I'm connecting to IDS 11.50.FC2 on AIX 5.3.
    Your workaround didn't work for me.
    However, I believe the best forum to report a problem with OAT is:

    http://www.iiug.org/forums/oat
    You're right, i discovered it after posting here. I note a few tips to correct some issues on 2.23 on this post :
    http://www.iiug.org/forums/oat/index.cgi/read/144
    Please let me know if this help or not.
    Regards.
  • dkremen
    dkremen
    7 Posts

    Re: OAT 2.23 Server Administration/Configuration error

    ‏2008-12-19T14:48:25Z  
    You're right, i discovered it after posting here. I note a few tips to correct some issues on 2.23 on this post :
    http://www.iiug.org/forums/oat/index.cgi/read/144
    Please let me know if this help or not.
    Regards.
    It helped me, but that wasn't my main concern. I got A LOT of blank screens, but the cause was too old CSDK, when using the latest everything works fine.

    Regards