IC5Notice: We have upgraded developerWorks Community to the latest version of IBM Connections. For more information, read our upgrade FAQ.
Topic
  • 5 replies
  • Latest Post - ‏2013-02-11T07:01:23Z by SystemAdmin
jrkshankar
jrkshankar
11 Posts

Pinned topic MXES -RMI connection with active directory setting

‏2008-12-10T18:32:21Z |
Hi All,

I have an issue related to RMI as follows:

I am developing a client application using Java's Swing and I need to call Maximo with using MBO .Maximo with LDAP setting.Maximo login with IE its working fine.
If i am using client application the following message is displayed
"access#mxauthdisabled"

Thanks in advance for helping.

Cheers
Shankar K
Updated on 2013-02-11T07:01:23Z at 2013-02-11T07:01:23Z by SystemAdmin
  • bkearson
    bkearson
    6 Posts

    Re: MXES -RMI connection with active directory setting

    ‏2009-05-15T11:46:38Z  
    Hello,

    I have just enabled LDAP in Maxio 7 and now I can't connect to the RMI port anymore.
    Did you find a solution to this?
    If so how did you solve this?

    Thank you,

    Bill
  • bkearson
    bkearson
    6 Posts

    Re: MXES -RMI connection with active directory setting

    ‏2010-03-28T18:58:01Z  
    • bkearson
    • ‏2009-05-15T11:46:38Z
    Hello,

    I have just enabled LDAP in Maxio 7 and now I can't connect to the RMI port anymore.
    Did you find a solution to this?
    If so how did you solve this?

    Thank you,

    Bill
    Any updates on this?
    You have to hit weblogic first to authenticate when pass this authenticated token to the RMI server.
    Any code examples out there?
  • swkim90049
    swkim90049
    278 Posts

    Re: MXES -RMI connection with active directory setting

    ‏2011-10-27T03:08:01Z  
    • bkearson
    • ‏2010-03-28T18:58:01Z
    Any updates on this?
    You have to hit weblogic first to authenticate when pass this authenticated token to the RMI server.
    Any code examples out there?
    check your \maximo\applications\maximo\maximouiweb\webmodule\WEB-INF\web.xml

    We had some issues with security-constraints being commented out.

    Somehow LDAP changes we had put in were reverted to an older version.
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: MXES -RMI connection with active directory setting

    ‏2013-02-11T02:50:44Z  
    • bkearson
    • ‏2010-03-28T18:58:01Z
    Any updates on this?
    You have to hit weblogic first to authenticate when pass this authenticated token to the RMI server.
    Any code examples out there?
    Is anybody found solution for this?
  • SystemAdmin
    SystemAdmin
    5842 Posts

    Re: MXES -RMI connection with active directory setting

    ‏2013-02-11T07:01:23Z  
    Is anybody found solution for this?
    Hello;

    To connect Security Enabled maximo;
    You should use launchWebSphereThinClient in C:\IBM\SMP\maximo\tools\maximo\j2eeclient...

    Just check the file, and you can see the instructions in the file to get it done...

    Have a good day...