• 1 reply
  • Latest Post - ‏2008-12-11T17:02:50Z by SystemAdmin
262 Posts

Pinned topic Installing on Ubuntu 8.10

‏2008-12-01T14:56:00Z |
I have done the following so far. I downloaded the .rpm and converted it to .deb using alien. I installed libmotif3 and created a launcher including this in the command /opt/ibm/iSeriesAccess/bin/setup5250

I installed the .deb file and when I click on the launcher, the screen flashed for a brief moment and thats it. What else do I need to do to get this to work?
Updated on 2008-12-11T17:02:50Z at 2008-12-11T17:02:50Z by SystemAdmin
  • SystemAdmin
    262 Posts

    Re: Installing on Ubuntu 8.10

    I suggest this procedure:

    1- requirements :Ubuntu-restricted-extras with ie4linux installed. (this is another story !!)

    2- after the deb. installation (sudo dpkg -i "filename.deb") you must create some link with command:
    sudo ln -sf /opt/ibm/iSeriesAccess/lib/ /usr/lib/
    sudo ln -sf /opt/ibm/iSeriesAccess/lib/ /usr/lib/
    sudo ln -sf /opt/ibm/iSeriesAccess/lib/ /usr/lib/
    sudo ln -sf /opt/ibm/iSeriesAccess/bin/ibm5250 /usr/bin/ibm5250
    sudo ln -sf /opt/ibm/iSeriesAccess/bin/setup5250 /usr/bin/setup5250

    3- If you use a different language you must update the locales (i'm Italian) for ex:
    sudo gedit /var/lib/locales/supported.d/local

    and add the locales ( for ex. it_IT@euro ISO-8859-15 )

    after reconfigure locales:
    sudo dpkg-reconfigure locales

    4- I had a problem with the messagges error icon (it show as a little square (very little)
    I have correct this with commands:
    sudo mkdir /usr/lib/X11/bitmaps
    sudo ln -s /usr/include/X11/bitmaps/xm_error /usr/lib/X11/bitmaps/xm_error

    5- Finally :) you cam create a launcher including the command line:
    /opt/ibm/iSeriesAccess/bin/ibm5250 -LANGID xx_XX (for italian language : LANGID it_IT)

    With this method i've installed about 10 Client Acces into Ubuntu 8.04 without problem.

    Good look

    Piero.Brocca at
    Vicenza - Italy