Topic
  • 18 replies
  • Latest Post - ‏2012-10-02T14:47:11Z by SystemAdmin
SystemAdmin
SystemAdmin
30895 Posts

Pinned topic IE Secure and nonsecure items error when access WPS 6.1 HTTPS

‏2008-11-17T23:52:37Z |
Hi,

After doing a fresh install of Portal 6.1 and accessing it via HTTPS on: https://localhost:10035/wps/myportal , Internet Explorer will always issuing the following error:

This page contains both secure and nonsecure items.

This error is shown on login page and all subsequent authenticated pages.
Is there a fix to resolve this problem, without having to adjust the IE settings to ignore these errors?
We believe the problem is stemming from a javascript that is incorrectly building a HTTP URL for images when portal is accessed via HTTPS, our suspicions at the moment is on "semanticTagService.js", altho we are not sure how to fix it.

Any help is appreciated.

Ming
Updated on 2012-10-02T14:47:11Z at 2012-10-02T14:47:11Z by SystemAdmin
  • jwbarnes
    jwbarnes
    3336 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2008-11-18T02:13:00Z  
    there is currently an open problem record out there on this issue but has not been solved yet


    IBM Certified System Administrator -- WebSphere Portal V6.0, V5.1, V5.0
    IBM Certified Solution Developer -- WebSphere Portal V5.1, v6.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
  • ShilpaIBM
    ShilpaIBM
    10 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-06-08T06:25:02Z  
    Hi Jim,

    I am using Portal 6.1.0.1. Do we have a fix for this problem now? I am unable
    to find a fix on the ibm site. I have configured a HTTP server to handle all my https requests and still the pop-ip of 'secure/non secure items' is appearing.

    Please help!!

    Regards,
    Shilpa.
  • SystemAdmin
    SystemAdmin
    30895 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-06-12T06:42:59Z  
    • ShilpaIBM
    • ‏2009-06-08T06:25:02Z
    Hi Jim,

    I am using Portal 6.1.0.1. Do we have a fix for this problem now? I am unable
    to find a fix on the ibm site. I have configured a HTTP server to handle all my https requests and still the pop-ip of 'secure/non secure items' is appearing.

    Please help!!

    Regards,
    Shilpa.
    We had raised a PMR for this. The APAR number is PK82320.
    It is available in IBM Fix central

    Thanks,
    Jishnu
  • Carefx
    Carefx
    7 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-06-28T21:08:52Z  
    We had raised a PMR for this. The APAR number is PK82320.
    It is available in IBM Fix central

    Thanks,
    Jishnu
    Hello,

    I am getting this same error even after applying the APAR listed. I am using ISA 2006 from microsoft and it seems that there is a reference to the acutal host name of the server which causes the secure/non-secure message. I know there is a fix for TAM with html filters but ive yet to find the solution for ISA.
    The issue is that there is a javascript file, semanticTagService.js, that has the non-ISA url (http://carefx-wps-1-prod:10040/) hard-coded in the file. ISA isn't going to translate that link. That js is loading a CSS file "/wps_semanticTag/ui/styles.css". So, when you load the page and js runs, you now have a secure site requesting non-secure content from a different domain. Apparently IE's security settings still won't allow mixed content cross domain.

    any help is greatly appreciated.
  • Kaus
    Kaus
    6 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-07-01T08:41:30Z  
    This is a very known issue in WebSphere Portal and it was supposed to be fixed in WPS 6.1.0.2 version(fix included in this fixpack). Firefox and other browsers do not show a similar warning when browsing the same content.

    This popup usually appears if Secure Socket Layer (SSL) is configured in the environment, for example, by placement of a router or other device that terminates SSL in front of the Portal servers.

    One of the following options can be implemented to prevent the dialog box from appearing:

    • Reconfigure the browser to suppress the warning as follows:
    1. From the Internet Explorer menu, choose Tools --> Internet Options --> Security, and determine the appropriate zone for your WebSphere Portal site.

    2. Select the appropriate zone and click Custom Level.

    3. In the Settings dialog box, scroll down to the Miscellaneous category --> "Display mixed content", and select Enable.

    4. Click OK to save the changes.

    • Manually modify one of the WebSphere Portal jsp files:
    NOTE: This workaround requires a change on the desktop and is unlikely to be a practical solution for most systems.
    1. Edit the head_djConfig.jspf file, located in <wp_profile_root>\installedApps\<node>\wps.ear\wps.war\<YourTheme>\html\Portal\

    2. Find the following line:
    <portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS"/> or any other file accessed as http.

    3. Modify this line as follows:
    <portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS" *forceAbsolute="true"*/>

    4. Save the default.jsp.

    5. Delete the <wp_profile_root>/temp/<node>/WebSphere_Portal directory and restart the server. This will force the jsps to recompile and should take care of the issue.
  • Carefx
    Carefx
    7 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-07-01T20:31:32Z  
    • Kaus
    • ‏2009-07-01T08:41:30Z
    This is a very known issue in WebSphere Portal and it was supposed to be fixed in WPS 6.1.0.2 version(fix included in this fixpack). Firefox and other browsers do not show a similar warning when browsing the same content.

    This popup usually appears if Secure Socket Layer (SSL) is configured in the environment, for example, by placement of a router or other device that terminates SSL in front of the Portal servers.

    One of the following options can be implemented to prevent the dialog box from appearing:

    • Reconfigure the browser to suppress the warning as follows:
    1. From the Internet Explorer menu, choose Tools --> Internet Options --> Security, and determine the appropriate zone for your WebSphere Portal site.

    2. Select the appropriate zone and click Custom Level.

    3. In the Settings dialog box, scroll down to the Miscellaneous category --> "Display mixed content", and select Enable.

    4. Click OK to save the changes.

    • Manually modify one of the WebSphere Portal jsp files:
    NOTE: This workaround requires a change on the desktop and is unlikely to be a practical solution for most systems.
    1. Edit the head_djConfig.jspf file, located in <wp_profile_root>\installedApps\<node>\wps.ear\wps.war\<YourTheme>\html\Portal\

    2. Find the following line:
    <portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS"/> or any other file accessed as http.

    3. Modify this line as follows:
    <portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS" *forceAbsolute="true"*/>

    4. Save the default.jsp.

    5. Delete the <wp_profile_root>/temp/<node>/WebSphere_Portal directory and restart the server. This will force the jsps to recompile and should take care of the issue.
    Thanks so much for the update! I am trying to update WPS to 6.1.0.2 but still having issues with it failing. It telling me that the extractor may be compromised and failing on the people finder portlet.

    ASX7017E: Exception received while running file "/opt/IBM/WebSphere/wp_profile/ConfigEngine/config/work/was/curJaclScript.jacl"; exception information: com.ibm.ws.scripting.ScriptingException: WASX7109E: Insufficient data for install task "MapWebModToVH
    2009-06-25T21:16:45-04:00 Result:
    2009-06-25T21:16:45-04:00 Result: wsadmin ADMA0010E: A Validation error occurred in task Selecting virtual hosts for Web modules. A virtual host is not specified for Web module People Finder Portlet with URI lwp.peoplefinder.jsr168.war,WEB-INF/web.xml."

    I will attempt to do what is listed below and see if that will work.

    Thanks,

    Rommel
  • Carefx
    Carefx
    7 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-07-11T22:14:45Z  
    • Carefx
    • ‏2009-07-01T20:31:32Z
    Thanks so much for the update! I am trying to update WPS to 6.1.0.2 but still having issues with it failing. It telling me that the extractor may be compromised and failing on the people finder portlet.

    ASX7017E: Exception received while running file "/opt/IBM/WebSphere/wp_profile/ConfigEngine/config/work/was/curJaclScript.jacl"; exception information: com.ibm.ws.scripting.ScriptingException: WASX7109E: Insufficient data for install task "MapWebModToVH
    2009-06-25T21:16:45-04:00 Result:
    2009-06-25T21:16:45-04:00 Result: wsadmin ADMA0010E: A Validation error occurred in task Selecting virtual hosts for Web modules. A virtual host is not specified for Web module People Finder Portlet with URI lwp.peoplefinder.jsr168.war,WEB-INF/web.xml."

    I will attempt to do what is listed below and see if that will work.

    Thanks,

    Rommel
    It seems adding absolute="true" does not fix it. Modifying the IE settings did work. IBM is looking into this now. Does anyone know of another workaround for ISA and this issue?

    thanks,

    rommel
  • Carefx
    Carefx
    7 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-08-06T04:42:56Z  
    • Carefx
    • ‏2009-07-11T22:14:45Z
    It seems adding absolute="true" does not fix it. Modifying the IE settings did work. IBM is looking into this now. Does anyone know of another workaround for ISA and this issue?

    thanks,

    rommel
    IBM is currently developing a fix for both WPS 6.1.0.1 and 6.1.0.2. I am testing the fix so that it resolves this issue when using ISA. PK91435 is in development at this time.
  • sashadelenn
    sashadelenn
    18 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-10-28T14:04:08Z  
    • Carefx
    • ‏2009-08-06T04:42:56Z
    IBM is currently developing a fix for both WPS 6.1.0.1 and 6.1.0.2. I am testing the fix so that it resolves this issue when using ISA. PK91435 is in development at this time.
    Have they released the fix yet? We have the same problems on our website. Its very fustrating when developing.
  • sashadelenn
    sashadelenn
    18 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-10-29T07:51:30Z  
    Have they released the fix yet? We have the same problems on our website. Its very fustrating when developing.
    This isent really a problem for us. We found the solution (for the time being), the only people who where getting this problem where domain users in our domain. We just changed the group policy to enable mixed mode. But for all the users else where they have to themselfs know how to chnage the security on there web browser. And changing the security is not good.

    It is very annoying. So if IBM does make a fix, i hope they publish it on their site!
  • deanthebean220
    deanthebean220
    1 Post

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2009-12-23T01:03:57Z  
    • Carefx
    • ‏2009-07-11T22:14:45Z
    It seems adding absolute="true" does not fix it. Modifying the IE settings did work. IBM is looking into this now. Does anyone know of another workaround for ISA and this issue?

    thanks,

    rommel
    Apparently the PK is in FP3. I have not tried that yet but I did find a way to make it work in FP2. The problem is in head_djConfig.jspf. This is in the theme so it gets especially dicey when deploying a custom theme in an external servlet. Here is the fix that is (so far) working for us:

    <script type="text/javascript">
    <%
    //scope all local variables so they disappear after this block is closed.
    {
    %><portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS" forceAbsolute="true"/><%

    // Bug:
    // The line above gives us http://my.secure.host.com/wps/themes/./dojo/portal_dojo/dojo/dojo.js
    // We should get https://my.host.com/MyCustomTheme/themes/dojo/portal_dojo/dojo/dojo.js

    // Parse the bogus URL
    String bogusDojoUrl = dojoJS.toString();
    String[] bogusDojoUrlParts = bogusDojoUrl.split("/");
    String host = bogusDojoUrlParts[2];
    String dojoBaseUrl = "";
    if (host.equalsIgnoreCase("my.secure.host.com")) {
    dojoBaseUrl = "https://" + host + "/MyCustomTheme/themes/dojo/portal_dojo/dojo/";;
    } else {
    dojoBaseUrl = "http://" + host + "/MyCustomTheme/themes/dojo/portal_dojo/dojo/";;
    }

    %>
    var djConfig = {parseOnLoad: false, isDebug: false, locale: '<%=userLocale%>'.replace(/_/, '-').replace(/iw/, 'he').toLowerCase(), baseUrl: '<%=dojoBaseUrl%>' }; //fix locale compatibility issues in Dojo
    <%}%>
    </script>
  • SystemAdmin
    SystemAdmin
    30895 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2010-06-18T15:17:53Z  
    Apparently the PK is in FP3. I have not tried that yet but I did find a way to make it work in FP2. The problem is in head_djConfig.jspf. This is in the theme so it gets especially dicey when deploying a custom theme in an external servlet. Here is the fix that is (so far) working for us:

    <script type="text/javascript">
    <%
    //scope all local variables so they disappear after this block is closed.
    {
    %><portal-logic:urlFindInTheme file="./dojo/portal_dojo/dojo/dojo.js" id="dojoJS" forceAbsolute="true"/><%

    // Bug:
    // The line above gives us http://my.secure.host.com/wps/themes/./dojo/portal_dojo/dojo/dojo.js
    // We should get https://my.host.com/MyCustomTheme/themes/dojo/portal_dojo/dojo/dojo.js

    // Parse the bogus URL
    String bogusDojoUrl = dojoJS.toString();
    String[] bogusDojoUrlParts = bogusDojoUrl.split("/");
    String host = bogusDojoUrlParts[2];
    String dojoBaseUrl = "";
    if (host.equalsIgnoreCase("my.secure.host.com")) {
    dojoBaseUrl = "https://" + host + "/MyCustomTheme/themes/dojo/portal_dojo/dojo/";;
    } else {
    dojoBaseUrl = "http://" + host + "/MyCustomTheme/themes/dojo/portal_dojo/dojo/";;
    }

    %>
    var djConfig = {parseOnLoad: false, isDebug: false, locale: '<%=userLocale%>'.replace(/_/, '-').replace(/iw/, 'he').toLowerCase(), baseUrl: '<%=dojoBaseUrl%>' }; //fix locale compatibility issues in Dojo
    <%}%>
    </script>
    Hi,

    I know, it has already been long discussion on this topic but just want to know, have we got any permanent fix for this?

    We are also facing same problem and need any permanent fix urgently.

    Would appreciate any help if anyone has got any solution for this.

    we are using portal 6.1.5.

    thanks much again..
    <Neeraj Sidhaye/>
    http://ExtremePortal.blogspot.com
  • mingcha
    mingcha
    1 Post

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2010-07-15T11:26:56Z  
    I can confirm 6.1.0.3 FP resolves this issue, as I no longer experience the HTTP/HTTPS mixed content popup error on IE.

    (I'm the original poster of the thread)

    Ming
  • SystemAdmin
    SystemAdmin
    30895 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2010-07-16T20:09:39Z  
    • mingcha
    • ‏2010-07-15T11:26:56Z
    I can confirm 6.1.0.3 FP resolves this issue, as I no longer experience the HTTP/HTTPS mixed content popup error on IE.

    (I'm the original poster of the thread)

    Ming
    Hi,

    Thanks for your response..

    i have resolved this issue.

    Thanks.
    <Neeraj Sidhaye/>
    Extreme Portal
  • SystemAdmin
    SystemAdmin
    30895 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2010-08-13T10:33:27Z  
    Hi,

    Thanks for your response..

    i have resolved this issue.

    Thanks.
    <Neeraj Sidhaye/>
    Extreme Portal
    Hi Neeraj,

    Could you please share the solution.

    Regards,
    shake
  • Edwin.Byrne
    Edwin.Byrne
    1 Post

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2011-02-21T21:51:20Z  
    Shake wrote:
    Hi Neeraj,

    Could you please share the solution.

    Regards,
    shake

    Can you share it with us? I've got the same problem, Thank you! Anybody can help?
  • sashadelenn
    sashadelenn
    18 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2012-02-22T11:17:34Z  
    Hi,

    Thanks for your response..

    i have resolved this issue.

    Thanks.
    <Neeraj Sidhaye/>
    Extreme Portal
    Hi, could you post your solution? We got the same problem again, we are curently on wp 6.1.0.3. I have tried all above earlier.
  • SystemAdmin
    SystemAdmin
    30895 Posts

    Re: IE Secure and nonsecure items error when access WPS 6.1 HTTPS

    ‏2012-10-02T14:47:11Z  
    • jwbarnes
    • ‏2008-11-18T02:13:00Z
    there is currently an open problem record out there on this issue but has not been solved yet


    IBM Certified System Administrator -- WebSphere Portal V6.0, V5.1, V5.0
    IBM Certified Solution Developer -- WebSphere Portal V5.1, v6.0

    The postings on this site are my own and do not necessarily represent the positions, strategies, or opinions of IBM
    We are using WPS 6.1.3. Previously we never used to get this IE Secure and nonsecure items popup. But recently after we moved our
    codes to Dev,UAT the popup has started coming. However its not there in our Prod environment. We have not moved our code to Prod environment yet.

    Not sure what is really causing this. Is it related to themes like Dojo or what. (Because the portal version is same in all environments)

    Any idea?