Topic
  • 3 replies
  • Latest Post - ‏2008-10-29T20:08:53Z by consijp
SystemAdmin
SystemAdmin
11979 Posts

Pinned topic Error while deploying EJB CODE using ant / ejbdeploy.sh in WAS 6.1 server

‏2008-07-31T10:23:53Z |
I am getting following error when trying to deploy EJB code in WAS 6.1 using ant ejbdeploy.sh
exec
exec Starting workbench.

exec
exec o0723.06
exec
exec *Error An unexpected exception was thrown. Halting execution.

exec
exec Shutting down workbench.

exec Error executing deployment: java.lang.ClassNotFoundException. Error is com.ibm.etools.ejbdeploy.batch.plugin.BatchExtension.
exec java.lang.ClassNotFoundException: com.ibm.etools.ejbdeploy.batch.plugin.BatchExtension
exec at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
exec at java.security.AccessController.doPrivileged(Native Method)
exec at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
exec at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
exec at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
exec at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
exec at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
exec at java.lang.Class.forName0(Native Method)
exec at java.lang.Class.forName(Class.java:164)
exec at com.ibm.etools.ejbdeploy.batch.impl.BootLoaderLoader.run(BootLoaderLoader.java:239)
exec at com.ibm.etools.ejbdeploy.batch.impl.BatchDeploy.execute(BatchDeploy.java:99)
exec at com.ibm.etools.ejbdeploy.EJBDeploy.execute(EJBDeploy.java:83)
exec at com.ibm.etools.ejbdeploy.EJBDeploy.main(EJBDeploy.java:313)
exec EJBDeploy level: o0723.06
exec Result: 1
did any one face this issue and able to resolve this?
what's the jar in which com.ibm.etools.ejbdeploy.batch.plugin.BatchExtension class is present.
Updated on 2008-10-29T20:08:53Z at 2008-10-29T20:08:53Z by consijp
  • SystemAdmin
    SystemAdmin
    11979 Posts

    Re: Error while deploying EJB CODE using ant / ejbdeploy.sh in WAS 6.1 serv

    ‏2008-08-08T05:39:41Z  
    the class is in ejbdeploy.jar under WebSphere\AppServer\deploytool\itp\plugins\com.ibm.etools.ejbdeploy\runtime, I am also facing same issue, the task used to run in 6.0.x and not working in 6.1..
    did u find any solution?
  • consijp
    consijp
    2 Posts

    Re: Error while deploying EJB CODE using ant / ejbdeploy.sh in WAS 6.1 server

    ‏2008-10-29T20:06:51Z  
    Was using ant.bat instead of ws_ant.bat Once I switched it then it could find the BatchExtension.class file.
    To:
    E:\Websphere6\AppServer\bin\ws_ant.bat
    From:
    E:\WebSphere6\AppServer\deploytool\itp\plugins\org.apache.ant_1.6.5
  • consijp
    consijp
    2 Posts

    Re: Error while deploying EJB CODE using ant / ejbdeploy.sh in WAS 6.1 server

    ‏2008-10-29T20:08:53Z  
    • consijp
    • ‏2008-10-29T20:06:51Z
    Was using ant.bat instead of ws_ant.bat Once I switched it then it could find the BatchExtension.class file.
    To:
    E:\Websphere6\AppServer\bin\ws_ant.bat
    From:
    E:\WebSphere6\AppServer\deploytool\itp\plugins\org.apache.ant_1.6.5
    Also wanted to note: IBM had us upgrade to 6.1.0.17 saying that it had a fix that would correct this issue. We did apply that patch but it had no impact on finding the BatchExtension. Using ws_ant solved the issue.