Topic
  • 10 replies
  • Latest Post - ‏2013-10-22T23:51:57Z by prap
SystemAdmin
SystemAdmin
4179 Posts

Pinned topic Debugging in MB 6.1

‏2008-07-16T14:14:10Z |
I am attempting to debug in Message Broker 6.1 but am having difficulty running the debugger.

I am going to Run->Debug->Message Broker Debug. I then have host name as "localhost" and Java debug port as 10002. I am able to select an execution group, however when I click "Debug" I get the following error message:
Some things to note:
Updated on 2009-06-19T01:00:09Z at 2009-06-19T01:00:09Z by Rayudu_AP
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2008-07-16T14:22:42Z  
    I am attempting to debug in Message Broker 6.1 but am having difficulty running the debugger.

    I am going to Run->Debug->Message Broker Debug. I then have host name as "localhost" and Java debug port as 10002. I am able to select an execution group, however when I click "Debug" I get the following error message when the debug session is attempting to connect to the JVM:

    "Can not communicate with the flow engine.

    Reason:
    The flow engine has been attached to another debug session, or
    The flow engine is not listening on the specified port, or
    The broker is in abend state, or
    Timeout occurred when connecting

    Resolution:
    Assign a debug port to the flow engine and restart the Broker, and
    Make sure that the Broker is not in the abend state, and
    Make sure that the Flow engine had started successfully or
    Increase the timeout setting in the Preference page

    Failed to attach to COMPNAME:10002"
    Some things to note:
    • I have been told that the RAC is not necessary for MB 6.1 and therefore I do not have this service running
    • Before I begin the debug and even connect to the default connfiguration manager, I am able to see that DataFlowEngine.exe is listening on port 10002 by using the netstat command

    My initial impression is that the DataFlowEngine may be stuck listening on another debug session, despite the fact that the computer has been restarted and all Websphere services have been stopped and restarted.
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2008-07-16T19:34:24Z  
    jibro,

    make sure you have compile with debug option on in your workspace -- java code needs to be compiled with debug on before it can be debugged.

    Also, in case you already don't know this:

    use these commands to find out the the status of if your execution group is listening on the right port:

    mqsichangeproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManager -n jvmDebugPort -v <debug port> --> this commands change the port to what you want it to be

    mqsireportproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManager -a --> this command will report the properties

    mqsireload <message broker instance name> -e <execution group name> --> use this command to reload the execution group instead of restarting whole message broker take debug port setting in effect
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2008-09-05T05:27:11Z  
    jibro,

    make sure you have compile with debug option on in your workspace -- java code needs to be compiled with debug on before it can be debugged.

    Also, in case you already don't know this:

    use these commands to find out the the status of if your execution group is listening on the right port:

    mqsichangeproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManager -n jvmDebugPort -v <debug port> --> this commands change the port to what you want it to be

    mqsireportproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManager -a --> this command will report the properties

    mqsireload <message broker instance name> -e <execution group name> --> use this command to reload the execution group instead of restarting whole message broker take debug port setting in effect
    Running the command I can see that the jvmDebugPort is the one that I have specified. However, when I run "netstat -a -b -p tcp" I do not see anything listening on port 9997. How do I start the listener for the debug mode?
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2008-09-05T05:54:06Z  
    Running the command I can see that the jvmDebugPort is the one that I have specified. However, when I run "netstat -a -b -p tcp" I do not see anything listening on port 9997. How do I start the listener for the debug mode?
    I was able to start listening on port 9997 by restarting the broker. For your reference I used the following command:
    
    mqsistop <broker name>
    

    followed by
    
    mqsistart <broker name>
    
  • Rayudu_AP
    Rayudu_AP
    3 Posts

    Re: Debugging in MB 6.1

    ‏2009-04-10T17:46:14Z  
    I was able to start listening on port 9997 by restarting the broker. For your reference I used the following command:
    <pre class="jive-pre"> mqsistop <broker name> </pre>
    followed by
    <pre class="jive-pre"> mqsistart <broker name> </pre>
    @Jawwad Hakeem,

    I am a newbie to message broker. I have gone through your post and I couldn't understand one thing. Have you developed the flow using ESQL or Java? May be this is a strange question for you but please clarify my doubt. I couldn't understand the reason why you have used JVM etc....Please clarify my doubt.
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2009-04-13T12:07:56Z  
    Hi ,

    Inorder to enable your debug you need to enable the port on execution group . you can right click on executution group and set a port number for it.

    Did you enable your execution group for debug at first place.
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2009-04-15T03:51:39Z  
    Hi,

    In order to run in debug mode follow the below procedure:

    a) Right click on execution group and assign a unique port number
    b) Restart the broker
    c) Go to Message Broker debug and select the execution group from the "Flow Engine" Option.

    Cheers,
    Anil LN
  • SystemAdmin
    SystemAdmin
    4179 Posts

    Re: Debugging in MB 6.1

    ‏2009-06-11T04:20:32Z  
    Hi,

    I am getting same error and try to do all you mentioned but no use, please see the attached screen shot of my error and any help is greatly appreciated.

    Thanks, !!
  • Rayudu_AP
    Rayudu_AP
    3 Posts

    Re: Debugging in MB 6.1

    ‏2009-06-19T01:00:09Z  
    Hi,

    I am getting same error and try to do all you mentioned but no use, please see the attached screen shot of my error and any help is greatly appreciated.

    Thanks, !!
    Hi Anil,

    You can follow the below procedure:

    1. First you have to assign a unique port number to the execution group - You can do this in two ways (either 'a' or 'b' as mentioned below):

    a. By using the command "mqsichangeproperties"
    mqsichangeproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManger -n jvmDebugPort -v <debug port> -- This command change the port to what you want it to be.

    mqsireportproperties <message broker instance name> -e <execution group name> -o ComIbmJVMManager -a --- This command report the properties

    b. By right clicking on the execution group:
    Right click the execution group and select "Properties" and set the port number in the input field of "JVM Debug Port". Now the debug mode of the execution group will automatically be enabled. This you can see by right clicking the execution group and selecting the "debug" option.

    2. Restart the broker
    3. Go to Message Broker Debug and select the execution group from the "select execution group" option.

    Hope this helps....
  • prap
    prap
    1 Post

    Re: Debugging in MB 6.1

    ‏2013-10-22T23:51:57Z  
    Hi,

    I am getting same error and try to do all you mentioned but no use, please see the attached screen shot of my error and any help is greatly appreciated.

    Thanks, !!

    Hi,

    I also got the same problem but when I tried the below steps then it worked fine..:)

    1) We need take a new port number (unique port number) other than the one present in the netstat list, as netstat gives all the ports that are currently in use.
    2) changed the port number of the execution group (from the broker console) to new port .
    3)Then re-started the broker (stopped & started the broker).
    4) After that , I have also verified the  "Java debug Port"  & the execution group from the debug configuration and both are matching with the set values.
    5) Then tried sending a message (test message) then it absolutely worked fine..

    Hope this helps..:)

     

    Updated on 2013-10-23T00:01:16Z at 2013-10-23T00:01:16Z by prap