Topic
4 replies Latest Post - ‏2008-06-05T14:31:22Z by SystemAdmin
SystemAdmin
SystemAdmin
262 Posts
ACCEPTED ANSWER

Pinned topic Image viewer (3489 emulation) and RVI

‏2008-06-04T17:11:29Z |
We recently began using Real Vision Imaging's document retention system, but were told we needed to use the Windows version of iSeries Access and their viewer to view saved images. I read recently that iSeries Access for Linux includes a (3489 emulation) image viewer, so I tried doing the view process. The image flashed on the screen, then the emulator died. When I ran Access from a terminal, I got the following error message:
  • glibc detected *** /opt/ibm/iSeriesAccess/bin/ibm5250: munmap_chunk(): invalid pointer: 0x095dea00 ***
followed by a backtrace and memory map.
We have no other applications that make use of the image viewer, so I don't know if the trouble is with RVI's software or with the image viewer. We are running iSeries Access 1.6 for 5.4.0 on CentOS 5.1. Does anybody else have the image viewer working with RVI software or with another application? Is there anything I could do that might get this working, or at least tell me where the problem is?
Updated on 2008-06-05T14:31:22Z at 2008-06-05T14:31:22Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    262 Posts
    ACCEPTED ANSWER

    Re: Image viewer (3489 emulation) and RVI

    ‏2008-06-04T17:31:11Z  in response to SystemAdmin
    If it helps, I have attached a core dump.

    Attachments

  • SystemAdmin
    SystemAdmin
    262 Posts
    ACCEPTED ANSWER

    Re: Image viewer (3489 emulation) and RVI

    ‏2008-06-04T17:31:16Z  in response to SystemAdmin
    Hello Michael, can you try with:

    #ibm5250 -debug -trace &> $HOME/debugibm5250.txt

    And attach the resulting file debugibm5250.txt just after the crash?

    Thanks!
  • SystemAdmin
    SystemAdmin
    262 Posts
    ACCEPTED ANSWER

    Re: Image viewer (3489 emulation) and RVI

    ‏2008-06-04T17:34:01Z  in response to SystemAdmin
    Thanks for your assistance. Here is the file you requested.
    • SystemAdmin
      SystemAdmin
      262 Posts
      ACCEPTED ANSWER

      Re: Image viewer (3489 emulation) and RVI

      ‏2008-06-05T14:31:22Z  in response to SystemAdmin
      Michael,

      Seems like a bug, smells like a bug and I'd say even taste like a bug. You can try calling IBM support or, wait until I have some time to spend trying to figure out what is going on, but if you can call IBM support I strongly suggest you to do so.

      Also, is there any chance to get a copy here of one of the image you want to display? the code that reads the image is throwing some errors that are likely later causing the crash, is this a TIFF image?