Topic
  • 8 replies
  • Latest Post - ‏2012-01-09T11:06:25Z by Frizz1977
SystemAdmin
SystemAdmin
2233 Posts

Pinned topic Enable JSP reloading in WASCE 1.1.0.2

‏2008-05-06T11:13:40Z |
Hi all,

I am using WASCE 1.1.0.2. I have a few web applications where I need to modify the JSP in it frequently.
Previously when I was using Tomcat, I was able to perform these changes without restarting the application.
But now with WASCE, everytime I change a JSP, I need to restart the application which will cause some service disruption.
I was wondering since WASCE also used Tomcat, is it possible to enable the JSP reloading?
Thanks.

Regards,
Gilbert
Updated on 2012-01-09T11:06:25Z at 2012-01-09T11:06:25Z by Frizz1977
  • Ashish_Jain
    Ashish_Jain
    274 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2008-05-06T12:53:21Z  
    Hi Gilberto,
    Something which is possible in Tomcat will obviously be possible in WAS CE.
    Can you try using the following:
    1) Open for <WASCE_HOME>/var/catalina/conf/web.xml in edit mode.
    2) Search for <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>.
    3) Add the following attribute in the same servlet class.

    <init-param>
    <param-name>reloading</param-name>
    <param-value>true</param-value>
    </init-param>

    Thanks
    Ashish
  • Ashish_Jain
    Ashish_Jain
    274 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2008-05-07T05:54:44Z  
    Hi Gilberto,
    Something which is possible in Tomcat will obviously be possible in WAS CE.
    Can you try using the following:
    1) Open for <WASCE_HOME>/var/catalina/conf/web.xml in edit mode.
    2) Search for <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>.
    3) Add the following attribute in the same servlet class.

    <init-param>
    <param-name>reloading</param-name>
    <param-value>true</param-value>
    </init-param>

    Thanks
    Ashish
    Also include
    <init-param>
    <param-name>checkInterval</param-name>
    <param-value>10</param-value>
    </init-param>
    here the time is in seconds.

    Thanks
    Ashish
  • Ashish_Jain
    Ashish_Jain
    274 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2008-05-07T11:17:06Z  
    Also include
    <init-param>
    <param-name>checkInterval</param-name>
    <param-value>10</param-value>
    </init-param>
    here the time is in seconds.

    Thanks
    Ashish
    You can also have a look at the following technote
    http://www-1.ibm.com/support/docview.wss?rs=2359&uid=swg21304458

    Thanks
    Ashish
  • SystemAdmin
    SystemAdmin
    2233 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2008-05-10T06:03:07Z  
    You can also have a look at the following technote
    http://www-1.ibm.com/support/docview.wss?rs=2359&uid=swg21304458

    Thanks
    Ashish
    Hi Ashish,

    Thanks for your advice.

    Regards,
    Gilbert
  • MohamedYehiya
    MohamedYehiya
    1 Post

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2011-12-14T10:26:01Z  
    Starting from WASCE 2.1.1.3 onwards, need to configure
    /var/catalina/conf/web.xml
    by

    <servlet>
    <servlet-name>jsp</servlet-name>
    <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
    <init-param>
    <param-name>development</param-name>
    <param-value>true</param-value>
    </init-param>
    </servlet>
  • Frizz1977
    Frizz1977
    3 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2012-01-06T14:42:28Z  
    Starting from WASCE 2.1.1.3 onwards, need to configure
    /var/catalina/conf/web.xml
    by

    <servlet>
    <servlet-name>jsp</servlet-name>
    <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
    <init-param>
    <param-name>development</param-name>
    <param-value>true</param-value>
    </init-param>
    </servlet>
    It doesn't work for me. I'm using eclipse,if I change a jsp the .car file doesn't change until I republish the application..
  • SystemAdmin
    SystemAdmin
    2233 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2012-01-09T06:25:51Z  
    • Frizz1977
    • ‏2012-01-06T14:42:28Z
    It doesn't work for me. I'm using eclipse,if I change a jsp the .car file doesn't change until I republish the application..
    Hi,
    Which WAS CE version do you use?

    For WAS CE 2.1.1.5, there has an explanation for this in var\catalina\conf\web.xml:

    <!-- checkInterval If development is false and checkInterval is -->
    <!-- greater than zero, background compilations are -->
    <!-- enabled. checkInterval is the time in seconds -->
    <!-- between checks to see if a JSP page needs to -->
    <!-- be recompiled. [0]

    Try to config as below:
    <servlet>
    <servlet-name>jsp</servlet-name>
    <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
    <init-param>
    <param-name>development</param-name>
    <param-value>false</param-value>
    </init-param>
    <init-param>
    <param-name>checkInterval</param-name>
    <param-value>10</param-value>
    </init-param>
    </servlet>
  • Frizz1977
    Frizz1977
    3 Posts

    Re: Enable JSP reloading in WASCE 1.1.0.2

    ‏2012-01-09T11:06:25Z  
    Hi,
    Which WAS CE version do you use?

    For WAS CE 2.1.1.5, there has an explanation for this in var\catalina\conf\web.xml:

    <!-- checkInterval If development is false and checkInterval is -->
    <!-- greater than zero, background compilations are -->
    <!-- enabled. checkInterval is the time in seconds -->
    <!-- between checks to see if a JSP page needs to -->
    <!-- be recompiled. [0]

    Try to config as below:
    <servlet>
    <servlet-name>jsp</servlet-name>
    <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
    <init-param>
    <param-name>development</param-name>
    <param-value>false</param-value>
    </init-param>
    <init-param>
    <param-name>checkInterval</param-name>
    <param-value>10</param-value>
    </init-param>
    </servlet>
    I use Wasce 3.0, the explanation in web.xml is the same.
    Probably eclipse doesn't update the .car file....