Topic
IC4NOTICE: developerWorks Community will be offline May 29-30, 2015 while we upgrade to the latest version of IBM Connections. For more information, read our upgrade FAQ.
No replies
SystemAdmin
SystemAdmin
895 Posts
ACCEPTED ANSWER

Pinned topic Problem using Dynamic Table

‏2008-04-04T11:46:45Z |
Hi ,
I could use some help with a couple of things

1. To display viewonly search results on a page , should Dynamic Table be used or DataPage Builder ?
2. Does dynamic table builder only read from a variable with the following format ?
<data>
<row>
.
.
</row>
<row>
.
.
</row>
</data>

I was trying to use a WSCall_reply variable which is of the following format

<_parties:searchPartiesResponse xmlns:_parties="http://NUAnnuityBPILibrary/SearchParties">
<partySearchResponse>
<loginStatus>
<loginSuccessful>true</loginSuccessful>
<status><statusCode>ISZ4012I</statusCode>
</status>
</loginStatus>
<partySearchResults>
<parties>
<identifier>..</identifier>
<title>MRS</title>
<forename>...</forename>
<lastName>...</lastName>
<address><addressLineOne>OVERTOWN FARMHOUSE</addressLineOne>
</address>
</parties>
<parties>
<parties>
<identifier>..</identifier>
<title>MRS</title>
<forename>...</forename>
<lastName>...</lastName>
<address><addressLineOne>OVERTOWN FARMHOUSE</addressLineOne>
</address>
</parties>
<parties>
</partySearchResults>
</partySearchResponse>
</_parties:searchPartiesResponse>
When i specify ${Variables/SearchService_reply/searchPartiesResponse/partySearchResponse/partySearchResults/parties}
in Source Data field , I get only the first row in the output page . Seems like the dynamic builder cannot pick up the rest of the <parties> elements.

Any one , please , any clue why this is happening?