Topic
  • 2 replies
  • Latest Post - ‏2008-03-11T05:04:42Z by Venkat@TCS
SystemAdmin
SystemAdmin
6056 Posts

Pinned topic Failure to install ITM 6.2 on AIX5.3 (64bit)

‏2008-03-10T16:38:56Z |
I executed an install and configuration of Unix OS Agent. No errors until I tried to start the UX agent.

Unable to start agent. Please, check log file. (traceKey:1205166496009)

log file:

exec(): 0509-036 Cannot load program kuxagent because of the following errors:
rtld: 0712-001 Symbol _DoIs was referenced
from module kuxagent(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol _Getctype__FPCc was referenced
from module kuxagent(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol _Getcvt__FPCc was referenced
from module kuxagent(), but a runtime definition
of the symbol was not found.
rtld: 0712-001 Symbol __ct__Q2_3std8_LocinfoFPCci was referenced
from module kuxagent(), but a runtime definition
of the symbol was not found.
rtld: 0712-002 fatal error: exiting.

Any ideas what to do?
Updated on 2008-03-11T05:04:42Z at 2008-03-11T05:04:42Z by Venkat@TCS
  • chrisrlayton
    chrisrlayton
    50 Posts

    Re: Failure to install ITM 6.2 on AIX5.3 (64bit)

    ‏2008-03-10T19:39:17Z  
    I resolved this issue by upgrading xlC to v8
  • Venkat@TCS
    Venkat@TCS
    41 Posts

    Re: Failure to install ITM 6.2 on AIX5.3 (64bit)

    ‏2008-03-11T05:04:42Z  
    Hello,
    AIX 5.3 ships with xlc.rte version 6.0.0.0. Upgrading the xlc runtime environment to 8.0.0.0 fixes the problem.

    The following command displays the version of the current runtime:
    lslpp -La |grep -i xlC

    sample output
    xlC.aix50.rte 6.0.0.13 C F C Set ++ Runtime for AIX 5.0
    xlC.cpp 6.0.0.0 C F C for AIX Preprocessor
    xlC.msg.en_US.cpp 6.0.0.0 C F C for AIX Preprocessor
    xlC.msg.en_US.rte 6.0.0.0 C F C Set ++ Runtime
    xlC.rte 6.0.0.0 C F C Set ++ Runtime

    The 8.0.0.0 version of the xlc runtime can be downloaded from "May 2005 IBM C++ Runtime Environment Components for AIX" (#4009788).

    ################################################################################

    To upgrade this runtime envt the AIX System should have the following pre-requisites:
    On AIX 5.3, the fileset bos.rte.libc must be at 5.3.0.3 or higher.

    ################################################################################

    Best of Luck.

    Regards,
    Veeran
    IBM Certified Advanced Deployment Professional - Tivoli.