Topic
7 replies Latest Post - ‏2008-02-26T17:58:30Z by SystemAdmin
SystemAdmin
SystemAdmin
3234 Posts
ACCEPTED ANSWER

Pinned topic HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

‏2008-02-14T13:53:49Z |
Hi everyone

I have a minor problem. My Suse linux 9 bladeservers are running Linux FC HBA driver failover.My SAN is DS4300. Is it possible to change failover to > Linux (multipath) RDAC failover instead of Linux FC HBA (ADT)?? The host type is Linux on the Storage Manager 9X. The ADT is already enabled, and I read a draft document, saying that you must disable (adt) mode before installing the RDAC linux driver on SLES9?? Has anyone seen/experience the same as I? Has anyone a description or a procedure on how to change the failver from HBA failover to RDAC driver failover on SuseLinux 9??

Best Regards
Joel
Updated on 2008-02-26T17:58:30Z at 2008-02-26T17:58:30Z by SystemAdmin
  • jmatica
    jmatica
    21 Posts
    ACCEPTED ANSWER

    Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

    ‏2008-02-20T16:06:57Z  in response to SystemAdmin
    first of all, my advise is: be careful in doing this kind of operations on a production server unless you fill more then confident..

    anyway,

    assuming you are using QLogic HBA:

    to disable HBA failover, add or modify this line in /etc/modprobe.conf or /etc/modprobe.conf.local

    options qla2xxx ql2xfailover=0

    then you have to rebuild a new ramdisk with mkinitrd

    reboot or reload the driver for the change to take effect.
    You can check if failover hba is on or off inspecting the file in /proc/scsi/qla2xxx, in the 2nd row you have:

    "Firmware version 3.03.19 IPX, Driver version 8.01.06fo" if failover hba is on,

    "Firmware version 3.03.19 IPX, Driver version 8.01.06" if failover hba is off

    Do this for each hba, then install and configure RDAC..

    mauro
    --

    Message was edited by: jmatica
    Updated on 2008-02-20T16:06:57Z at 2008-02-20T16:06:57Z by jmatica
    • SystemAdmin
      SystemAdmin
      3234 Posts
      ACCEPTED ANSWER

      Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

      ‏2008-02-26T13:27:12Z  in response to jmatica
      Hi
      first of all thanks for your reply. But first, I need to know if you must disable ADT/AVT mode on my Storage Manager 9.60 before youre installation continous of the RDAC driver for linux?

      Best Regards
      Joel Andersen
  • SystemAdmin
    SystemAdmin
    3234 Posts
    ACCEPTED ANSWER

    Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

    ‏2008-02-26T14:58:47Z  in response to SystemAdmin
    Answer is short: if you want to use RDAC, you have to disable AVT. You can do this using script or setting host type as LNXCL or LNXCLVMWARE.
    If you want another solution, such Qlogic Failover or linux native mpp, AVT must be enabled.
    Some passages from DS4000 Best Practices and Performance Tuning Guide”:
    • When using the Linux RDAC as the failover/failback driver, the host type should be set to LNXCLVMWARE instead of Linux. If Linux RDAC is not used, the host type of Linux must be used instead.
    • AVT is required if you are using the Qlogic Failover drivers.
    • SystemAdmin
      SystemAdmin
      3234 Posts
      ACCEPTED ANSWER

      Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

      ‏2008-02-26T15:39:48Z  in response to SystemAdmin
      Hi

      okay! Lastly, Just to mention that I only use one hba adapter for (Linux RDAC failover) for this solution and not 2 hba adapters. Can I still use RDAC failover on one hba adapter?
      Best Regards
      Joel
      • SystemAdmin
        SystemAdmin
        3234 Posts
        ACCEPTED ANSWER

        Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

        ‏2008-02-26T16:19:07Z  in response to SystemAdmin
        Did you correct zoning? HBA must see both DS4300 controllers, but storage controllers must not be visible to each other.
        It’s a special situations, I don’t remember how it’s named (something like “Single HBA”).
        Although it isn’t recommended by IBM, it’s supported and RDAC should be used in this situation.
        • SystemAdmin
          SystemAdmin
          3234 Posts
          ACCEPTED ANSWER

          Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

          ‏2008-02-26T17:26:38Z  in response to SystemAdmin
          hi

          I think you mean Single Path from the HBA. You must isolate the second path (1) or (0) depending what your zone config looks like. I think you must disable the second hba port (Ctrl Q) on the HBA bios and disable 0x100 or 0x200.
          (something like that!)
          The Hba has always 2 ports 0 and 1 - and in order to install Linux OS and W2k3 server it is always recommended to enable only 1 path to the controller A or B!

          Im not sure if can do Failover if you only use one Hba?!
          My zone is correct.
          Best Regards
          Joel Andersen
          • SystemAdmin
            SystemAdmin
            3234 Posts
            ACCEPTED ANSWER

            Re: HS20 SANboot bladeserver with SLES 9, RDAC failover or HBA failover.

            ‏2008-02-26T17:58:30Z  in response to SystemAdmin
            No. It’s described exactly as “ Single HBA configuration”
            You can look about in
            • “DS4000 Best Practices and Performance Tuning Guide”, chapter “11.1.4 HBA configurations One HBA on host and two controllers on DS4000”
            • “IBM System Storage DS4000 Storage Manager Version 9. Installation and Support Guide for Windows 2000/Server 2003, NetWare, ESX Server, and Linux”, chapter “1. Introduction. Creating the SAN-attached configuration”