Topic
  • 3 replies
  • Latest Post - ‏2007-12-24T10:56:12Z by SystemAdmin
SystemAdmin
SystemAdmin
1215 Posts

Pinned topic IBM Websphere Application Server admin console not opening

‏2007-12-21T13:22:40Z |
hi,

i am a newbie to IBM Websphere. i have installed it on Fedora core 5 OS. i am not able to get the admin console for the admin server.
I start the server using the following command:

root@localhost bin# ./startServer.sh server1

Output:

ADMU0116I: Tool information is being logged in file
/opt/IBM/WebSphere/AppServer/profiles/AppSh/logs/server1/startServer.log
ADMU0128I: Starting tool with the AppSh profile
ADMU3100I: Reading configuration for server: server1
ADMU3200I: Server launched. Waiting for initialization status.
ADMU3000I: Server server1 open for e-business; process id is 3330

the server starts but when i run the browser at localhost(http://localhost:9081/) i get this error:

Error 404: No target servlet configured for uri: /
Please help me out with this. Do i need to make any changes in the configuration.

Thanks
Updated on 2007-12-24T10:56:12Z at 2007-12-24T10:56:12Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1215 Posts

    Re: IBM Websphere Application Server admin console not opening

    ‏2007-12-21T17:17:38Z  
    rtisan@gmail.com escribió:
    hi,

    i am a newbie to IBM Websphere. i have installed it on Fedora core 5 OS. i am not able to get the admin console for the admin server.
    I start the server using the following command:

    root@localhost bin# ./startServer.sh server1

    Output:

    ADMU0116I: Tool information is being logged in file
    /opt/IBM/WebSphere/AppServer/profiles/AppSh/logs/server1/startServer.log
    ADMU0128I: Starting tool with the AppSh profile
    ADMU3100I: Reading configuration for server: server1
    ADMU3200I: Server launched. Waiting for initialization status.
    ADMU3000I: Server server1 open for e-business; process id is 3330

    the server starts but when i run the browser at localhost(http://localhost:9081/) i get this error:

    Error 404: No target servlet configured for uri: /
    Please help me out with this. Do i need to make any changes in the configuration.

    Thanks

    WAS is not supported in Fedora, so that could be part or your problem,
    but aside of that, assuming that it got installed correctly and 9081 is
    the port it got assigned (9080 is the default usually), the URL you
    should use to access the console is

    http://localhost:9081/ibm/console
    or
    http://localhost:9081/admin


    Juanma Martinez
  • SystemAdmin
    SystemAdmin
    1215 Posts

    Re: IBM Websphere Application Server admin console not opening

    ‏2007-12-24T10:45:33Z  
    rtisan@gmail.com escribió:
    hi,

    i am a newbie to IBM Websphere. i have installed it on Fedora core 5 OS. i am not able to get the admin console for the admin server.
    I start the server using the following command:

    root@localhost bin# ./startServer.sh server1

    Output:

    ADMU0116I: Tool information is being logged in file
    /opt/IBM/WebSphere/AppServer/profiles/AppSh/logs/server1/startServer.log
    ADMU0128I: Starting tool with the AppSh profile
    ADMU3100I: Reading configuration for server: server1
    ADMU3200I: Server launched. Waiting for initialization status.
    ADMU3000I: Server server1 open for e-business; process id is 3330

    the server starts but when i run the browser at localhost(http://localhost:9081/) i get this error:

    Error 404: No target servlet configured for uri: /
    Please help me out with this. Do i need to make any changes in the configuration.

    Thanks

    WAS is not supported in Fedora, so that could be part or your problem,
    but aside of that, assuming that it got installed correctly and 9081 is
    the port it got assigned (9080 is the default usually), the URL you
    should use to access the console is

    http://localhost:9081/ibm/console
    or
    http://localhost:9081/admin


    Juanma Martinez
    Hi Juanma,

    Thanks for your reply.

    i have tried with both the urls:

    http://localhost:9081/admin/console

    output: Error 404: No target servlet configured for uri: /admin/console

    and http://localhost:9081/ibm/console

    output:Error 404: No target servlet configured for uri: /ibm/console

    the installation went fine and Fedora core 5 does support WAS.

    May be i need to set some path to run admin console...Please let me know if you have a solution to the problem.

    Thanks
  • SystemAdmin
    SystemAdmin
    1215 Posts

    Re: IBM Websphere Application Server admin console not opening

    ‏2007-12-24T10:56:12Z  
    Hi Juanma,

    Thanks for your reply.

    i have tried with both the urls:

    http://localhost:9081/admin/console

    output: Error 404: No target servlet configured for uri: /admin/console

    and http://localhost:9081/ibm/console

    output:Error 404: No target servlet configured for uri: /ibm/console

    the installation went fine and Fedora core 5 does support WAS.

    May be i need to set some path to run admin console...Please let me know if you have a solution to the problem.

    Thanks
    rtisan@gmail.com escribió:
    Hi Juanma,

    Thanks for your reply.

    i have tried with both the urls:

    http://localhost:9081/admin/console

    output: Error 404: No target servlet configured for uri: /admin/console

    and http://localhost:9081/ibm/console

    output:Error 404: No target servlet configured for uri: /ibm/console

    the installation went fine and Fedora core 5 does support WAS.

    May be i need to set some path to run admin console...Please let me know if you have a solution to the problem.

    Thanks
    It might be that Fedora supports WAS but I don't see that WAS supports
    Fedora. You can check the supported platforms at:

    http://www-1.ibm.com/support/docview.wss?rs=180&uid=swg27006921

    Then it seems like 9081 is not your administration port, try then:

    http://localhost:9061/ibm/console

    or

    http;//localhost:9061/admin (not /admin/console, btw)
    if that doesn't work either, check with NETSTAT which ports get started
    after starting WAS.


    Juanma Martinez