Topic
  • 7 replies
  • Latest Post - ‏2012-07-18T11:27:21Z by SystemAdmin
SystemAdmin
SystemAdmin
1485 Posts

Pinned topic NullPointerException starting ODR

‏2007-12-20T22:41:56Z |
I'm running WAS 6.1.0.13 with XD 6.1.0.0 on Red Hat Linux. We are just starting to use XD and are building our environment. We have two IHS instances, two ODRs, and two app server instances in our cell. Everything is going fairly well, except we have a problem starting the ODRs after creation. Here are some of the errors from their startup log. App Server instances, node agents, deployment manager and IHS instances start up ok.

Anyone seen anything like this before? Any ideas where to check for misconfiguration?
12/20/07 15:58:23:634 CST 0000000a ODCHelper W ODCF0002E: Exception: unknown property name: staticweight.

12/20/07 15:58:23:680 CST 0000000a ODCService E ODCF0002E: Exception: jav
a.lang.NullPointerException
at com.ibm.ws.odc.nd.cell.TreeBuilder.<init>(TreeBuilder.java:229)
at com.ibm.ws.odc.xd.XDTreeBuilder.<init>(XDTreeBuilder.java:206)
at java.lang.Class.newInstanceImpl(Native Method)
at java.lang.Class.newInstance(Class.java:1263)
at com.ibm.ws.odc.util.FactoryHelper.getInstance(FactoryHelper.java:101)
at com.ibm.ws.odc.xd.XDODCFactory.createODCTreeBuilder(XDODCFactory.java
:45)
Caused by: java.lang.NullPointerException
at com.ibm.ws.dwlm.client.DWLMClientImpl.<init>(DWLMClientImpl.java:92)
at com.ibm.ws.xd.dwlm.client.BaseDWLMClientImpl.<init>(BaseDWLMClientImp
l.java:26)

Message was edited by: rol7805
Updated on 2012-07-18T11:27:21Z at 2012-07-18T11:27:21Z by SystemAdmin
  • DiegoSanchezSchenone
    2 Posts

    Re: NullPointerException starting ODR

    ‏2008-01-04T13:59:02Z  
    Hello, I have the same problem. I am running "WebSphere Application Server 6.1.0.13" and "WebSphere Extended Deployment 6.1.0.0" on Solaris 10.

    if anyone has seen this before and know how to fix it, please help me !

    Thanks.
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: NullPointerException starting ODR

    ‏2008-01-04T15:47:35Z  
    Hello, I have the same problem. I am running "WebSphere Application Server 6.1.0.13" and "WebSphere Extended Deployment 6.1.0.0" on Solaris 10.

    if anyone has seen this before and know how to fix it, please help me !

    Thanks.
    We received specific fix packs from IBM for this issue. They are:

    IFPK55536 & IFPK57460

    Per our sys admin, they must be applied in that order. Everything seems to be working ok now since those were applied.
  • DiegoSanchezSchenone
    2 Posts

    Re: NullPointerException starting ODR

    ‏2008-01-06T16:32:22Z  
    We received specific fix packs from IBM for this issue. They are:

    IFPK55536 & IFPK57460

    Per our sys admin, they must be applied in that order. Everything seems to be working ok now since those were applied.
    Yes, that's true. After I applied these packs, the server has started ok.

    Thank you.
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Websphere XD Profile creation problem

    ‏2008-01-18T15:52:47Z  
    Yes, that's true. After I applied these packs, the server has started ok.

    Thank you.
    HI ,

    We are in the process of Implementing Webpshere XD.

    We have successfully Installed Websphere 6.1.0.13 and then Webpshere XD operations Optimizations 6.1.0 .But using We are not able to create XD -DMGR profile .we are using manageprofiles.sh and using XD DMGR Template.It throws following error:
    WASX7091I: Executing script: "/apps/websphere/ws61/profileTemplates/xd_augment/actions/installXDPortlet.py"
    1/17/08 12:05:38:675 CST 0000000a AbstractShell E WASX7120E: Diagnostic information from exception with text "com.ibm.ws.scripting.ScriptingException: WASX7280E: An application with name "isclite" does not exist.
    " follows:

    com.ibm.ws.scripting.ScriptingException: WASX7280E: An application with name "isclite" does not exist.
    at com.ibm.ws.scripting.AbstractShell.setAndThrowScriptingException(AbstractShell.java:1599)
    and more error logs:
    wsadmin failed with exception = wsadmin task failed with return code :103

    thread>10</thread>
    <message>/apps/websphere/ws61/profileTemplates/dmgr/actions/deployAdminConsole.ant:38: wsadmin task failed with return code :103
    at com.ibm.websphere.ant.tasks.WsAdminInProcess.execute(WsAdminInProcess.java:334)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
    at org.apache.tools.ant.Task.perform(Task.java:364)
    at org.apache.tools.ant.Target.execute(Target.java:341)
    at org.apache.tools.ant.Target.performTasks(Target.java:369)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: Websphere XD Profile creation problem

    ‏2008-01-18T18:04:28Z  
    HI ,

    We are in the process of Implementing Webpshere XD.

    We have successfully Installed Websphere 6.1.0.13 and then Webpshere XD operations Optimizations 6.1.0 .But using We are not able to create XD -DMGR profile .we are using manageprofiles.sh and using XD DMGR Template.It throws following error:
    WASX7091I: Executing script: "/apps/websphere/ws61/profileTemplates/xd_augment/actions/installXDPortlet.py"
    1/17/08 12:05:38:675 CST 0000000a AbstractShell E WASX7120E: Diagnostic information from exception with text "com.ibm.ws.scripting.ScriptingException: WASX7280E: An application with name "isclite" does not exist.
    " follows:

    com.ibm.ws.scripting.ScriptingException: WASX7280E: An application with name "isclite" does not exist.
    at com.ibm.ws.scripting.AbstractShell.setAndThrowScriptingException(AbstractShell.java:1599)
    and more error logs:
    wsadmin failed with exception = wsadmin task failed with return code :103

    thread>10</thread>
    <message>/apps/websphere/ws61/profileTemplates/dmgr/actions/deployAdminConsole.ant:38: wsadmin task failed with return code :103
    at com.ibm.websphere.ant.tasks.WsAdminInProcess.execute(WsAdminInProcess.java:334)
    at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
    at org.apache.tools.ant.Task.perform(Task.java:364)
    at org.apache.tools.ant.Target.execute(Target.java:341)
    at org.apache.tools.ant.Target.performTasks(Target.java:369)
    at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1216
    Check your ulimit -n. Make sure it is 8192 or higher before running manageprofiles.sh. Also, make sure you create the profile you are trying to augment from an ND dmgr profile and you are using the profileTemplate from profileTemplates/xd_augment/dmgr

    Brian

    Message was edited by: bkmartin
    Updated on 2008-01-18T18:04:28Z at 2008-01-18T18:04:28Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: NullPointerException starting ODR

    ‏2012-03-26T14:15:55Z  
    Faced similar problem.
    Root cause was missing host entry in /etc/hosts file.
    When I was trying to ping current hostname, output was "ping: host name xxxxxxxx NOT FOUND"

    Was able to create profile successfully, once correct host entry added in /etc/hosts file.
  • SystemAdmin
    SystemAdmin
    1485 Posts

    Re: NullPointerException starting ODR

    ‏2012-07-18T11:27:21Z  
    Faced similar problem.
    Root cause was missing host entry in /etc/hosts file.
    When I was trying to ping current hostname, output was "ping: host name xxxxxxxx NOT FOUND"

    Was able to create profile successfully, once correct host entry added in /etc/hosts file.
    Thanks a lot Amith..
    Even I faced the same issue. But ur suggestions works for me.

    Thanks a lot..... :) :)