Topic
4 replies Latest Post - ‏2012-11-19T07:27:02Z by SystemAdmin
SystemAdmin
SystemAdmin
14225 Posts
ACCEPTED ANSWER

Pinned topic No cooperative portlet menu in RAD7

‏2007-12-13T20:58:18Z |
I've created two JSR-168 faces portlets in RAD7 for deployment on WPS 6.0. The portlets work fine on the server. Now I want to make them cooperative portlets, one sending a data object to the other. I open the portlet deployment descriptor in the project explorer and I can select the portlets but when I right-click to get to the cooperative portlet context menu I get nothing. In Web perspective I look under the Cooperative menu item in the Page menu and the options are inactive. Does anyone know what might be keeping me from making these cooperative? I don't think I've done anything different from the other examples of this I've done.

Reards,

Phil
Updated on 2012-11-19T07:27:02Z at 2012-11-19T07:27:02Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: No cooperative portlet menu in RAD7

    ‏2008-02-05T13:14:57Z  in response to SystemAdmin
    I had the same problem cause the project facet "JSR 168 Portlets on WebSphere Portal 6.0" wasn't enabled. You can enable it in the project's properties page und "project facets".

    Hope it helps,
    Lars
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: No cooperative portlet menu in RAD7

    ‏2008-02-13T22:08:10Z  in response to SystemAdmin
    I got around this the first time by recreating my (small at that time) project. It's back now and I've too much invested to do that again. Anyone got any other ideas? I've got the JSR-168 facet enabled and the faces facets. This happens, I believe, when I add a JSF cooperative trigger component and use that wizard to define the cooperative sending features of the portlet.
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: No cooperative portlet menu in RAD7

    ‏2008-02-13T22:12:38Z  in response to SystemAdmin
    I found a clue elsewhere and after I enabled the Portal capability I had the menus back.
    • SystemAdmin
      SystemAdmin
      14225 Posts
      ACCEPTED ANSWER

      Re: No cooperative portlet menu in RAD7

      ‏2012-11-19T07:27:02Z  in response to SystemAdmin
      You could also see, the option if you try creating a new portlet from menu and RAD shouts "This activity needs Portlet Environment to be enabled". Within few seconds the portal environment gets enabled and we can close the wizard. Menus should be back.

      Reg
      Sat