Topic
  • 1 reply
  • Latest Post - ‏2007-05-08T09:19:47Z by SystemAdmin
SystemAdmin
SystemAdmin
2340 Posts

Pinned topic Getting errors during upgrade from 3.5 to 3.6

‏2007-05-07T23:58:55Z |
Getting errors during upgrade from 3.5 to 3.6
I am upgrading the wbeclient from 2.5 to 3.6 and the default webclient works fine.
However I am encountering the following error with the custom webclient
( pointing to FMC1.FMCSYS1.FMCGRP1)
Quote:

Loading com.xxx.xxxx.web.MyCommandHandler:: java.lang.VerifyError: (class: com/xxx/xxxx/web/MyCommandHandler, method: onLogon signature: (Lcom/ibm/workflow/servlet/client/RequestContext;)V) Incompatible object argument for method call

My classpth for the WAS server is as follows:
F:\PROGRA~1\MQSERI~1\BIN\fmcjapi.jar
${MQ_INSTALL_ROOT}/java/lib/com.ibm.mqjms.jar
${MQ_INSTALL_ROOT}/java/lib/com.ibm.mq.jar
F:\PROGRA~1\MQSERI~1\BIN\fmcohcli.jar
F:\xxxx\MYCODE.jar
F:\PROGRA~1\IBM\SQLLIB\java\db2java.zip
I could successfully install another custom client for different application( pointing to FMC.FMCSYS.FMCGRP) running under different WAS instance on the same machine
Cna anyone help what this error is trying to tell?
Updated on 2007-05-08T09:19:47Z at 2007-05-08T09:19:47Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    2340 Posts

    Re: Getting errors during upgrade from 3.5 to 3.6

    ‏2007-05-08T09:19:47Z  
    Hi,

    I suggest to recompile your custom client and tell us whether this helped.

    The classpath that you mentioned: did you explicitely specify this
    classpath
    setting in your AppServer environment?!
    The WebClient should get the resources in the ear file.

    The customized client that works: is it an instance of the same customized
    client code
    that has the problems? I do not think that the configuration contributes
    to your specific problem.

    Volker Hoss
    IBM WebSphere Process Server Development