• 1 reply
  • Latest Post - ‏2007-04-30T15:41:43Z by Stan
1525 Posts

Pinned topic Derby synch with DB2 Everyplace - DSYC613E error

‏2007-04-28T18:03:32Z |
We have a derby database embedded in our application. We are trying to replicate the database with a network db2 database. So, I set up a DB2 8.2 and DB2 Everyplace 8.2 server on my machine. I set up a simple database, with one table, to test it with. I set up a mirror database. In DB2 Everyplace, I set up the subscription set and mapped the table to replicate. The data in the table replicates fine between the back-end database and the mirror database.

When I call the synch method in the code, I get the following error:
DSYC613E: Exception server error.
That's a pretty vague exception and I didn't find anything on the web to help me get any more detail. There were a couple problem reports on the error code, but they were for a previous release.

Here's more detail on from the print statements:
2007-04-27 19:31:33.156 0% DSYC1008I: Synchronizing subscription : test1
2007-04-27 19:31:33.156 0% DSYC1002I: Preparing message
2007-04-27 19:31:33.171 0% DSYC1003I: Sending message
2007-04-27 19:31:33.281 0% DSYC1002I: Preparing message
2007-04-27 19:31:33.281 0% DSYC1003I: Sending message
2007-04-27 19:10:36.625 0% DSYC613E: Exception server error.
2007-04-27 19:10:36.625 0% DSYC418E: Error server exception!!
2007-04-27 19:10:36.64 0% DSYC1013I: Synchronization failed
2007-04-27 19:10:36.64 0% DSYC5002Q: Inquery if user wants to continue with the synchronization or cancel 613

And, the log has this:
at javax.servlet.http.HttpServlet.service(
at javax.servlet.http.HttpServlet.service(

What I find expecially intersting about this is that I have deleted the subscription it is trying to synch (test1) because I messed it up the first time. It should not be trying to synch that subscription. I think the error is that it's trying to synch a subscription that doesn't exist anymore. I tried unconfiguring the Everyplace server and reconfiguring it, but that didn't work. I even uninstalled Everyplace and dropped the Everyplace databases from the DB2 server. But, after reinstalling it I still get this error.

I would really appreciate any suggestions you may have.
Updated on 2007-04-30T15:41:43Z at 2007-04-30T15:41:43Z by Stan
  • Stan
    267 Posts

    Re: Derby synch with DB2 Everyplace - DSYC613E error

    Hi Steve -
    I see you have posted this issue on the DB2e forum

    The error is from the sync server layer and best addressed by those folks - I don't see any Derby error codes (SQL Exceptions).