Topic
2 replies Latest Post - ‏2013-09-25T18:28:23Z by NidhishAggarwal
SystemAdmin
SystemAdmin
14225 Posts
ACCEPTED ANSWER

Pinned topic Can't compile anymore (RAD 7.0.0.1)

‏2007-03-23T11:57:25Z |
In our team we use RAD 7.0.0.1 for our WAS 6.0 projects. Suddenly I can't compile my Workspace, the other team members don't have this problem! We share our Sources with ClearCase LT.

I have installed 7.0.0.1 Fixpack. Reinstalled RAD entirely, created a new Workspace import the projects using a TeamProject set. I can't compile the projects. I tried refreshing the projects, clean the workspace, clean single projects. No class file is written. Even a simple Java Project wont compile, no class files are written to the output directory (bin).

Remember my teammates using the same source can compile, I cant. We use the same .classpath, .project, .ejb.xml, .....

Please help!

The Problems are:
CHKJ2800E: <local> interface at.racon_linz.elbi.bean.AdminSessionLocal, or one of its supertypes, cannot be reflected. Check the classpath. EJB_Elbi/ejbModule/META-INF ejb-jar.xml Enterprise bean: AdminSession 1174650028766 343920

CHKJ2907E: Type at.racon_linz.elbi.bean.AdminSession, or one of its supertypes, cannot be reflected. Check the classpath. EJB_Elbi/ejbModule/at/racon_linz/elbi/bean AdminSession.java line 5 1174650028766 343970

Project WEB_Common is missing required Java project: 'WSC_StyleguideNeu' WEB_Common Build path 1174650059298 344068

The project was not built since its build path is incomplete. Cannot find the class file for java.lang.Object. Fix the build path then try building this project JAVA_Common Unknown 1174650062610 344099

The type java.lang.Object cannot be resolved. It is indirectly referenced from required .class files EJBClient_Phase/ejbModule/at/racon_linz/elbi/phase PhaseHome.java line 1 1174650068673 344112
Updated on 2008-04-08T07:37:25Z at 2008-04-08T07:37:25Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    14225 Posts
    ACCEPTED ANSWER

    Re: Can't compile anymore (RAD 7.0.0.1)

    ‏2008-04-08T07:37:25Z  in response to SystemAdmin
    Hello I got exactly the same problem. Using the RAD 7.0.0.5 and CVS as a repostitory. Before to got the errors, I change the file ibm-ejb-jar-ext.xmi to modify some finder declarations. I had to return to previous version (a correct one) and after that i got a lot of errors like:

    CHKJ2907E: Type com.bo.retail.solutionset.impl.creditcarddetails.CreditCardDetailsPK, or one of its supertypes, cannot be reflected. Check the classpath. com/bo/retail/solutionset/impl/creditcarddetails CreditCardDetailsPK.java line 36 1207586318968 182037

    CHKJ2102E: Either a finder descriptor, or a matching custom finder method on the com.bo.retail.solutionset.impl.user.UserCMPBeanFinderObject class, must be defined. com/bo/retail/solutionset/impl/user UserHome.java line 62 1207586306062 181812

    If you have a light in the end of this tunnel please give me a hand.

    Best regards;
    GLAUBER MIRANDA CASANOVA
    • NidhishAggarwal
      NidhishAggarwal
      1 Post
      ACCEPTED ANSWER

      Re: Can't compile anymore (RAD 7.0.0.1)

      ‏2013-09-25T18:28:23Z  in response to SystemAdmin

      Hi All,

      I faced the same problem today, I would like to share the option which worked for me. (Although its not straightforward).

      Background: I tried all options of checking out latest code from SVN, clean, build etc. It did not work although with same code other developer m/c are good, I am not sure where RAD is caching this wrong information for classpath issue.

       

      Resolution: Finally I managed to get over of this problem by following steps -

      1. Within Ejb project delete the ejb for which RAD is complaining the classpath problem (By right click on ejb and select delete). For me it was complaining this issue only for one ejb out of 5 ejbs. So i deleted that perticuler ejb in tool.

      2. After that make sure you do clean and rebuild and check that RAD does not have any such classpath error for any other ejb. There could be other error in other java project which were reffeing the deleted ejb, that will be resolved after following step 3. With this approach I managed to clean the RAD cache holding unnecessary  ejb compilation error.

      3. Now close and reopen RAD, checkout latest code to bring back the deleted ejb code, perform clean and build again on ejb project. and finally it worked.!!! :)

       

      Regards

      Nidhish