Topic
3 replies Latest Post - ‏2009-03-06T20:42:17Z by ppinatti
SystemAdmin
SystemAdmin
104 Posts
ACCEPTED ANSWER

Pinned topic IBM Installation Toolkiton 7028-6E4

‏2007-02-20T16:23:27Z |
Hello,

I am having a problem trying to boot the IBM Installation Toolkit CD on a 7028-6E4. This is a slightly older pseries server that we were hoping to make use of once again.

The boot loader starts, does some stuff, then is a message: "Kernel Panic: Attempted to kill init!".

Here are the last few lines on the screen before this message:
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 332k freed
Waiting for hardware probing...
ipr: IBM Power RAID SCSI Device Driver version: 2.0.10.4 (September 14, 2005)
Initializing USB Mass Storage Driver...
usbcore: registered new driver usb-storage
USB Mass Storage support registered
Available memory is 16198844 KB
cdrom devices:
Can't find filesystem, sorry.
Send this output to support
Kernel panic: Attempted to kill init!
<0>Rebooting in 180 seconds..

Any help with this would be greatly appreciated. Thanks!
Updated on 2009-03-06T20:42:17Z at 2009-03-06T20:42:17Z by ppinatti
  • rceron
    rceron
    41 Posts
    ACCEPTED ANSWER

    Re: IBM Installation Toolkiton 7028-6E4

    ‏2007-02-22T12:27:21Z  in response to SystemAdmin
    Hello,

    First of all, I apologize for the 2-day delay to answer your post. My team was on holidays earlier this week.

    Thanks for posting the boot messages, this makes pinpointing your problem a lot easier. By having a look at them, the problem here is that the system is not being able to see your cd/dvdrom drive, thus it fails to mount the livecd file system, as we can see here:

    cdrom devices:

    In systems properly configured with this device, you would have seen something like:

    cdrom devices: hde

    Let's now work out what's happening to our system to prevent it from detecting your drive. First of all, are you running this machine with LPARs? If you are, is the cd/dvdrom hardware dedicated to your LPAR? You can check that by looking if the "mass storage device" has been assigned to your LPAR in your LPAR configuration screen.

    Let me know this information, then I can further assist you with this issue.

    Kind regards,
    Rodrigo Ceron
    • SystemAdmin
      SystemAdmin
      104 Posts
      ACCEPTED ANSWER

      Re: IBM Installation Toolkiton 7028-6E4

      ‏2009-03-06T20:12:00Z  in response to rceron
      Hi!
      I am trying to Install REDHAT EL 5.3 (the most recent version downloaded at the redhatsite) 4 PPC. First I have tried to install directly from the DBD redhat, but it hangs up to the first table of Checking CD Media. After I have tried to Install IBM Toolkit 4 Linux PPC, but, it freezes up before starting the graphical interface. After I have updated the sys firmware at the latest ver. and the Installation Toolkit DVD boots up successfully. Now I tried different times to install Redhat 5.3, but it freeze, when trying to Copy something.
      After several Times I have downloaded the first disk of RH EL 4.7 and it begins to install. My question is that is any method to install from the network, cause from what I have read and tried, I cannot select the method NFS, HTTP or ftp. In fact I have copied the content of the DVD 5.3 at the ftp site, but anyway I cannot select the ftp method of installind. It shows me just a interface to put the Distro Linux, .. and when I put the right ftp path,.. it says that is wrong.
      Is it possible that this kind of server can operate with the Linux OS? Thankyou
      Dritan Muco
      Customs, Albania
      • ppinatti
        ppinatti
        11 Posts
        ACCEPTED ANSWER

        Re: IBM Installation Toolkiton 7028-6E4

        ‏2009-03-06T20:42:17Z  in response to SystemAdmin
        Hello Dritan,

        currently the IBM Installation Toolkit has no support for RHEL 5.3 so you will not be able to install it. Support will be available in the next version of the Toolkit and is planned to be released in the next few months.

        Please, let me know if you have any further questions.

        Thank you

        Paulo Pinatti