Topic
  • 6 replies
  • Latest Post - ‏2013-05-10T08:57:40Z by franzw
SystemAdmin
SystemAdmin
9855 Posts

Pinned topic Problem with ITIM APIs

‏2006-11-22T10:45:03Z |
Hi

I am developing a Java application to access ITIM server using the following details which I am reading off the 'context.properties' file.
loginContext=ITIM
ejbUser=rasweb
ejbPwd=password
platformContextFactory=com.ibm.itim.apps.impl.websphere.WebSpherePlatformContextFactory
appServerURL=iiop://itim-server01 - (the actual entry in the file is 'appServerURL=iiop://localhost' but my ITIM server is installed on a remote machine)

When i run my code, i get the following exception:

com.ibm.itim.apps.ApplicationException: com/ibm/websphere/security/auth/CredentialDestroyedException
at com.ibm.itim.apps.InitialPlatformContext.createPlatformContext(InitialPlatformContext.java:156)
at com.ibm.itim.apps.InitialPlatformContext.<init>(InitialPlatformContext.java:77)
at TivoliDevOne.main(TivoliDevOne.java:85)
Caused by: java.lang.NoClassDefFoundError: com/ibm/websphere/security/auth/CredentialDestroyedException
at com.ibm.itim.apps.impl.websphere.WebSpherePlatformContextFactory.createContext(WebSpherePlatformContextFactory.java:37)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.ibm.itim.apps.InitialPlatformContext.createPlatformContext(InitialPlatformContext.java:149)
... 2 more
Any ideas? Your help would be much appreciated.

Thanks.
Updated on 2008-01-08T23:33:10Z at 2008-01-08T23:33:10Z by chandratondepu
  • Grantk
    Grantk
    321 Posts

    Re: Problem with ITIM APIs

    ‏2007-10-17T11:59:54Z  
    Hi, were you able to resolve this issue, as I currently receive the same error.

    Cheers.
  • SystemAdmin
    SystemAdmin
    9855 Posts

    Re: Problem with ITIM APIs

    ‏2007-10-17T12:29:16Z  
    • Grantk
    • ‏2007-10-17T11:59:54Z
    Hi, were you able to resolve this issue, as I currently receive the same error.

    Cheers.
    Make sure that following two jar files are present in your classpath:

    APP_SRV_HOME/lib/sas.jar
    APP_SRV_HOME/lib/wssec.jar
  • chandratondepu
    chandratondepu
    26 Posts

    Re: Problem with ITIM APIs

    ‏2008-01-08T23:33:10Z  
    Pls. ensure to have the below mentioned WAS runtime jar files in the classpath. The jar file names I have mentioned are for Websphere 6 Runtime.

    ecutils.jar
    idl.jar
    j2ee.jar
    lmproxy.jar
    namingclient.jar
    ras.jar
    sas.jar
    utils.jar
    wssec.jar
    wsexception.jar
    naming.jar
    bootstrap.jar
    emf.jar
    iwsorb.jar
    ffdc.jar
    ecsutils.jar
    ejbcontainerImpl.jar
    wasjmx.jar
    drs.jar
    admin.jar
    httpsession.jar
    dynacache.jar

    Also ensure to have the following ITIM jars in classpath:

    api_ejb.jar
    itim_api.jar
    itim_server.jar

    Hope this helps.

    Regards, Chandra Tondepu.
    Chandrasekhar.tondepu@gmail.com
  • ManishKumarPoddarAveksa
    2 Posts

    Re: Problem with ITIM APIs

    ‏2013-05-09T13:08:47Z  
    Pls. ensure to have the below mentioned WAS runtime jar files in the classpath. The jar file names I have mentioned are for Websphere 6 Runtime.

    ecutils.jar
    idl.jar
    j2ee.jar
    lmproxy.jar
    namingclient.jar
    ras.jar
    sas.jar
    utils.jar
    wssec.jar
    wsexception.jar
    naming.jar
    bootstrap.jar
    emf.jar
    iwsorb.jar
    ffdc.jar
    ecsutils.jar
    ejbcontainerImpl.jar
    wasjmx.jar
    drs.jar
    admin.jar
    httpsession.jar
    dynacache.jar

    Also ensure to have the following ITIM jars in classpath:

    api_ejb.jar
    itim_api.jar
    itim_server.jar

    Hope this helps.

    Regards, Chandra Tondepu.
    Chandrasekhar.tondepu@gmail.com

    Hi,

     

    Where can we find these jars, i am tired of searching it all around. please suggest some source, where i can get these Jars.

    or else could any one please mail me on mpoddar@aveksa.com

     

     

    Thanks,

    Manish Poddar

  • ManishKumarPoddarAveksa
    2 Posts

    Re: Problem with ITIM APIs

    ‏2013-05-09T13:09:17Z  
    Make sure that following two jar files are present in your classpath:

    APP_SRV_HOME/lib/sas.jar
    APP_SRV_HOME/lib/wssec.jar

    Hi,

     

    Where can we find these jars, i am tired of searching it all around. please suggest some source, where i can get these Jars.

    or else could any one please mail me on mpoddar@aveksa.com

     

    Thanks,

    Manish Poddar

  • franzw
    franzw
    339 Posts

    Re: Problem with ITIM APIs

    ‏2013-05-10T08:57:40Z  

    Hi,

     

    Where can we find these jars, i am tired of searching it all around. please suggest some source, where i can get these Jars.

    or else could any one please mail me on mpoddar@aveksa.com

     

     

    Thanks,

    Manish Poddar

    The necessary jars are included in your WAS and ITIM setup. They are not delivered separately.

    The necessary jars may vary from WAS/ITIM version - so you need to check the documentation and the examples library of your ITIM setup.

    If you after that still has problem you should raise a PMR to get help from IBM support.

    HTH

    Regards

    Franz Wolfhagen