Topic
2 replies Latest Post - ‏2006-10-10T18:24:06Z by SystemAdmin
SystemAdmin
SystemAdmin
162 Posts
ACCEPTED ANSWER

Pinned topic Installing WPT for Eclipse 3.2 fails because features.xml file is incorrect?

‏2006-08-15T11:58:40Z |
Hi, I tried following your instructions on page 8 of 17 (https://www6.software.ibm.com/dw/education/i-osource3/section8.html) to install WPT on Eclipse 3.2 using

--
Help > Software Updates

Find and Install > Search for new features to install

Import sites

Select the bookmarks.xml file
--

It would install PHPEclipse and Subclipsethe, but not the Web Tools Platform because some of the reference files for WPT were incorrect.

- eclipse wst requires feature "org.eclipse.emf (2.2.0)", or equivalent.

Do you know if there is a fix for this?

I also tried by downloading WPT 1.5 and installing it locally, but got the same errors.

I finally downloaded the WPT-all-in-one and installed that then updated the PHPEclipse and Subclipse with the bookmarks.xml file which got things working.

---
Updated on 2006-10-10T18:24:06Z at 2006-10-10T18:24:06Z by SystemAdmin
  • SystemAdmin
    SystemAdmin
    162 Posts
    ACCEPTED ANSWER

    Re: Installing WPT for Eclipse 3.2 fails because features.xml file is incorrect?

    ‏2006-08-16T17:28:54Z  in response to SystemAdmin
    Hi malachy,

    Thanks for reading our tutorials.

    > Hi, I tried following your instructions on page 8 of
    > 17
    > (https://www6.software.ibm.com/dw/education/i-osource3
    > /section8.html) to install WPT on Eclipse 3.2 using
    >

    Eclipse 3.2 comes with the proper update sites for WTP so you don't need that entry in the bookmarks.xml file. Thank you for bringing this up, we'll make a note of this change in the tutorial so that future readers don't encounter this problem.

    We have also experienced issues with the Eclipse update sites not having all of the dependencies for a particular feature. Hopefully you didn't run in to that issue.

    > I finally downloaded the WPT-all-in-one and installed
    > that then updated the PHPEclipse and Subclipse with
    > the bookmarks.xml file which got things working.

    This is what we had to do when the Eclipse update sites weren't working properly. I am glad you were able to work through the problem.
    Thanks for your feedback, we are keeping an eye on what the community is saying about our work. I hope you are looking forward to the next articles in the series as they will help you exercise the Eclipse development environment you just setup.
    Stephen
    • SystemAdmin
      SystemAdmin
      162 Posts
      ACCEPTED ANSWER

      Re: Installing WPT for Eclipse 3.2 fails because features.xml file is incorrect?

      ‏2006-10-10T18:24:06Z  in response to SystemAdmin
      Hello,

      I encountered the same problem as malachy did and I downloaded the WPT-all-in-one. Then, I installed PHPEclipse and Subclipse using Help>Software Updates, etc. (not the bookmarks.xml file).

      Best regards,
      Adrian