Topic
No replies
SystemAdmin
SystemAdmin
510 Posts
ACCEPTED ANSWER

Pinned topic Installation Error

‏2006-07-26T17:14:40Z |
Hi,
I've tried installing MetaStage on 3 different machines, and I get the same error on all three when I attempt to create a new directory in the Directory Administrator. My database is DB2. I get the following error : 'Generate Schema failed for MetaBroker MetaStage10 Error Calling CREATE TABLE... Unable to allocate new pages in table space "TSLARGE"... null User is unable to CREATE TABLE in the Directory Database'.

I have created a tablespace in a bufferpool that has a 32K page size and I've granted all permissions on that tablespace to public. It doesn't seem to matter how big the container is for the tablespace, I still get this error. I've tried creating the directory by explicitly specifying the tablespace and bufferpool on the Tablespace setup page, and I've also tried leaving that page blank to let MetaStage Administrator figure out what tablespace to use. I get this error following either method. Has anyone seen this before?

Thanks, Mary